Accesibilidad

    Introducción

    Este documento está escrito para usuarios ciegos y con discapacidad visual de MuseScore 2.0. No tiene la intención de proporcionar una descripción completa de todas las características de MuseScore; deberías leer esto junto con la documentación regular de MuseScore.

    MuseScore viene con soporte para la fuente gratuita y abierta NVDA screen reader para Windows. Las características en este documento han sido probadas en Windows con NVDA. No hay soporte en este momento para otros lectores de pantalla como Jaws para Windows, o VoiceOver para macOS, que puede funcionar de manera diferente, o no funcionar en absoluto.

    En este momento, MuseScore 2.0 es accesible principalmente como lector de partituras, no tanto como un editor de partituras. Este documento se centrará en las características de lectura de partituras, con solo una breve descripción de la edición de partituras.

    Configuración inicial

    Cuando ejecuta MuseScore por primera vez, es posible que desee deshabilitar permanentemente la ventana del Centro de inicio. Para hacerlo, vaya primero a la ventana del Centro de inicio, luego al menú Editar (Alt+E), elija Preferencias, y allí, desmarque Mostrar Centro de Inicio. Guarde y cierre la ventana de preferencias.

    Encontrar su camino

    La interfaz de usuario en MuseScore funciona de manera muy parecida a otros programas de notación u otros programas orientados a documentos en general. Tiene una única ventana de documento principal en la que puede trabajar con una puntuación. MuseScore admite varias pestañas de documentos dentro de esta ventana. También es compatible con una vista de pantalla dividida para que pueda trabajar con dos documentos a la vez, y puede tener varias pestañas en cada ventana.
    Además de la ventana de puntuación, MuseScore tiene una barra de menú a la que puede acceder mediante los accesos directos para los menús individuales.:

    • Archivo: Alt+A
    • Editar: Alt+E
    • Ver: Alt+V
    • Añadir: Alt+A
    • Notas: Alt+N
    • Diseño: Alt+D
    • Estilo: Alt+S
    • Plugins: Alt+P
    • Ayuda: Alt+U

    De estos, solo el menú Archivo es de mucho interés cuando se usa MuseScore como lector de partituras. Una vez que abre un menú, puede tomar varias presiones de las teclas Arriba o Abajo antes de que todo se lea correctamente.

    También hay varias barras de herramientas, paletas y subventanas dentro de MuseScore, y puede recorrer los controles en estas usando Tab (o May+Tab para retroceder en este mismo ciclo). La primera vez que inicie MuseScore, o cargue una partitura, el foco debe estar en la ventana principal de musci. Al presionar Tab, se accede a una barra de herramientas que contiene una serie de botones para operaciones como Nuevo, Abrir, Reproducir, y así sucesivamente. Tab saltará cualquier botón que no esté activo actualmente. Los nombres y accesos directos (cuando corresponda) para estos botones deben leerse en su lector de pantalla.

    Una vez que haya pasado por los botones de la barra de herramientas, la siguiente Tab que visitará es la Paleta. Esto se usaría para agregar varios elementos a una partitura, pero actualmente no se puede acceder excepto por dos botones visitados por Tab: un menú desplegable para seleccionar entre diferentes espacios de trabajo (una disposición guardada de paletas) y un botón para crear un nuevo espacio de trabajo.

    Si ha abierto una de las ventanas opcionales, como el Inspector o el Filtro de selección, la tecla Tab también las visitará. Puede cerrar ventanas que no necesita yendo al menú Ver y asegurarse de que no se seleccione ninguna de las primeras casillas de verificación (las ventanas que aparecen antes de la configuración de Zoom). De manera predeterminada, solo se debe seleccionar el Centro de inicio, las Paletas y el Inspector. Ver [Configuración inicial]](#setup) para obtener instrucciones sobre cómo deshabilitar el Centro de inicio. F9 se puede usar para activar y desactivar las paletas, mientras que F9 activará y desactivará el Inspector.

    Para volver a enfocar la ventana de la partitura después de visitar la barra de herramientas, o una subventana, presione Esc. Esto también borra cualquier selección que haya realizado en la ventana de partituras.

    La ventana de partituras

    WhLa primera vez que inicias MuseScore 2.0, una partitura de ejemplo vacía titulada “My First Score”. Si desea experimentar con las funciones de edición, este sería un buen lugar para comenzar. De lo contrario, es probable que desee comenzar cargando una partitura. MuseScore usa los accesos directos estándar para acceder a comandos del sistema como Ctrl+O (Mac: Cmd+O) para abrir un archivo, Ctrl+S (Mac: Cmd+S) para guardar, Ctrl+W (Mac: Cmd+W) para cerrar, etc.

    Si presiona Ctrl+O (Mac: Cmd+O) para cargar una partitura, se le presenta un cuadro de diálogo de archivo bastante estándar. MuseScore puede abrir partituras en su propio formato (MSCZ o MSCX) e importar partituras en el formato estándar MusicXML, en formato MIDI, o de algunos otros programas como Guitar Pro, Capella y Band-in-a-Box. Una vez que haya cargado una partitura, se mostrará en una nueva pestaña dentro de la ventana de la partitura. Puede moverse entre las pestañas en la ventana de partituras usando Ctrl+Tab (no se aplica para Mac).

    Hay algunas cosas interesantes que puede hacer con una partitura cargada además de leerla nota por nota. Puede presionar la barra espaciadora para que MuseScore reproduzca la partitura para usted. Puede usar Archivo / Exportar para convertir a otro formato, incluidos PDF, PNG, WAV, MP3, MIDI, MusicXML, etc. Y, por supuesto, puede imprimirlo a través de Archivo/Imprimir o Ctrl+P (Mac: Cmd+P).

    Si una partitura contiene múltiples instrumentos, es posible que ya haya vinculado partes generadas. Las partes vinculadas se presentan como pestañas de parte dentro de las pestañas de partituras, pero actualmente, no hay forma de navegar por estas pestañas de parte usando el teclado. Las partes normalmente no contienen información diferente de la partitura; solo se mostrarían de manera diferente (cada parte en su propia página). Si una partitura aún no tiene partes generadas, puede hacerlo a través de Archivo/Partes, y ese cuadro de diálogo es accesible. Si desea imprimir las partes, puede evitar la posibilidad de acceder individualmente a las pestañas de partes mediante el cuadro de diálogo Archivo/Exportar partes, que exporta automáticamente archivos PDF (u otros formatos) para todas las partes en un solo paso.

    Lectura de partituras

    Cuando carga por primera vez una partitura, la ventana de partitura tiene el foco del teclado, pero no habrá nada seleccionado. El primer paso para leer un puntaje es seleccionar algo, y el lugar más natural para comenzar es con el primer elemento de la partitura. Ctrl+Inicio (Mac: Cmd+Inicio) hará esto. Probablemente también desee utilizar esto, si alguna vez borra su selección presionando Esc.

    A medida que navega entre los elementos, su lector de pantalla debe leer el nombre del elemento seleccionado (probablemente la clave al principio del pentagrama superior de su puntaje). Escuchará que lee el nombre del elemento (por ejemplo, "clave de sol") y también brinda información de posición (por ejemplo, "Compás 1, Tiempo 1, Pentagrama 1"). La cantidad de información leída actualmente no se puede personalizar, pero tratamos de ubicar la más importante primero para que pueda pasar rápidamente al siguiente elemento antes de que haya terminado de leer, o simplemente ignorar el resto de lo que se lee. Presionando May actualmente interrumpe la lectura, que también puede ser útil.

    La mayor parte de la navegación en MuseScore se centra únicamente en notas y silencios: omitirá claves, Indicaciones de compás, armaduras, barras de compás y otros elementos. Entonces, si solo usa las teclas estándar Derecha y Izquierda para moverse a través de su partitura, solo escuchará sobre notas y silencios (y los elementos unidos a ellos). Sin embargo, hay dos comandos de navegación especiales que te serán útiles para obtener un resumen más completo de la partitura:

    • Próximo elemento: Ctrl+Alt+May+Derecha (Mac: Cmd+Option+Shift+Derecha)
    • Elemento anterior: Ctrl+Alt+May+Izquierda (Mac: Cmd+Option+Shift+Izquierda

    Estos comandos incluyen claves y otros elementos que omiten los otros comandos de navegación, y también navegan a través de todas las voces dentro del pentagrama actual, mientras que otros comandos de navegación como Derecha and Izquierda solo navega a través de la voz actualmente seleccionada hasta que cambie explícitamente las voces. Por ejemplo, si tiene una negra en el tiempo 1 del compás 1, y hay dos voces en esa medida, presionar Derecha pasará a la siguiente nota de voz 1, que estará en el tiempo 2, mientras que al presionar Ctrl+Alt+May+Derecha (Mac: Cmd+Option+May+Derecha) se mantendrá en el tiempo 1 pero se moverá a la nota en la voz 2. Solo cuando hayas movido todas las notas del ritmo actual en el pentagrama actual, el atajo te llevará al siguiente tiempo. La intención es que este atajo sea útil para navegar a través de una puntuación si aún no sabes cuáles son los contenidos.

    Cuando navega hacia un elemento, su lector de pantalla debería leer información sobre él. Para notas y silencios, también leerá información sobre los elementos adjuntos a ellos, como letras, articulaciones, símbolos de acordes, etc. Por el momento, no hay forma de navegar directamente a estos elementos.
    Una nota importante: ¡Arriba y Abajo por sí mismos, con May, o con Ctrl / Cmd no son atajos útiles para la navegación! En su lugar, cambian el tono de la nota o notas seleccionadas actualmente. Tenga cuidado de no editar inadvertidamente una partitura que está tratando de leer. Arriba y Abajo solo deben usarse con Alt / Opción si tu intención es solo navegación. Vea la lista de atajos de navegación abajo.

    Avanzando o retrocediendo en el tiempo

    Los siguientes atajos son útiles para mover "horizontalmente" a través de una partitura:

    • Siguiente elemento: Ctrl+Alt+May+Derecha
    • Elemento anterior: Ctrl+Alt+May+Izquierda
    • Siguiente acorde o silencio: Derecha
    • Acorde o silencio anterior: Izquierda
    • Compás siguiente: Ctrl+Derecha
    • Compás anterior: Ctrl+Izquierda
    • Ir a compás: Ctrl+F
    • Primer elemento: Ctrl+Home
    • Último elemento: Ctrl+End

    Moverse entre notas en un punto dado en el tiempo

    • Los siguientes atajos son útiles para mover "verticalmente" a través de una partitura:

    • Próximo elemento: Ctrl+Alt+May+Derecha

    • Elemento anterior: Ctrl+Alt+May+Izquierda
    • Siguiente nota más alta en voz, voz anterior o personal anterior: Alt+Arriba
    • Siguiente nota más baja en voz, próxima voz o personal a continuación: Alt+Abajo
    • Nota superior en acorde: Ctrl+Alt+Arriba
    • Nota inferior en acorde: Ctrl+Alt+Abajo

    Los comandos Alt+Arriba y Alt+Abajo son similares a los de los comandos Ctrl+Alt+May+Derecha and Ctrl+Alt+Shift+Izquierda porque están diseñados para ayudarlo a descubrir el contenido de un puntaje No necesita saber cuántas notas hay en un acorde, cuántas voces hay en un pentagrama, o cuántas pentagramas hay en una partitura para moverse verticalmente a través del puntaje usando estos comandos.

    Lectura del puntaje de filtrado

    Es posible excluir ciertos elementos como letras o nombres de acordes al leer la partitura usando el Filtro selección (F6). Desmarca aquellos elementos que no quieras leer.

    Reproducción de partituras

    La barra Espacio sirve para iniciar y detener la reproducción. La reproducción comenzará con la nota actualmente seleccionada si se selecciona una; donde la reproducción fue detenida por última vez si no se seleccionó ninguna nota; o al comienzo de la partitura en la primera reproducción.

    MuseScore admite la reproducción en bucle para que pueda repetir una sección de una pieza con fines prácticos. Para establecer los puntos de "entrada" y "salida" para la reproducción de bucle a través del Panel de reproducción (F11):

    1. Primero, seleccione la nota en la ventana de la partitura donde debería comenzar el ciclo
    2. Ve al panel de reproducción y presiona el botón para Fijar la entrada del bucle en el posición
    3. Vuelva a la ventana de partituras, navegue hasta la nota donde desea que termine el ciclo
    4. Vuelva a cambiar al Panel de reproducción, y presione el botón para alternar la posición Fijar bucle de salida
    5. Para habilitar o deshabilitar el bucle, presione el botón para Fijar la salida del bucle en el posición

    También puede controlar la reproducción de bucle y controlar otros parámetros de reproducción, como anular el tempo básico de una partitura, utilizando el Panel Ver/Reproducir (F11).

    Edición de partituras

    Actualmente, la edición de partituras no es muy accesible: demasiados elementos de partituras requieren la intervención del mouse para colocar objetos en una partitura. Además, la referencia visual y el ajuste manual de la posición de varios elementos a veces es necesario debido al apoyo limitado de MuseScore para evitar conflictos de elementos.

    Por el contrario, MuseScore a menudo proporciona una gran cantidad de valores predeterminados y una plataforma para experimentar con los conceptos básicos de entrada de notas.
    Para ingresar al modo de ingreso de notas, primero navegue hasta el compás en la que desea ingresar notas, luego presione "N". Casi todo lo relacionado con la entrada de notas está diseñado para ser accesible mediante el teclado, y la documentación estándar debe ser útil para ayudarlo durante el proceso. Tenga en cuenta que MuseScore puede estar en la entrada de notas o en el modo normal, y no siempre estará claro en qué modo se encuentra. (Nota: a partir de la versión 2.1 hay 5 modos de entrada de notas). En caso de duda, presione Esc. Si estuvieras en modo de entrada de nota, esto te sacará. Si estuviera en modo normal, se quedará allí, aunque también perderá su selección.

    Personalización

    Puede personalizar los atajos de teclado usando Editar/Preferencias/Atajos. En algún momento, podemos proporcionar un conjunto de atajos optimizados para la accesibilidad y/o una forma de guardar y cargar conjuntos de definiciones de atajos.

    Do you still have an unanswered question? Please log in first to post your question.