Accessibilità

MuseScore è dotato di supporto per il lettore dello schermo libero e open source NVDA screen reader per Windows. Al momento non c'è supporto per gli altri lettori come Jaws per Windows, o VoiceOver per macOS.

Introduzione

Questo documento è scritto per gli utenti non vedenti e ipovedenti di MuseScore 2.0.1 Non è destinato a fornire una descrizione completa di tutte le caratteristiche di MuseScore; vi consigliamo di leggere congiuntamente la normale documentazione di MuseScore. Comunque data il continuo sviluppo di MuseScore 2.0.1 la documentazione non è ancora completa.

Questo documento si applica a qualsiasi nightly build recente (dal 1 novembre 2014). Le funzioni di accessibilità sono state introdotte con la versione Beta 1 dell'agosto 2014, ma ci sono stati un gran numero di correzioni e miglioramenti da allora, sia in materia di accessibilità che di funzionalità di base. Le funzioni in questo documento sono state testate su Windows con NVDA. Altri lettori di schermo e altri sistemi operativi possono funzionare in modo diverso, o non funzionare.

In questo momento MuseScore 2.0.1 è in gran parte accessibile come lettore di partiture, non altrettanto per la composizione delle partiture. Quindi questo documento è focalizzato sulle caratteristiche di lettura della partitura e accenna solamente alla compilazione.

Configurazione iniziale

Quando si esegue MuseScore per la prima volta, si consiglia di disabilitare in modo permanente la Finestra di Avvio. Per prima cosa chiudere la finestra di avvio, pio dal menù Modifica (Alt+E), selezionare Preferenze e deselezionare la casella Mostra finestra di avvio. Premere applica e OK e chiudere la finestra preferenze

Trovare il vostro percorso

L'interfaccia utente di MuseScore funziona come altri programmi di notazione, o altri programmi di testo in genere. Ha una sola finestra principale del documento in cui lavorare su una partitura. All'interno di questa finestra MuseScore supporta le schede multiple. Supporta anche una visione a schermo diviso per permettervi di lavorare con due documenti alla volta, e si possono avere più schede in ogni finestra.
Oltre alla finestra della partitura MuseScore ha una barra dei menù da cui è possibile accedere, tramite scorciatoie, ai sottomenù:

  • File: Alt+F
  • Modifica: Alt+E
  • Visualizza: Alt+V
  • Aggiungi: Alt+A
  • Note: Alt+N
  • Impaginazione: Alt+L
  • Stile: Alt+S
  • Plugin: Alt+P
  • Aiuto: Alt+H

Tra questi e il menù File quello di maggior interesse quando si usa MuseScore come lettore di partiture. Una volta che si apre un menù, possono essere necessarie diverse pressioni dei tasti Su o Giù prima che tutto sia letto correttamente.

Ci sono anche una serie di barre degli strumenti, tavolozze e sottofinestre all'interno MuseScore, ed è possibile scorrere ciclicamente i relativi controlli utilizzando Tab (o Maiusc+Tab per spostarsi all'indietro attraverso questo stesso ciclo). Al primo avvio di MuseScore, o all'apertura di una partitura, l'attenzione dovrebbe essere focalizzata sulla finestra della partitura. La pressione di Tab vi porta a una barra degli strumenti che contiene una serie di pulsanti per le operazioni come Nuovo, Apri, Riproduci e così via. Tab ometterà i pulsanti che non sono attualmente attivi. I nomi e le scorciatoie (se applicabili) per questi pulsanti devono essere letti da screen reader.

Dopo aver esplorato i pulsanti della barra degli strumenti la successiva finestra che Tab illustrerà è Tavolozza. Questa è utilizzata per aggiungere vari elementi alla partitura, ma attualmente non è accessibile che per due pulsanti visitati con Tab: un menu a discesa per scegliere tra le diverse aree di lavoro (un set di tavolozze salvato), e un pulsante per creare un nuova area di lavoro.

Se avete aperto una delle finestre opzionali, come l'Ispettore, o il filtro di selezione, il tasto Tab esplorerà anche questi. È possibile chiudere le finestre non necessarie dal menù Visualizza assicurandosi che siano deselezionate tutte le caselle di controllo del primo gruppo (quelle prima delle impostazioni dello zoom). Per impostazione predefinita solo la tavolozza Navigatore deve essere selezionata e non è inclusa nell'elenco del tabulatore.
Per ritornare alla finestra della partitura, dopo aver esplorato la barra degli strumenti, o una sottofinestra, premere Esc. Questo elimina anche qualsiasi selezione potreste aver fatto nella finestra della partitura.

Finestra della partitura.

Al primo avvio MuseScore 2.0.1 viene caricato di default un esempio "My First Score". Se volete sperimentare le funzionalità di modifica questo è un buon punto di partenza. In caso contrario, si può iniziare caricando un brano. MuseScore utilizza i tasti di scelta rapida standard per accedere ai comandi di sistema come Ctrl+O (Mac: Cmd+O) per aprire un file, Ctrl+S (Mac: Cmd+S) per salvare, Ctrl+W (Mac: Cmd+W) per chiudere, ecc.

Se premete Ctrl+O (Mac: Cmd+O) per caricare una partitura, viene visualizzata con una finestra di dialogo standard (attualmente fornita da Qt). MuseScore è in grado di aprire partiture nel proprio formato (MSCZ o MSCX) come di importare quelli nel formato standard MusicXML, in formato MIDI, o quelli di alcuni programmi come Guitar Pro, Capella, e Band-in-a-Box. Una volta caricato un brano esso viene visualizzato in una nuova scheda all'interno della finestra principale. È possibile spostarsi tra le schede nella finestra utilizzando Ctrl+Tab (non si applica a Mac).

Ci sono un paio di cose interessanti che si possono fare con una partitura caricata, oltre la lettura nota per nota. È possibile premere la barra spaziatrice perchè MuseScore riproduca la partitura. È possibile utilizzare File/Esporta per convertire in altri formati, tra cui PDF, PNG, WAV, MP3, MIDI, MusicXML, ecc. E, naturalmente, è possibile stampare tramite File/Stampa o Ctrl+P (Mac: Cmd+P).

Se un partitura contiene molteplici strumenti, potrebbe aver già generato le parti collegate. Le parti collegate vengono presentate come schede all'interno della finestra della partitura, ma attualmente, non c'è modo di navigare tra queste schede di parte utilizzando la tastiera. Le parti normalmente non contengono informazioni diverse dalla partitura; potrebbero solo essere visualizzate in modo diverso (ogni parte sulla propria pagina). Se la partitura non ha già generato parti, è possibile farlo attraverso File/Parti..., dalla finestra di dialogo accessibile. Se si desidera stampare le parti, è possibile aggirare l'impossibilità di accedere alle relative schede individualmente utilizzando la finestra di dialogo Esporta parti... che esporta automaticamente tutte le parti in PDF (o altri formati) in un solo passaggio.

Lettura partitura

Quando si carica un partitura, la finestra partitura è attiva, ma non ci sarà nulla di selezionato. Il primo passo per la lettura di un punteggio è selezionare qualcosa, e il punto più naturale da cui partire è il primo elemento del punteggio. Ctrl+Home (Mac: Cmd+Home) lo individuerà. Potreste aver bisogno di utilizzare questo comando qualora aveste cancellato la selezione premendo Esc.

Mentre si naviga tra gli elementi, il lettore dello schermo dovrebbe dare il nome dell'elemento selezionato (molto probabilmente la chiave all'inizio del pentagramma superiore della partitura). Si sentiranno leggere il nome dell'elemento (ad esempio, "chiave di violino") e anche le informazioni di posizione (per esempio, "Misura 1; Battito 1; Pentagramma 1"). La quantità di informazioni lette non è attualmente personalizzabile, ma abbiamo cercato di mettere il più importante al primo posto in modo da poter passare rapidamente all'elemento successivo prima di aver terminato la lettura, o semplicemente ignorare il resto di ciò che viene letto. Premere Maiusc attualmente interrompe la lettura (potrebbe essere utile).

La maggior parte della navigazione in MuseScore è incentrata solo su note e pause - si omettono chiavi, tonalità, unità di tempo, stanghette, e altri elementi. Quindi, se si utilizzano i tasti standardDestra e Sinistra per spostarsi attraverso la partitura si sentiranno solo nomi di note e pause (e gli elementi ad esse collegati). Tuttavia, ci sono due comandi di navigazione speciale che troverete utili per ottenere un riepilogo più completo della partitura:

  • Elemento successivo: Ctrl+Alt+Maiusc+Destra (Mac: Cmd+Opzioni+Maiusc+Destra)
  • Elemento precedente: Ctrl+Alt+Maiusc+Sinistra (Mac: Cmd+Opzione+Maiusc+Sinistra

Questi comandi includono chiavi e altri elementi che gli altri comandi di navigazione saltano, e si spostano attraverso tutte le voci all'interno del pentagramma attuale, mentre altri comandi di navigazione, come Destra and Sinistra navigano solo attraverso la voce attualmente selezionata finché non si modificano in modo esplicito le voci. Per esempio, se siete su una semiminima sul battito 1 della battuta 1, e ci sono due voci nella battuta, premendo il pulsante destro si passa alla nota successiva della voce 1 che sarà sul battito 2 mentre premendoCtrl+Alt+Maiusc+Destra (Mac: Cmd+Opzione+Maiusc+Destra) si rimarrà sul battito 1, ma si passerà alla nota della voce 2. Solo dopo essersi spostati attraverso tutte le note del battito e del pentagramma corrente, con la scorciatoia si passa alla battuta successiva. L'idea è che questo sia essere utile per la navigazione nella partitura, se non se ne conosce già il contenuto.

Quando si accede a un elemento il lettore di schermo dovrebbe leggere le informazioni su di esso. Per le note e le pause, leggerà anche le informazioni sugli elementi ad esse connessi, come testi, articolazioni, simboli degli accordi, ecc. Per il momento, non vi è alcun modo per accedere direttamente a questi elementi.
Una nota importante: Su e Giù da sole o associate a Maiusc, o a Ctrl / Cmd non sono scorciatoie utili per la navigazione! Viceversa cambiano l'intonazione della nota o delle note attualmente selezionate. Fate attenzione a non modificare inavvertitamente una partitura che si sta tentando di leggere. Su e Giù devono essere utilizzati con Alt/Opzione se il vostro intento è solo spostarsi. Vedere l'elenco dei tasti di scelta rapida per la navigazione sotto.

Spostamento in avanti o indietro nel tempo

Le seguenti scorciatoie sono utili per lo spostamento "orizzontale" attraverso una partitura

  • Elemento successivo: Ctrl+Alt+Maiusc+Destra
  • Elemento presedente: Ctrl+Alt+Maiusc+Sinistra
  • Accordo o pausa successiva: Destra
  • Accordo o pausa precedente: Sinistra
  • Battuta successiva: Ctrl+Destra
  • Battuta precedente: Ctrl+Sinistra
  • Vai alla battuta: Ctrl+F
  • Primo elemento: Ctrl+Home
  • Ultimo elemento: Ctrl+End

Spostamento tra le note di un battito

Le seguenti scorciatoie sono utili per lo spostamento "verticale" attraverso una partitura

  • Elemento successivo: Ctrl+Alt+Maiusc+Destra
  • Elemento presedente: Ctrl+Alt+Maiusc+Sinistra
  • Successiva nota più alta della Voce, Voce precedente, o pentagramma superiore: Alt+Su
  • Successiva nota più bassa della Voce, Voce precedente, o pentagramma inferiore:: Alt+Giù
  • Nota superiore dell'accordo: Ctrl+Alt+Su
  • Nota inferiore dell'accordo: Ctrl+Alt+Giù

I comandi Alt+Su e Alt+Giù sono simili ai comandi Ctrl+Alt+Maiusc+Destra and Ctrl+Alt+Maiusc+Sinistra in quanto sono progettati per aiutare a scoprire il contenuto di una partitura. Non hai bisogno di sapere quante note ci sono in un accordo, quante voci sono in un pentagramma o quanti sistemi ci sono in una partitura per spostarti verticalmente attraverso la partitura utilizzando questi comandi.

Filtro lettura partitura

Escludere alcuni elementi come testi, o nomi degli accordi durante la lettura della partitura è possibile utilizzando il filtro di selezione (F6). Deselezionare gli elementi che non si desidera leggere.

Riproduzione partitura

La barra spaziatrice serve sia per avviare che per interrompere la riproduzione. La riproduzione inizia con la nota attualmente selezionata, se se ne è selezionata una; dal punto in cui la riproduzione è stata interrotta la volta precedente. O all'inizio della partitura alla prima riproduzione.

MuseScore supporta la riproduzione ciclica in modo da poter ripetere una sezione di un pezzo per fare pratica. Per impostare i punti di "inizio" e "fine" ciclo per la riproduzione tramite il pannello Controlli di riproduzione (F11):

  1. Selezionare la nota da cui il ciclo deve iniziare
  2. Nel pannello Controlli di riproduzione premere il pulsante Riproduzione ciclica
  3. Dalla finestra della partitura selezionare la nota su cui la riproduzione deve terminare
  4. Passare nuovamente al pannello Controlli di riproduzione premere il pulsante "fine ciclo"
  5. Per attivare o disattivare la riproduzione ciclica premere il pulsante "Riproduzione ciclica"

È inoltre possibile controllare la riproduzioneciclica e controllare altri parametri di riproduzione, come ad esempio modificare tempo di base di un partitura, utilizzando il pannello di visualizzazione (F11)/ Controlli riproduzione.

Modifica partitura

Attualmente la modifica delle partiture non è molto accessibile - troppi elementi richiedono l'intervento del mouse in modo da inserire gli oggetti su un partitura. Inoltre è a volte necessario un riferimento visivo, e la regolazione manuale della posizione dei vari elementi, a causa del limitato supporto di MuseScore nell'evitare conflitti di elementi.

Per contro MuseScore fornisce un default ampio e una piattaforma per sperimentare con le basi dell'inserimento note.
Per attivare la modalità inserimento note in primo luogo posizionarsi sulla battuta in cui si desidera inserire le note, quindi premere il tasto "N". Quasi tutto ciò che riguarda l'inserimento note è progettato per essere accessibile dalla tastiera e la documentazione standard dovrebbe essere valida per aiutare l'utente attraverso la procedura. Tenete a mente che MuseScore può essere sia in modalità inserimento note che in modalità normale, e non sarà sempre chiaro in quale modalità ci si trova. In caso di dubbio, premere Esc. Se si è in modalità inserimento note questo la sospenderà. Se si è in modalità normale si rimarrà in questa condizione anche se si perderà la selezione.

Personalizzazione

È possibile personalizzare le scorciatoie da tastiera utilizzando Modifica/Preferenze/Scorciatoie. In alcuni punt, si possono impostare una serie di speciali tasti di scelta rapida ottimizzati per l'accessibilità e/o la possibilità di salvare e caricare gruppi di definizioni di scorciatoie.

Hai una domanda senza risposta? Inseriscila nel forum.