Nouvelles fonctionnalités de MuseScore 3.x

Mis à jour il y a 2 mois
Cette traduction est obsolète, consultez la page en Anglais pour la version actuelle: New features in MuseScore 3

MuseScore 3 comprend un certain nombre de fonctionnalités nouvelles/améliorées. Pour un bref résumé, voir les Notes de publication pour MuseScore 3. Vous trouverez plus de détails dans les résumés ci-dessous et en consultant les pages pertinentes du manuel.

Placement automatique

MuseScore place initialement les éléments dans la partition en fonction de (a) les propriétés spécifiées dans style par défaut et (b) tout ajustement manuel effectué. Cependant, pour les éléments dont le positionnement automatique est activé, MuseScore tentera d’éviter les collisions en déplaçant un ou plusieurs d’entre eux au besoin.

Voir Placement automatique.

Position par défaut

La position par défaut de la plupart des éléments est contrôlée par les paramètres dans Format → Style. Vous pouvez soit changer la valeur par défaut ici, soit le faire dans l'Inspecteur. Appliquez un réglage manuel (voir ci-dessous) puis utiliser la commande "Définir un style" (le S à droite de la valeur que vous souhaitez définir)

Les propriétés spécifiques que vous pouvez définir varient selon le type d’élément mais incluent :

  • placement (si l’élément apparaît au-dessus ou en dessous de la portée par défaut)
  • position au-dessus/dessous (positions spécifiques lorsqu’elles sont placées au-dessus ou en dessous)
  • décalage (identique à la position au-dessus/dessous, pour laquelle le placement est par défaut)
  • placement automatique Distance minimum (distance minimale par rapport aux autres éléments lorsque le placement automatique est activé)

Voir Placement automatique.

Réglages manuels

De nombreux éléments peuvent être placés au-dessus ou en dessous de la portée. Pour basculer un élément du haut vers le bas ou vice versa, utilisez le paramètre « Placement » dans l'Inspecteur, ou appuyez sur le raccourci "X".

Les réglages manuels de la position peuvent être effectués en faisant glisser ou en modifiant les parramètres du décalage dans l’inspecteur. Cependant, aucune des deux méthodes ne vous permettra de positionner un élément de manière à provoquer une collision. Pour prendre le contrôle total de la position d’un élément, vous pouvez désactiver le placement automatique pour celui-ci.

Voir Placement automatique.

Désactiver le placement automatique

Pour désactiver le placement automatique d’un élément, décochez la case "Placement automatique" dans l’Inspecteur. L’élément reviendra à sa position par défaut, et il ne sera plus pris en compte lors du placement automatique d’autres éléments.

Voir Placement automatique.

Position dans la pile (Z)

Le paramètre "Position dans la pile (Z)" dans l'Inspecteur contrôle quels éléments se chevauchent dans les cas où ils se chevauchent réellement et ne sont pas déplacés en raison du placement automatique.

Voir Placement automatique.

Formatage du Texte

Le formatage du texte est contrôlé par trois facteurs :

  • Le style de texte associé à l’élément définit les valeurs par défaut pour les propriétés telles que la police, l’alignement et le cadre.
  • Les modifications apportées à ces propriétés de texte peuvent être appliquées aux éléments sélectionnés via l’Inspecteur
  • Le formatage personnalisé peut être appliqué à des caractères spécifiques dans le texte à l’aide de la barre d’outils de texte

Voir Bases sur les textes, Styles de texte et propriétés.

Styles de Texte

Chaque élément de texte est associé à un style de texte. Le style par défaut d’un élément est déterminé par le type de l’élément lui-même - par défaut, le texte de la portée correspond au style de texte Portée, la dynamique au style de texte Dynamique, etc. Ce style de texte détermine la police par défaut, la taille, le style (gras/italique/souligné), l’alignement et les propriétés du cadre.

Vous pouvez modifier les valeurs par défaut pour n’importe lequel de ces styles de texte en utilisant Format → Style → Styles de texte. Par exemple, vous pouvez agrandir les marques de répétition ou mettre les paroles en italique. Cela affectera tous les éléments existants utilisant ce style ainsi que les éléments que vous ajouterez plus tard. Certains éléments contiennent également un ensemble limité de paramètres de style de texte dans leurs propres sections de la Format → Boîte de dialogue de style (bien que ce ne soit peut-être pas le cas dans la version finale). Les paramètres sont liés : vous pouvez modifier la taille de la police pour les numéros de mesure dans Format → Style → Numéros de mesure, ou dans Format → Style → Styles de textes : Numéros de Mesure. L’effet est le même : tous les nombres de mesure dans la partition prendront cette taille. Vous pouvez également modifier les valeurs par défaut d’un style de texte à l’aide de l’Inspecteur; voir Propriétés du Texte ci-dessous.

Pour la plupart des éléments de texte que vous créez directement (comme le texte de la portée, les marques de répétition et les paroles), vous pouvez appliquer un style de texte différent à l’aide du paramètre Style de l’Inspecteur. Cela les fera s'afficher en utilisant ce style au lieu du style "natif" pour l’élément. Par exemple, vous pouvez sélectionner un ou plusieurs éléments de texte de la portée et leur donner le style Tempo pour les forcer à s’afficher comme s’ils étaient des marques de tempo.

Voir Bases sur les textes, Styles de texte et propriétés.

Propriétés du Texte

Le style de texte contrôle les propriétés par défaut pour les éléments utilisant ce style, mais vous pouvez outrepasser n’importe laquelle de ces propriétés pour des éléments sélectionnés en utilisant l’Inspecteur. Par exemple, vous pouvez sélectionner une poignée d’éléments de texte de portée en utilisant Ctrl+click, puis utiliser l’Inspecteur pour les agrandir. Le bouton Réinitialiser au Style par Défaut situé à côté de chaque contrôle de propriété le ramène à la valeur par défaut. Vous pouvez également cliquer sur le bouton Définir un Style pour modifier le style. Donc, une autre façon de changer la taille de tous les numéros de mesure est d'en sélectionner un, changer sa taille dans l’inspecteur, puis cliquez sur Définir un Style.

Voir Bases sur les textes, Styles de texte et propriétés.

Formatage Personnalisé

Le formatage personnalisé est appliqué au texte en utilisant la barre d'outils au bas de la fenêtre principale de la même manière que dans les versions précédentes. Ainsi, vous pouvez mettre en gras un mot dans une phrase alors que le reste est normal, ou utiliser un caractère particulier, etc. Vous pouvez également supprimer tout formatage personnalisé sur les éléments de texte sélectionnés en utilisant le bouton "Supprimer le formatage personnalisé" dans l’Inspecteur. Cela remet le texte aux paramètres actuellement affichés dans l’Inspecteur.

Voir Édition des textes.

Changement de type de portée

Vous pouvez modifier différentes propriétés de la portée même au milieu de la partition, y compris la taille de la portée, formes de têtes de notes (e.g., for pitch name noteheads), generation of time signatures, and others. The staff type change element is found on the Text palette (currently, but see #278205: Move Staff Type Change to another palette (it is not text) - it may move). Add it to the measure where you want the change to occur, then use the Inspector to change properties of the staff type change element.

See Staff Type Change

Temporary and Cutaway Staves

To create a temporary staff that appears on certain systems only: first add the staff normally (Edit / Instruments), then add notes, then right-click the staff, click Staff Properties, and set "Hide when empty" to "Always". This will cause the staff to show only where needed even without needing to turn on "Hide empty staves" for the whole score (in Format / Style). The default for "Hide when empty" is "Auto", meaning the staff will be hidden when empty if "Hide empty staves" is enabled. Additional values include "Never" (the staff will not be hidden when empty even if "Hide empty staves" is enabled) and "Instrument" (for instruments containing multiple staves, the staff is hidden only if all staves for that instrument are empty).

To create a cutaway staff in which only the measures containing notes are visible (for ossia or cutaway scores, for example), right-click the staff, click Staff Properties, and enable the "Cutaway" option. This can be used independently of "Hide when empty" or "Hide empty staves".

System Dividers

System dividers are a set of short diagonal lines that are used to visually separate systems on a page. MuseScore can add these to your score automatically. In Format → Style → System, you can enable dividers on the left, right, or both, and you can set their default position. You can also adjust the position of individual dividers in your score manually or mark them invisible (this currently does not survive saving).

Staff Spacing

As part of the automatic placement in MuseScore, staves are now spaced automatically, so you can set a comfortable minimum distance and depend on MuseScore to open up more space where needed. You can use staff spacers as in MuseScore 2 to increase distance between staves, but MuseScore 3 now also provides a way to decrease it—the "fixed" staff spacer, found on the Breaks & Spacers palette. Just add the spacer and adjust its height. This will also prevent MuseScore from automatically adding more space to avoid collisions, allowing you to manage this yourself.

See Spacers.

Don't Break

Currently disabled

In addition to the system, page, and section breaks familiar from MuseScore 2, the "Breaks & Spacers" palette now contains a new "Don't Break" element. This allows you to force two measures to be kept together, for example, if there is some complex passage that spans the measures and you want to make sure they are adjacent. If both measures don't fit on a system, MuseScore moves them both to the next system. (currently, this leaves a "hole" at the end of the first staff - is this a bug or is there some purpose behind it?)

Parts from Voices

In addition to the ability to generate parts from the different instruments in your score, you can now also associate a part with a specific staff within the instrument or even a specific voice within a specific staff. This allows you to combine multiple parts (e.g., Flute 1 & 2) onto a single staff in the score while still generating separate parts.

The Parts dialog now contains two sections at the bottom, Instruments in Score and Instruments in Part. Once you have generated a part (or all parts) using the New and New All buttons, you can select any part at the top and use the controls at the bottom to control not only what instrument is in the part, but also which staves and voices within the instrument are included.

To add an instrument to a part, select it from "Instruments in Score" and press "+". To remove an instrument from a part, select it from "Instruments in Part" and press "-". To customize the part at the staff or voice level, click the arrow next to the instrument in "Instruments in Part" to expand the listing to show all staves and voices of the instrument. You can remove a staff by selecting it and pressing "-", or remove a voice by unchecking it.

Limitations: If you select only voice 1 for a given staff, then only the content in voice 1 for that staff will be included in the part. Thus, in order to share flute 1 & 2 on the same staff, you will need to enter all notes onto both voices, even in passages where they share content. You also cannot enter the two parts as chords in the passages where they share rhythms.

Explode and Implode

Explode has been updated to allow separation of voices as well as notes. See Explode.

The implode tool (Tools / Implode) works in one of two modes.

With a single staff selected, the implode command merges notes in different voices into chords where possible (when notes are on the same beat and have the same duration). This is the same as recent versions of MuseScore, although some bugs have been fixed.

With multiple staves selected, the implode command combines the content of the first four non-empty voices (on any staves) into multiple voices on the top selected staff. This is different from MuseScore 2, where notes would be combined into chords rather than using multiple voices, and thus required the rhythms to match. The MuseScore 3 approach preserves the original rhythms even where they differ, and is intended to produce the expected results when combining two different parts onto one staff for use with the parts from voices feature, or when reducing an open (four-stave) SATB score into a closed (two-stave) version. To further merge the voices into chords where possible, simply run the command again.

See Tools.

Insert mode

You can insert and delete notes and have the measure automatically expand or contract to accommodate the change. This can be useful in creating unmetered music or in ordinary editing.

To insert a note before the currently-selected note, press Ctrl+Shift while adding the note normally. For example, in note input mode, Ctrl+Shift+click will insert a note of the currently-selected duration at that location. Ctrl+Shift+B will insert a B of the currently-selected duration before the note at the current cursor position. You can also switch to Insert mode using the dropdown menu next to the note input button on the toolbar. In this mode, all notes you add act as if you were pressing Ctrl+Shift - they are inserted rather than replacing the existing notes or rests at that location.

To delete notes, you must be in normal (not note input) mode. Select either a single note or a range and press Ctrl+Del.

See Note input modes, Remove selected range (Tools)

Split/Join Measures

To split a measure before a given note, simply insert a barline from the palette at that point while holding Ctrl. For example, you can select the note, and Ctrl+double-click the barline in the palette, or Ctrl+drag the barline to the note. You can also use Tools → Measure → Split Measure Before Selected Note/Rest.

To join two measures, Ctrl+Del the barline between them. You can also use the menu command Tools → Measure → Join Measures.

See Measure operations.

Timeline

The Timeline presents a graphical overview of your score. To access it, use View →Timeline (F12). The top portion of the Timeline shows the location of tempo, key, and time signature changes as well as rehearsal marks, repeats, and double barlines. The bottom portion shows the staves of your score, with non-empty measures highlighted. You can click anywhere within this view to jump to the corresponding spot in the score.

See Timeline

Score Comparison Tool

The Score Comparison Tool (View / Score Comparison Tool) allows you to compare two versions of a score to find the differences between them. Select the two scores you want to compare and whether you want to compare the current version or the last saved version (note you can compare the current version of a score against the last saved version of the same score to see what you have changed since the last save), then click the Compare button. A list of differences will be displayed to the right. The score view will automatically change to Documents Side by Side, with the two scores you have selected displayed within. Double-click on a difference from the list and both score views will automatically pan to show you the changed element, which will also be highlighted.

Normally you would want the default Intelligent comparison, which displays the differences in human-readable format (e.g. "Measure 1: Note: property pitch changed from B4 to C5"). There is also a Raw mode to show the results according to the actual XML code.

See Score comparison.

Mixer

See Mixer.

Piano Roll Editor

See Piano roll editor (preliminary page).

Capo changes

Capo changes are now a property of staff text, and can be used to automatically change the pitch of all notes that follow them, up until another capo change.

See Capo playback.

Fretboard Diagrams

New UI. See Fretboard diagrams.

Do you still have an unanswered question? Please log in first to post your question.