Reprises, repères personnalisés.

• 25 Févr. 2021 - 17:50

Bonjour

Version 3.6.1 et 3.6.2 de MuseScore.
Il me semble qu'il y ait un problème avec les reprises, repères personnalisés.
Je les utilise dans la partition https://musescore.com/jmib/la-flamb-e-montalbanaise où elles fonctionnent parfaitement.
Mais ... Lorsque j'enregistre la partition sur mon disque (Fichier-Enregistrer) et que je la ré-ouvre plus tard, les reprises ne fonctionnent plus. Les repères personnalisés ont disparu.

Phase 1 : Etiquette personnalisée, reprise qui fonctionne à la lecture :
Capture d’écran 2021-02-25 à 18.18.19.png

Phase 2 : Après enregistrement, fermeture et ré-ouverture du fichier :
Capture d’écran 2021-02-25 à 18.20.03.png
On voit que le "Type de repère à disparu". La reprise ne fonctionne plus.

Phase 3 : Après avoir remis le type de repère à "Personnalisé", le nom de du repère redevient "Coda" :
Capture d’écran 2021-02-25 à 18.25.52.png
Et, comme il y a plusieurs repères personnalisés dans la partition, cela ne fonctionne plus.

Ci joint un squelette de partition qui, lui, fonctionne.
et ci joint la partition qui ne fonctionne pas après enregistrement/ré-ouverture.
Ou est-ce que je ne m'y prend pas comme il faut ?

Merci pour l'aide et pour vos avis.

Fichier attaché Taille
La_Flambée_Montalbanaise.mscz 41.2 KB
Maquette_Trio_Coda.mscz 16.79 KB

Commentaires

Bonsoir. Le fichier maquette fonctionne car les noms des repères correspondent exactement à ce qui est indiqué dans les sauts (mots, majuscules). Quand j'ouvre la partition complète, ça n'est pas le cas. Quand il y a une erreur MuseScore corrige par le nom qui lui semble correct ou ne suit pas la commande erronée. Je n'ai jamais utilisé la mention "repère personnalisé", j'ai toujours laissé vide dans ce cas. Je joins mon essai.

Fichier attaché Taille
La_Flambée_Montalbanaise 2.mscz 37.36 KB

En réponse à par Melis.sa

Merci Melis.sa pour la réponse.

Le fichier La_Flambée_Montalbanaise 2.mscz se comporte pareil que le mien : le type de repère "Personnalisé" a disparu et, lorsqu'on le remets en place, l'étiquette redevient "codab".

Il semble que Miré ait déjà vécu la situation et, bien que l'ayant signalé, aucune amélioration n'ait été apporté à ce propos depuis nombre de versions.

On va donc vivre avec...

En réponse à par Jean-Michel Bencetti

Le fichier 2 que j'avais modifié sans remplir le type de repère refonctionne toujours après réouverture, redémarrage, etc... Il suffit peut-être de ne pas chercher à mettre les repères en "personnalisé", ce qui n'empêche pas de renommer et le type de repères et le saut, comme vous l'avez choisi.

En réponse à par Melis.sa

Bonjour !
Dès qu'on modifie l'étiquette d'un repère c'est MuseScore, je crois, qui le place en "personnalisé". Je pense qu'il serait mieux qu'une action quelconque ne fasse pas perdre une personnalisation mais aucun écho de ce problème sur le forum anglosaxon fait qu'effectivement il faudra vivre avec.

En réponse à par Miré°

"c'est MuseScore, je crois, qui le place en "personnalisé" Il me semble que dès qu'on modifie l'étiquette d'un repère, après l'enregistrement le type de repère devient vide mais l'étiquette personnalisée reste et cela fonctionne. C'est à ce moment-là que je ne touche plus à rien. Effectivement remettre "personnalisé" remodifie l'étiquette... On peut y perdre du temps ! ☹

Do you still have an unanswered question? Please log in first to post your question.