Versions Reference

Updated 4 meses ago

    Introduction

    If it is a table and relates to versions, and which X is supported by Y, it can go here (or for existing pages, link from here). Also allows us to track the edge cases where we are de-supporting a particular OS (permanently or potentially only temporarily) and what the reason for the de-support is.

    OS versions supported, MuseScore version and Qt version that they are built against

    • Versions that are "known to work". For versions that are officially supported by these QT versions, see below
    • QT Long Term Support (LTS) version in Bold
    MuseScore version Qt Version OS Note
    1.x 4.8 Windows XP or higher, macOS 10.4, 10.6 or higher, Linux
    2.x 5.4 Windows 7 or higher, macOS 10.7 or higher, Linux Last version known to work with Windows XP and Vista, albeit unsupported
    3.x 5.9 Windows 7 or higher, macOS 10.10 or higher, Linux

    OS versions that are not supported on MuseScore

    Last supported MuseScore version First unsupported MuseScore version Qt Version OS Note
    2.3.2 3.0.0 5.4 Windows XP, Vista Windows versions not supported by QT 5.9/5.12
    2.3.2 3.0.0 5.4 macOS 10.7 - 10.9 macOS versions not supported by QT 5.9/5.12, no future plans to support.

    MuseScore version detail

    Qt versions and OS supported versions

    • QT Long Term Support (LTS) in Bold
    Qt version OS Versions Architectures Note
    5.14 Windows 7, 8.1, 10 x86 and x86_64
    5.14 macOS 10.12, 10.13, 10.14, 10.15 x86_64 and x86_64h
    5.14 Generic Linux GCC 4.8, GCC 4.9, GCC 5, GCC 6, GCC 7 x86 and x86_64
    5.12 Windows 7, 8.1, 10 x86 and x86_64 Supported until Dec 6, 2021
    5.12 macOS 10.12, 10.13, 10.14 x86_64 and x86_64h
    5.12 Generic Linux GCC 4.8, GCC 4.9, GCC 5, GCC 6, GCC 7 x86 and x86_64
    5.9 Windows 7, 8.1, 10 x86 and x86_64 Supported until May 31, 2020
    5.9 macOS 10.10, 10.11, 10.12 x86_64 and x86_64h
    5.9 Generic Linux GCC 4.8, GCC 4.9, GCC 5.3 x86 and x86_64
    5.8 Windows 7, 8.1, 10 x86 and x86_64
    5.8 macOS 10.9, 10.10, 10.11, 10.12 x86_64 and x86_64h
    5.4 Windows XP
    5.4 macOS 10.7, 10.8, 10.9, 10.10 Vista, 7, 8 32-bit and 64-bit | MuseScore 32-bit only (but an unsupported 64-bit version)
    4.8 Windows XP, Vista 32-bit
    4.8 macOS 10.6, 10.7 x86_64

    Macs and maximum macOS version

    • Sample data from MacTracker (iOS app)
    • Excludes MacBook Air, Mac Pro, Mac Mini, since the maximum macOS tend to largely correspond with the same year for all Macs released in the same year.
    • Even though macOS 10.10 is the oldest supported on Qt 5.9, macOS 10.11(.6) is the latest supported by this generation of Macs from 2007-2009.
    • The next jump in model year and max. macOS is 2010/2011 with max. macOS 10.13. Even though Qt 5.12 supports macOS 10.12, those users would have upgraded to 10.13 already.
    Year released Type Max. macOS
    2006 MacBook, MacBookPro, iMac 10.7
    2007 MacBook 10.7
    2007 MacBookPro, iMac 10.11
    2008 MacBook 10.7
    2008 MacBookPro, iMac 10.11.6
    2009 MacBook, MacBookPro, iMac 10.11.6
    2010 MacBook, MacBookPro, iMac 10.13.6
    2011 MacBook, MacBookPro, iMac 10.13.6
    2012+ MacBook Air, MacBookPro, iMac 10.15

    Windows support cycle

    Windows version Year released OS vendor supported Supported until Maximum MuseScore version
    10 2015 Yes not announced 3.x
    8.1 2013 Yes 2023-01-10 3.x
    8 2012 No 2016-01-13 3.x
    7 2009 No 2020-01-14 3.x
    Vista 2007 No 2017-04-17 2.3.2
    XP 2001 No 2014-04-08 2.3.2