Joindre le Mélangeur aux différentes palettes, il disparaît définitivement

• 26 mars 2019 - 16:15

Bonjour
MS3; J'ai voulu faire apparaître en permanence le mélangeur comme onglet à cliquer dans mes palettes au même titre que le filtre de sélection et l'inspecteur (voir image ci-dessous).

onglet melangeur.PNG

Je l'ai ouvert, je l'ai déplacé, il s'est bien positionné en onglet "Mix", je l'ai sélectionné et tout fonctionnait, il était bien à ma disposition à la demande comme l'inspecteur, la palette ou le filtre..
Mais surprise, me remettant au travail sur le même fichier, même palette, l'onglet a disparu...

Melangeur-palette.PNG

Alors que Affichage -> Mélangeur -> il est bien encore coché.
Je décoche, je recoche, j'ai perdu mon mélangeur,
Bien sûr, j'envisage dans -> préférence -> cocher -> rétablir les préférence par défaut, mais si je pouvais éviter cela.
Est-ce une anomalie de MS3, ou me suis-je fourvoyé dans une manipulation inapropriée?


Comments

Et qu'arrive-t-il en passant d'un espace de travail personnalisé (par exemple) à un autre espace de travail, Avancé ou De base? Le mélangeur ne revient-il pas?

Bonjour,
Vous ne vous etes pas fourvoyé. Je viens de le tester. La position du mélangeur n'est jamais sauvegardée
Les 3 seuls qui supportent ce mode onglet sont les Palettes, l'inspecteur, et le filtre de sélection.
Vous pouvez ouvrir une issue dans le Issue Tracker pour le signaler, ce serai bien pratique d'avoir cette fonctionalité.

En réponse à par JLWaltener

Fredipi, j'ai essayé de reproduire ce que tu as fait et ça marche. Je retrouve à chaque ouverture de n'importe quelle partition MS3 l'option "mélangeur " dans les palettes.
J'ai procédé comme suit :
1. J'ai cliqué sur le + en bas de la palette principale pour ajouter un espace de travail
2. J'ai nommé ce nouvel espace de travail "Mélangeur"
3. Il apparait donc maintenant en permanence avec les choix "de base" et "avancé"
4. Quand j'arrête MS3 et que j'ouvre une nouvelle partition ce choix "mélangeur" apparait toujours mais je dois cliquer une première fois dessus pour faire apparaitre le choix "Mixer" juste dessous.
Mixer.JPG
Mixer3.JPG
Mixer4.JPG

En réponse à par Papibois

Merci Papibois,
Je viens de retenter, je n'obtiens pas le même résultat que vous, le mélangeur disparait après avoir fermé MuseScore et réouvert.
Notez par ailleurs que le nom de la boite de dialogue du mélangeur garde son nom anglais plutot qu la traduction, ça n'a certainement rien à voir, quoique.
Testé avec la 3.0.5 et la dernière Nightly 3.1.0.6182, revision: 8920c76
Curieux que nos résultats different, à creuser.

En réponse à par JLWaltener

Ce n'est pas lié à cela, je pense. Dans tous les cas, quand on ferme MuseScore en laissant le mélangeur ouvert, même sur un second écran, MS le mémorise et le remet automatiquement à la même place à l'ouverture suivante. C'était déjà le cas avec MuseScore 2.3.2
Une piste pour expliquer nos différences dans les préférences avancées : Chez moi, la ligne "application/useSinglePalette" est décochée
Mixer7.JPG
Je précise aussi ma version et également que je suis sur Windows 10 version 1809
Mixer6.JPG

En réponse à par Papibois

Ce qui voudrai dire qu'il faut toujours laisser le mélangeur ouvert avant de quitter MuseScore.
En soi, ce n'est pas un fonctionnement normal.
"application/useSinglePalette" est décochée chez moi aussi.
De toute façon il y a un dysfonctionnement, lié à la fois au mélangeur et aux espaces de travail.

En réponse à par JLWaltener

Je ne sais pas s'il y a un lien mais quand le filtre de sélection est présent en onglet dans l'inspecteur, il n'est pas coché dans le menu affichage. Un bug différent ou un disfonctionnement plus insidieux que l'on ne pense ?
Constaté pour 2.3.2 et 3.0.5...
Mais cela ne crée pas de gêne et on vit très bien avec !

En réponse à par JLWaltener

"JLWaltener • Mar 27, 2019 - 05:09
Ce qui voudrai dire qu'il faut toujours laisser le mélangeur ouvert avant de quitter MuseScore."

Non, c'est juste un choix perso que je fais la plupart du temps. Mais quand je ne le fais pas, le mélangeur reste accessible par le menu affichage ou par F10.
Par contre comme l'a suggéré Cadiz1 dès le départ, et vous maintenant, je pense également que le problème exposé par Fredipi est lié aux espaces de travail.
Petite précision qui a peut-être son importance : Cet espace de travail "Mélangeur" que j'ai obtenu et qui se maintient à chaque ouverture est le tout premier espace de travail que je crée.

En réponse à par Papibois

C'est effectivement un choix de personalisation personnel, et c'est fait pour ça.
On s'oriente tous vers un problème d'espace de travail.
Avoir un espace personalisé est trés pratique, on peut modifer les palettes et les barres d'outils, j'utilise depuis que ça existe.
Il nous reste à attendre que nos developpeurs trouvent la solution, ils sont déja bien occupés :)

En réponse à par JLWaltener

@JLWaltener
@papibois
@Miré°
Je confirme, pour moi il disparaît, et de plus... il disparaît définitivement, je n'ai plus de mélangeur, quelque soit les palettes sélectionnées.
Et effectivement, comme le précise Miré°, le fait d'accrocher un outil dans la palette (Filtre de sélection, inspecteur...) induit qu'il ne soit plus coché dans affichage (Je découvre cette particularité)
Bon, après avoir bien lu les résultats des expériences de chacun je vais donc restaurer les paramètres et appliquer avec méthode la procédure de Papibois.

En réponse à par cadiz1

Effectivement cadiz1, c'est ce qui se passe sur mon autre ordi sur lequel je viens de tenter l'expérience.
Sur ma tour... plus de mélangeur, j'ai dû faire un truc bizarre.
Je suis sous windows 10 écran de bureau ACER
écrans en fait, ils sont tous deux allumés, rien sur l'un, rien sur l'autre

En réponse à par cadiz1

Etrange que nous arrivions à des résultats légérement différents chacuns.
Pour moi, essayé autant avec la 3.0.5 que la dérnière Nightly et Windows 7
Pas essayé avec ma machine Windows 10
OS: Windows 7 SP 1 (6.1), Arch.: x86_64, MuseScore version (64-bit): 3.0.5.5992, revision: 58dd23d
OS: Windows 7 SP 1 (6.1), Arch.: x86_64, MuseScore version (64-bit): 3.1.0.6182, revision: 8920c76
Et c'est le cas reporté dans #283258: Mixer panel (not) showing

En réponse à par fredipi

La desinstallation / réinstallation ne change pas les parametres.
Il faut vraiment restorer les parametres par défaut :
Menu: Aide -> Restaurer les parametres par défaut.
MuseScore va redemarrer et redemander la configuration.
Là on retrouve tout, sauf ce qui était déja configuré...

En réponse à par JLWaltener

@JLWaltener
J'avais bien compris, j'ai d'abord restoré les paramètres par défaut,
et je retrouve tout sauf... le mélangeur!
Donc et seulement après, je désinstalle complétement, nettoie le résiduel c'est à dire les différents dosssier Musescore3 créer dans program files (x86) et documents
et réinstalle MuseScore-3.0.5-x86_64
Et bien là, j'ai beau chercher partout, quelque soit la palette, que je coche ou non le mélangeur, c'est comme si il n'avait jamais existé?
Cela ressemble fichtrement à ce que décrit @manonash dans https://musescore.org/fr/node/283258
Je ne vais quand même pas devoir nettoyer les scories dans le registre, ça devient débile!

En réponse à par fredipi

Ah ben décidement, oui c'est crispant !
Et comme je disais à Cadiz, c'est curieux cette difference entre utilisateurs.
Aller dans le registre peut etre utile, faut etre un peu habitué.
on va tenter de faire plus simple :
Les fichiers personnels utilisateurs se trouvent en 2 endroits
- C:\Users\MonNomDeUser\Documents\MuseScore3 -> ceux là on y touche pas, il y a les parttions, etc.
- C:\Users\MonNomDeUser\AppData\Local\MuseScore\MuseScore3\workspaces -> Il faut supprimmer le dossier "Workspaces"
Relancer MuseScore, la configuration doit etre celle "De base" , normalement ça devrait fonctionner.

En réponse à par JLWaltener

merci pour l'info du AppData, je ne me souvenais plus
Je fais ce que tu me dis, ok, je relance, ok, plus de palettes perso, mais toujours plus de Mélangeur!!!!.
Donc je recommence tout
je désinstalle complet
passe CCleaner, PrivaZer free pour un bon nettoyage, supprime AppData... Musescore3
et réinstalle et après... (Je vais faire un footing pour me calmer...car je sens que je m'énerve)

En réponse à par JLWaltener

Ok, c'est enfin un retour à la normal,
j'ai carrément fait "regedit" et supprimé les lignes du registre correspondant à MS3
Réinstallation... et bonheur de voir réapparaître le mélangeur.

Avantage de cette discussion:
Je devais refaire toutes mes palettes... et bien NON, car j'ai un ordinateur portable sur lequel j'avais élaboré les mêmes palettes: 2 conclusions s'impose donc
1 - j'ai été dans C:\Users\NomDeUser\AppData\Local\MuseScore\MuseScore3 de cette autre ordinateur, mis sur une clé USB tous les fichiers spécifiques à chaque palette du type PaletteNom.workspace
et les ai déposés dans le dossier C:\Users\NomDeUser\AppData\Local\MuseScore\MuseScore3 de mon ordinateur à restaurer, et c'est bon, j'ai retrouvé mes palettes.
2 - avant de faire quoique ce soit si problème, copier ces fichiers pour les remettre en place après une réinstallation
3 - pas nécessaire de refaire ses palettes pour chaque ordinateur, il suffit de transférer d'un ordinateur sur l'autre dans C:\Users\user\AppData\Local\MuseScore\MuseScore3

En réponse à par fredipi

Eh bé ! Quel parcours du combattant ! Je comprends ton énervement.
En plus toujours pas d'explication à la différence de comportement entre chez toi et chez moi. J'ai dû avoir un sacré coup de pot, apparemment. Du coup je n'ose plus rien toucher ! Je vais laisser le mélangeur dans les palettes.

En réponse à par fredipi

Oui, sauvegarder ses fichiers .mpal, .workspaces permet de retrouver son environnement.
Pour le moment personne n'arrive à savoir pourquoi il y a des differnces, mais le pire, c'est que le développeur en charge du bug dit ne pas pouvoir reproduire le bug !!! Un comble vu le nombre de personnes qui en parlent.
En tout cas, tant que cela n'est pas résolu je ne joins pas le mélangeur aux palettes en tant qu'onglet suplémentaire.

En réponse à par JLWaltener

Pourquoi un comble? Ce n'est pas "le nombre de personnes qui en parlent" qui importe, mais qu'au moins une personne puisse fournir les étapes précises permettant de reproduire le problème à volonté et sur commande.
Alors, à partir de là, le développeur en question pourrait agir (celui-ci intervient depuis peu, et il n'est pas en charge de la question, c'est lui-même qui a pris l'initiative de "vouloir" résoudre le problème).
Mais ne pouvant pas reproduire, il n'a aucune prise/angle d'attaque pour cette question, fait du surplace et demande de l'aide.

En réponse à par cadiz1

Mais si c'est un comble voyons ! Enfin, faut arreter de se mentir. Tous les utilisateurs tentant cette configuration arrivent aux meme résultats.
Si il veut reproduire le bug, il suit pas à pas ce qu'on lui écrit.
C'est simple non ?
Si il n'y arrive pas c'est qu'il ne suit pas le step by step qu'on s'evertue à nous demander.

En réponse à par JLWaltener

Aucune mauvaise foi là-dedans.
Encore une fois, s'il demande de l'aide, c'est qu'il lui manque des clés pour le comprendre entièrement et le reproduire.
Le fait de constater que le mélangeur disparaisse après enregistrement de la partition n'est pas suffisant (puisque que personnellement, par exemple, je peux le récupérer sans aucun souci)
En revanche, le cas, sévère, de @fredipi mériterait vraiment plus ample investigation. Si j'étais lui (!), et connaissant le moyen de recouvrer le programme, je me précipiterais pour tenter de recommencer! Et de débusquer enfin le coupable principal.
Mais je peux comprendre aisément bien entendu que chat échaudé craigne l'eau froide désormais :)

En réponse à par cadiz1

Comme lui, vous devrier relire les differents rapports de bug, rejouer ce que chacun voit.
Et revenez nous dire quoi.
Ce que fredipi, comme papibois, comme tous ceux qui ont eu a subir ce bug savent trés bien ce qu'ils voient.
Je comprends qu'ils n'aient pas envie de tester en permanence, ils donnent les instructions pour reproduire, les testeurs n'ont qu'a suivre.
Je me suis preté au jeu, parce que j'ai pris un peu de temps, j'ai refait pas à pas tous les rapport de chaque utilisateur de l'issue, j'arrive au meme résultat que tout un chacun, et je ne suis pas dévelopeur, je suis utilisateur, et tous ceux rapportant ce bug utilisent MuseScore normalement.

En réponse à par JLWaltener

Un développeur veut comprendre, et pouvoir reproduire à volonté à partir d'une séquence d'étapes. Il n'y a strictement aucun plan de séquences précis dans ce rapport de bug (avec le message initial, changer de partition ne fait rien de particulier ici): #283258: Mixer panel (not) showing
Si vous en avez un, précis, reproduisible par tous et à tout coup (ou du moins sur certains systèmes ou configurations, si cela est lié?) et en quelques étapes - et je parle bien entendu de l'effet "fredipi" -, alors il ne faut surtout pas se priver de le mentionner.

En réponse à par JLWaltener

@JLWaltener
J'ai du mal à comprendre votre énervement contre les développeurs et encore plus celui contre Cadiz1 qui consacre un temps fou à essayer de venir en aide à chaque utilisateur.
De plus, vous m'incluez dans ceux qui ont subi le bug. Hors c'est juste l'inverse puisque chez moi, cette manipulation marche et n'a créé aucun dysfonctionnement. Merci d'en tenir compte.
Par contre, j'ai bien pris le temps de faire un step by step clair et j'ai joins des captures montrant bien les résultats (bons !) obtenus.
Ma démonstration pas à pas ne peut pas aider un développeur à comprendre le bug puisque je n'en ai pas.
Décrivez-la vôtre avec la précision nécessaire à sa reproduction à coup sûr parce que pour l'instant ce n'est pas le cas. Merci à vous

En réponse à par Papibois

Pas d'inquiétude, je ne suis pas enervé ni contre les dévelopeurs ni contre Cadiz qui fait un travail remarquable d'entraide, mais son insistance était un peu incongrue et déplacée, quand au developpeur, voila depuis décembre, et a tour de role qu'on nous dit ne pas savoir reproduire le bug.
Vous avez pu remarquer que le bug est trés facilement reproductible, pas de besoin d'une procédure complexe, je reste persuadé que le dévellopeur ne suit pas "pas à pas" ce que chacun décrit.
Je comprends que nous avons des differences de comportements entre nos PC.
Bug dificile certes, mais suivre, et lire, les messages des utilisateurs est le plus sur moyen d'arriver à un résultat.
En tout cas, à 3 aujourd'hui, en France nous avons reproduit aisément ce bug qui est décrit depuis quelques mois.

En réponse à par Papibois

Vraiment ? Interressant. Et pas rassurant du tout.
Donc oui je vais formaliser point à point la méthode pour reproduire le bug, d'abord en français (plus facile pour moi) et si elle est comprehensible ici je la transmettrai dans l'issue.
Pourtant il me semblait que la méthode de Fredipi était limpide, en tout cas pour moi c'est reproductible en permanence.
Mais d'abord pour partir du meme endroit et etre sur qu'on parle de la meme chose pouvez vous transmettre votre configuration:
Menu "Aide -> A propos..." cliquez sur le bouton de copie de révision et collez le ici, voici ma config
OS: Windows 7 SP 1 (6.1), Arch.: x86_64, MuseScore version (64-bit): 3.0.5.5992, revision: 58dd23d
Je ne peux tester bien sur que sous Windows 7 ou 10 pas de macos ni de linux
Je ferai les captures d'écran.

En réponse à par JLWaltener

La disparition du mélangeur peut apparaitre avec différents scénarios, mais celui montré ci dessous est facilement reproductible.

  • Version testée 3.0.5 sous Windows 7 SP1 OS: Windows 7 SP 1 (6.1), Arch.: x86_64, MuseScore version (64-bit): 3.0.5.5992, revision: 58dd23d
  • J'ai commuté la langue en US pour que les captures d'écrans soient plus parlantes pour les developpeurs

1) S'assurer que l'espace de travail est en mode Avancé

Mixer-01.png

2) Creer un espace de travail en cliquant sur le signe +

Mixer-02.png

3) Nommez le à votre convenance et cochez toutes les cases
4) Votre espace est créé et devint l'espace actif

Mixer-03.png

5) Fermez et redemarrez MuseScore
6) au redemarrage vous voyez que les parametres par défaut de l'espace on été appliqués, couleurs d'avant plan et d'arrière plan modifiés, antialiasing décoché.

Mixer-04.png

7) Reparamettrez vos couleurs, cochez la case antialiasing
8) Fermez zt redemarrez MuseScore
9) Au redemarrage ouvrez la partitionde votre choix
10) Ouvrez le mélangeur

Mixer-05.png

11) Clic gauche de souris sur la barre de titre du mélangeur pour le déplacer sur la barre des palettes, la barre de palettes devient bleu ciel, indiquant que les 2 barres d'outils seront jointes (dockés), lachez la souris, les onglets de barres d'outils apparaissent en bas

Mixer-06.png

12) Fermez et relancez MuseScore
13) Au redemarage, ouvrez une partition, vous notez que le mélangeur n'est plus joint à la palette de palettes

Mixer-07.png

14) Ouvrez le menu Affichage pour afficher le mélangeur

Mixer-08.png

Résultat : Le mélangeur ne s'affiche pas, changer d'espace de travail , supprimmer celui personalisé, redemarrer ne change rien.
Pour retrouver le mélangeur il faut restorer les parametres par défaut, au mieux, au pire, suprimer du registre les clés MuseScore.

En réponse à par JLWaltener

Bonjour à tous,
Je constate que le boulot commence tôt pour certain, voire ne cesse jamais pour d'autre.
@JLwaltener ; tu as , à priori, reproduit ce qui me semble être la manip qui m'a fait perdre le mélangeur et , comme le précise cadiz1, seul une description contrôlée du processus de mise en oeuvre de cette faille peut permettre une reproduction.
Donc j'ai l'impression que c'est bien ce que j'ai fait, avec la réserve que, ne sachant pas qu eça allait "merder" à ce point, j'ai peut être fait autre chose en plus ou en moins sans m'en souvenir (ce qui expliquerait que ce fut si ardu de retrouver mes billes).
L'effet FREDIPI ( :=) ...le début de la postérité!) effectivement mériterait que je reproduise mon problème, étape par étape comme tu le fais ( mais là je n'ai franchement pas le temps mais ne craindrai pas de le faire sachant à présent comment préserver au préalable mes palettes et raccourcis).
C'est au niveau du remède que j'ai peut-être été "non assez méthodique" (J'ai même planté ma bécane à un moment, arrêt-marche en sauvage... ce qui explique peut-être que j'ai dû passer par le registre pour un retour normal alors qu'une restauration des paramètres aurait suffit sans cet incident.
Plantage du fait de "Chrome" qui s'était bloqué sur un onglet.
Bonne journée à tous.

En réponse à par fredipi

Bonjour,
Même sans description pas à pas le problème est reproductible facilement, d'ailleurs je l'ai fait et il ne m'a pas fallu 3 heures pour voir ce qui se passe, comme je le disai à Cadiz, il suffit de lire ce que les utilisateurs écrivent, avec leurs mots certes , mais c'est pas bien compliqué.
Pour que cela soit bien compris, je l'ai mis en forme pour clarifier, et bien preciser à ceux qui ont du mal à suivre les idées des utilisateurs, le comment faire, et je repete qu'on ne fait rien de particulier, juste utiliser comme indiqué dans le Handbook.
Je viens de poster la méthode dans le issue tracker, le developpeur devrai pouvoir reproduire maintenant :)
Bonne journée.

En réponse à par JLWaltener

Merci d'avoir pris le temps de cette description détaillée.
A toutes fins utiles, je signale une différence avec ma méthode qui n'a pas provoqué la disparition du mélangeur, c'est le fait que je n'ai coché aucune des options du nouvel l'espace de travail, j'ai enregistré comme ceci :
Esp T.JPG
Je précise ma configuration : OS: Windows 10 (10.0), Arch.: x86_64, MuseScore version (64-bit): 3.0.5.5992, revision: 58dd23d

En réponse à par Papibois

Depuis le début je soupçonne un problème avec les espaces de travail, les differences de comportement entre utilisateurs viennent de là.
Merci de l'info, c'est un plus de le savoir.

La transcription est un travail de romain, 168 pages ! ça fait frémir... Déja que le temps me manque.
Mais quand je donne des partitions propres à mes amis musiciens, et qu'on les interprete ensemble , le plaisir musical est là

En réponse à par JLWaltener

Maheureusement, le patch PR 5011 a generé un autre bug impliquant la taille de la fenetre de l'inspecteur,
Le team a decidé de le retirer. le bug d'origine est de nouveau en cours de recherches.
Profitons tout de même de cette v3.1.0 qui a bien des atouts.
A suivre...

Do you still have an unanswered question? Please log in first to post your question.