Piano: comparatif MS3 et MS2 concernant les notes transférées sur l'autre portée et les liaisons associées

• 17 avr. 2019 - 16:45

Bonjour,
Je ne sais pas si le titre est significatif. Voici par 2 images je que je veux transcrire
piano exemple 1.PNG piano exemple 2.PNG
Genre de transcription que je faisais habituellement sans difficultés avec MS2.
Je travaille désormais avec MS version 3.1. Après avoir commencer le travail de transcription je le dépose sur Musescore.com (en mode "private") pour m'assurer du bon rendu...
Surprise: c'est du grand n'importe quoi...https://musescore.com/user/1630246/scores/5530284/s/LeT9Fl

Donc j'ai fait un test en utilisant MS3 puis MS2 pour le même travail. On va bien voir!
Protocole de test: avec MS3 j'ai rassemblé sur quelques mesures les difficultés à résoudre:
MS3 Portee_piano_fichier travail.png

J'ai téléchargé ce fichier sur Musescore.com, voila le résultat ci-dessous: (capture d'écran)
Site Internet Musescore - MS3.PNG

J'ai "download" ce fichier en format XML, et l'ai ouvert sur mon bureau avec le logiciel MS2
Sauvegardé, avec un nom différent sous MS2 , ci-dessous le fichier ouvert sous MS2 (mêmes difficultés que le fichier fait sous MS3 - pas de favoritisme...)

MS2 Portee_piano_fichier travail.png

Je télécharge ce nouveau fichier sur le Site Musecore.com, résultat ci-dessous (vue d'écran)
Site Internet Musescore - MS2.PNG

Applaudissement du public.... Vainqueur MS2 ( les liaisons sont reproduite à l'identique).
Et regardez bien la mesure 4, la barre entre les croches n'est même pas reproduite sous MS3.
Alors question? Est-ce une déficience liée au logiciel MS version 3
ou au traitement par le site Musescore.com des fichiers crées sous MS3?

Je sens que ça va causer.


Comments

Normalement, le bug des ligatures entre portées devrait être résolu. Pour vérification, peut-on voir la partition (ou une sélection, peu importe) en question? Et aussi un extrait/sélection pour les liaisons "égarées".

En réponse à par fredipi

Tu parles d'un comparatif entre MuseScore 2 et 3, "mais" après chargement de la partition sur musescore.com.
Comme tu peux le constater, le bug des ligatures entre portées (#280531: Beam separates from stems when crossing staves.) a été résolu, mais avec la 3.1 beta "seulement".
Franchement je ne sais pas (je ne fais jamais de comparatif avec le site musescore.com - j'utilise assez peu finalement), mais peut-être faut-il attendre la mise à jour "officielle" de la 3.1pour vérifier tout cela sur le site d'échange de partitions. Ca fonctionne sur le programme - version bêta - c'est déjà pas mal/mieux qu'avant (la 3.0.5) pour le moment.

Edit: et pour les liaisons, il s'agirait probablement de ce bug (pareil, résolu pour la 3.1): #279182: Cross-staff slurs/ties trying to avoid note on wrong staff

En réponse à par cadiz1

Je ne comprends pas tellement ton argumentaire:
Ma saisie "initiale", c'est avec la 3.1 beta, et c'est seulement après téléchargement sur le site Musescore.com, que je constate les failles.
Avec MS2, depuis longtemps je télécharge des fichiers contenant ce genre de liaison et jamais de problème.
Donc il me semble bien que sous 3.1 beta, le problème ... ( à la mise à jour "officielle" près) existe encore.
Bon, je continu donc mon travail en espérant qu'il va y avoir amélioration.
Au fait: peut-être dois-je mettre à jour régulièrement la version beta avec laquelle je travaille, ou cel est-il automatique

Et si c'est un problème lié au site Musesore.com, serait-il bon que je la précise alors sur
https://musescore.com/groups/improving-musescore-com

qu'en pense-tu?

En réponse à par fredipi

"Ma saisie "initiale", c'est avec la 3.1 beta, et c'est seulement après téléchargement sur le site Musescore.com, que je constate les failles."
Oui, c'est bien ce que j'ai compris. Le seul doute que j'ai (ou la méconnaissance surtout), c'est que j'ignore complètement s'il y a une "synchronisation" (quand/comment?) entre telle ou telle version du programme et le site d'échanges de partitions?
Et encore une fois, il faut vraiment se mettre en tête de scinder les choses. Ca fonctionne avec le programme. Ensuite, pour le "transfert", "la transition", je ne sais pas, et comme toujours, le mieux serait de poser la question/ces questions sur le groupe "Improving MuseScorecom", puisque c'est là où se situe le souci.

Edit: "Au fait: peut-être dois-je mettre à jour régulièrement la version beta avec laquelle je travaille, ou cel est-il automatique"
Je ne pense pas. Les seules mises à jour sont effectuées, par définition, dans les "nightlies"

En réponse à par fredipi

@cadiz1

Bonjour,
Après discussion sur "improving Musescore"
https://musescore.com/groups/improving-musescore-com/discuss/5038279?fr…
j'en conclus que, pour l'instant, une partition dont la finalité est d'être déposée sur le Site Musecore.com ne doit surtout pas être élaborée avec la version 3.1 beta.
J'ai transcrit ma page "test" avec MS 3.0.5, l'ai déposé sur le site et le résultat visuel est correct, il correspond à mon travail.
https://musescore.com/user/1630246/scores/5532712
Bonne journée à toi.

Do you still have an unanswered question? Please log in first to post your question.