Encore une facétie avec la 3.1 beta : réplication aléatoire de certains textes 'système'

• 20 avr. 2019 - 15:23

Bonjour
Je suis en train de compléter le travail d'un éditeur qui ne livre que de parties de tuba en Ut : le but ici est de saisir dans MS la partie Tuba en Ut pour ensuite la transposer pour contrebasse / saxhorn basse en Sib clé de fa et clé de sol. L'éditeur en question ayant fourni un matériel un peu farfelu sur les 8 première mesures qui ne comportaient aucune armure, pensant au vu du conducteur que la partie de Baryton étai aussi pour instrument en Ut, j'ai foncé tête baissée pour faire la même chose pour la baryton, ce qui explique dans le fichier ci-joint ( THE_SYMPHONIC_GERSHWIN_®.mscz ) la présence d'une ligne baryton, qui en fait ne sert à rien. Merci Belwin ! Et dire que la loi interdit de photocopier, recopier sous quelque forme que ce soit le matériel des éditeurs. Grrr... mais c'est un autre sujet !

J'en viens au problème : après avoir effectué et vérifié la saisie méticuleusement, je suis en cours de travail et je mets en forme les parties. J'avais déjà remarqué des comportements bizarres ce matin, mais je soumets ce cas qui me semble un bon exemple de dysfonctionnement déjà éprouvé (rectifié en trichant avec les textes de portée) et que je retrouverai probablement.

Cà se passe à la mesure 97 ou l'on doit faire figurer Animated et Rhapsody In Blue après le repère, comme texte de système sur le conducteur afin que ces éléments soient répercutés dans les différentes parties qui sont toutes concernées par ces indications.

A un moment, 'Rhapsody In Blue' ne figurait que sur la partie baryton, comme texte système (inspecteur faisant foi). Afin de tenter de rectifier, j'ai supprimé cette indication et je l'ai recréée toujours comme texte système sur le conducteur. Et cela reste en l'état (indication reproduite sur la partie baryton et pas sur les autres ! Je dois préciser que j'avais créé la partie de baryton en tout premier, puis j'y ai ajouté en plusieurs étapes les autres portées que j'ai placées au dessus de la ligne baryton, d'abord le tuba en Ut, puis les Tuba Bb (Contrebasse Sib) et saxhorn (Basse Sib). Bug ou boulette de ma part ?

PS : ce type de travail où en final on a 3 parties à mettre en page de la même façon, et qui est souvent à effectuer en raison des lacunes des éditeurs, justifierait à lui seul la fonctionnalité de copie de mise en forme d'une partie vers d'autres qui sont en en homo-rythmie (cf https://musescore.org/fr/node/287599 où je rêvais éveillé ;-))) A ce propos, j'ai fait ma manip sur un exemple avec Sibelius et un scénario de 'vidéo capture', comme je l'avais proposé. Il n'y plus qu'à....


Comments

Bonjour,
Ce n'est ni une facétie, ni aléatoire: c'est dû aux pauses multimesures. Désactive-les ("M") dans les parties concernées et tout le texte de système est bien là. Il figure donc sur la partie baryton, car, comme par hasard, il y a des notes à partir de la mesure 97, et non pas une pause multimesure.
Je ne sais pas encore si cela a été signalé, je vais regarder.

Bonjour
En regardant de près votre partition j'ai remarqué que vous aviez deux types de texte de portée à la mesure 97 : "Animated" qui a un formatage personnalisé et "Rhapsody In Blue" sans formatage personnalisé. Hors "Animated" apparait sur les parties exportées. J'ai donc lié dans le même texte de système "Animated" et "Rhapsody In Blue" et ainsi on retrouve bien ces deux indications dans chacune des 5 parties exportées
THE_SYMPHONIC_GERSHWIN_®.mscz
J'espère que c'est bien cela que vous désiriez.

En réponse à par Papibois

Nos constatations se sont croisées; voilà ce que j'étais en train d'écrire :
"En reprenant mon travail, j'ai voulu contourner en plaçant 'Rhapsody In Blue' à 97 comme texte de portée. Pour cela, j'ai désactivé les pauses multi-mesures et là, Le texte système apparaît... et disparaît dès que l'on réactive les pauses multi-mesures. Idem pour les autres parties sauf le baryton, qui lui, n'est pas en pause multi-mesures à ce moment. Si, je mets un texte de portée, il apparaît bien. Afin de terminer le job, je vais faire ainsi (en masquant le Texte de système dans les parties, mais ce n'est pas très académique."

J'ajoute que la pause multi-mesure est nécessaire. Je pense que ce comportement différents des texte système et portées est une anomalie.

@aPapibois, : c'est effectivement une façon de contourner, mais ce n'est pas ce que j'aurais souhaité pour être au plus près de l'original sur lequel Animated est bien en gras comme partout ailleurs pour ce type d'indication et le titre Rhapsody... en 'normal', comme partout ailleurs. Bon, je vais quand même m'en sortir, mais ce n'est pas 'élégant' ;-)

En réponse à par mikosax

"J'ajoute que la pause multi-mesure est nécessaire. Je pense que ce comportement différents des texte système et portées est une anomalie."
Bien entendu, les pauses multimesures sont nécessaires ici. Je nommais juste la cause. Et quand il y anomalie, il faut signaler sur le Issue Tracker (avec le moins de texte possible, mais en énonçant une simple séquence d'étapes clairement identifiées), et si possible avec un fichier, réalisé dans cette intention, de quelques mesures démontrant ce qui se passe.

En réponse à par mikosax

En fait sur ces mesures il y a quelquefois un mélange des 2 types de textes...
J'ai donc ré-essayé en faisant ceci : Supprimer les textes de portées (quand il en avait) et ne mettre qu'un seul texte de système.
"A little faster" mesure 52
"Animated - Rhapsody In Blue" mesure 97
"With movement" mesure 125
"A little slower" mesure 148
Il me semble que cela marche très bien partout quelque soit le type de mesure sous le texte et que les pauses multi-mesures soient activées ou pas.
THE_SYMPHONIC_GERSHWIN_®_bis.mscz

Do you still have an unanswered question? Please log in first to post your question.