Mystère pour une reprise alternative

• 14 Oct. 2020 - 23:02

Bonjour. Pour essayer les soundfonts "vocales" je reouvre une partition saisie en mai 20, utilisée encore récemment et pour laquelle je n'avais rien remarqué. Est-ce maintenant avec MS 3.5.1, 186bf15 sous Win 10 : les 1ers reprises 1et 2 fonctionnent, mais pas celles de la fin : l'alternative n'est pas vu et la mesure 1. est rejouée... J'ai essayé de resaisir les 2 dernières mesures, refaire les lignes, les barres de reprise, rien à faire, et même pour mettre la ligne d'alternative à la 2e portée elle s'attache à la 1ere... J'ai du coup reouvert le fichier en version 2.3.2 avec MS2 (je continue à les convertir à partir du fichier MS3 pour ceux qui sont encore sous Vista, ou avec une vieille tablette pas compatible) et il fonctionne comme attendu comme depuis le début... Je joins les 2 versions, si quelqu'un trouve une explication...


Commentaires

Bonjour !
En V3, supprimez les lignes de reprises de la portée inférieure ( totalement inutiles et ici perturbatrices car incomplètement placées ) et tout rentre dans l'ordre. Les lignes de reprises présentes sur la portée inférieure à la première reprise mais absentes pour la deuxième reprise "trompe" MuseScore sur l'ordonnance des répétitions.
N.B. Les lignes de reprises ne doivent être placées que sur la portée supérieure d'un système. En V2 toutes les lignes de reprises sont présentes sur la portée inférieure ce qui est accepté, MuseScore ne voyant pas de discordance d'exécution.

En réponse à par Miré°

Merci pour la réponse. Mon étonnement vient du fait que cette partition faite avec MS 3.4.1 est encore parfaitement lue sur un autre PC encore en version 3.4.2... Ce n'est qu'à l'ouverture hier avec la 3.5.1 que j'ai constaté le problème - sans que je ne sois intervenue - Et les corrections ou reprises de la portée 2 ne pouvaient plus être appliquées. Espérons que ce n'est lié qu'à cette partition et non à toutes les anciennes qui ne s'ouvriraient plus correctement ? Je joins le fichier d'origine exécutable en 3.4.2 (celui mis hier résultait de mes essais de contournement). Les alternatives de reprises juste sur la 1ere portée ne vont pas être bien lisibles quand les systèmes comportent de nombreuses portées...

Fichier attaché Taille
Liebesliederwalzer 4 -Brahms- en Fa-3.4.1.mscz 20.53 KB

En réponse à par Melis.sa

Bonjour !
Diagnostique confirmé : la présence de lignes de reprises sur les portées autres que la première d'un système perturbe les reprises.
Autre constat : avec 3.5.1 il semble qu'il ne soit plus possible de placer les lignes de reprises ailleurs que sur la première portée ( un placement sur une portée inférieure voit les ancrages de cette ligne être attachés à la première portée du système et elle se place sur cette première portée ( il y a plusieurs lignes de reprises l'une sur l'autre dans ce dernier fichier joint ). Conséquence : toutes les anciennes partitions dans lesquelles des lignes de reprises sont présentes sur les autres portées vont rencontrer un problème de lecture des reprises. Le remède est simple : supprimer les lignes de reprises des portées autres que la première.
A ce stade, les versions antérieures, y compris 3.5.0 de MuseScore, n'étant pas affectées par cette nouveauté, je ne peux définir s'il s'agit du comportement désormais "by design" de MuseScore ou d'un bug de 3.5.1. Personnellement, n'ayant jamais compris pourquoi certains trouvaient logique de placer des lignes de reprises ( inutiles, j'insiste ) sur chaque portées d'un système, ceci ( si bug ) ne me gêne aucunement.

En réponse à par Miré°

"Autre constat : avec 3.5.1 il semble qu'il ne soit plus possible de placer les lignes de reprises ailleurs que sur la première portée" : c'est ce que j'étais en train de vérifier : avec MS2 ou MS 3.4 : en sélectionnant 1 mesure sur toutes les portées du système les alternatives se posaient à chaque portée. Impossible avec la 3.5.1.
J'informe de ce pas tous les utilisateurs de mon association pour la solution pour les "anciennes" partitions pour lesquelles le problème risque donc d'apparaitre... Ceux qui le souhaitent pourront toujours rajouter la ligne sur leur version papier ! ;)

En réponse à par Miré°

Pourriez-vous joindre une partition (ou un fichier court test), montrant cela - cette question: https://musescore.org/fr/node/311737#comment-1033097 , je n'ai pas eu le temps de regarder. Et ça n'est pas clair (enfin, j'ai lu en diagonale pour l'instant), si cela concerne une partition avec parties ou pas.
En tout cas, sans approfondir, vos interventions m'ont fait penser, à tort ou à raison pour le moment, à cette "issue", découverte il y a peu: #311695: Edits to system text/tempo marking after save and reload of score do not propagate to all parts.

En réponse à par cadiz1

@Cadiz
Le comportement de la partition jointe dans les posts précédents est différent entre 3.5.0 et 3.5.1. avec ou sans parties.
Avec 3.5.0 et antérieures les reprises se font normalement qu'il y ait des lignes de reprises uniquement sur la portée supérieure ou sur chaque portée...
Avec 3.5.1 avec les lignes de reprises uniquement sur la portée supérieure les reprises se font tout à fait normalement mais avec des lignes reprises sur les autres portées la seconde reprise de la partition ne saute pas le volta 1 lors de la seconde lecture.
En créant une nouvelle partition avec 3.5.1 avec plusieurs instrument il est désormais impossible de placer une ligne de reprise ailleurs que sur la première portée.
Je m'interroge donc sur l'éventualité d'un bug ou d'un comportement désormais "normal" de MuseScore.

Les partitions créée avec 3.5.0 et antérieures, ouvertes avec 3.5.1, affichent cependant les lignes de reprises placées sur les autres portées ( qu'il n'est que possible d'ôter sans pouvoir les replacer ( sauf par annulation ))... ce qui perturbe apparemment les reprises sauf la toute première.

En réponse à par Miré°

Un certain nombre "d'issues" quant aux sauts/répétitions, ont été résolues pour cette version 3.5.1: https://github.com/musescore/MuseScore/pull/6248
Dont l'une des vôtres:
- #287447: Jump where "target" was included by previous Jump, but "end" wasn't fails
- #299320: A repeat before the Segno makes the D.S. and D.S. al coda not working as expected
- #300362: Bug "Play repeat"
- et https://musescore.org/en/node/304795

Je ne sais absolument pas si cela résout les problèmes comme attendu, ou si un (pour le moins) effet collatéral imprévu s'est immiscé dans le tableau.

En réponse à par Miré°

Effectivement le fait qu'il y ait des parties séparées dans la partition jointe est un hasard. Le problème est sur le conducteur : Que ce soit un comportement désormais "normal" de MuseScore n'est pas un problème en soit pour les nouvelles partitions qui seront faites à partir de maintenant...
Ce qui l'est par contre c'est que cette version 5.3.1 ne lise plus correctement les partitions qui s'exécutaient normalement jusque là (faites jusqu'à la version 3.5.0) c'est-à dire les fins alternatives d'un morceau s'il y en a déjà une précédente. Pour moi c'est un bug : ceux qui vont ouvrir ces partitions n'auront peut-être pas la possibilité de supprimer les lignes sur les portées autres que la première pour rendre l'exécution possible (par exemple sur appli ou en téléchargement ou ne souhaitant pas tenter autre chose que la lecture). @cadiz : j'ai regardé le lien, j'ai du mal à suivre, malgré la traduction automatique, les termes étant techniques, mais là il ne s'agit pas de problème de volta ou segno (je n'ai pas vérifié sur d'autres partitions ce qu'il en était dans ce cas, et là je manque de temps...)

Moi j'ai un problème avec un fichier sur lequel j'ai deux fois des reprises alternatives. La première fois, ça joue très bien et MuseScore fait bien la reprise alternative. Par contre, quelques système plus loin, j'ai encore une reprise alternative crée de la même façon et cette fois, le système joue la boîte 1 deux fois avant de jouer la boîte 2 et j'ai beau chercher, je ne trouve pas pourquoi. Ca m'agace vraiment. Pourquoi? Tout semble identique les deux fois, J'ai cherché dans tous les petits détails. Est-ce qun bug? Merci

Do you still have an unanswered question? Please log in first to post your question.