Copier/coller image avec MuseScore 2.0.1 = crash !

• 4 Mai 2015 - 22:47

Mes fichiers mscz issus de 1.3 comportent des images mais quand je les passe sur 2.0... problème : les images ( en général des vignettes typographiques ) ne sont plus que de hideux rectangles vides. Je les supprime donc et remet en place l'image.

L'intérêt est qu'avec 2.0 on place une image et il suffit de la copier et ensuite de la coller pour toutes les itérations éventuelles de cette image dans la partition. Utilité de ceci : se faire plaisir. Pas vraiment utile pour la musique.

Le copier/coller sur 2.0

Copier-coller 2.0.gif

Je dis bien avec 2.0 car avec la toute nouvelle 2.0.1... ça ne marche plus et même ça crash carrément.

Le copier/coller sur 2.0.1

Copier-coller 2.0.1.gif

C'est tout moi, ça ! un truc qui m'allait bien ( le copier/coller d'image ), un point fort pour moi de 2.0 ( parce que les répètes c'était pas ça ; ) et badaboum ! maintenant j'ai les répètes qui marchent pour enfin convertir mes vieux fichiers mais plus le copier/coller d'images... snif !!!

Merci pour le tuyaux de Licecap ( j'avais essayé un autre truc pour un post ( à propos des liaisons qui décalaient les portées )... et ça n'avait pas vraiment marché, il fallait double-cliquer sur l'image pour que l'animation s'affiche dans une nouvelle fenêtre de I.E.


Commentaires

Heu ! pourquoi l'animation se fait-elle correctement dans l'aperçu et ne fonctionne plus quand elle est postée ?

Edit : Si ça peut aider le plantage se manifeste à partir de la nightly "2015-05-01-1948-6000c0e". Les nightlies antérieures ne plantent pas...

En réponse à par cadiz1

Mes fichiers mscz issus de 1.3 comportent des images mais quand je les passe sur 2.0... problème : les images ( en général des vignettes typographiques ) ne sont plus que de hideux rectangles vides.

Tu as créé un rapport de bug pour ça ?

En réponse à par Nicolas

Non ! car il me semble avoir vu le sujet évoqué sur le forum anglais - mais je peux me tromper - et l'avoir même évoqué il y a déjà un certain temps ( 2.0 Beta1 ) : Que sont les pianos devenus
Comme je poussais ( par jeu ) MuseScore 1.3 dans ses derniers retranchements je ne m'affole pas quand survient un problème et je ne poste que si je n'arrive pas à le résoudre ne voyant pas ou je me suis planté.
Mais surtout, n'ayant jamais eu de problème avec les images placées dans les fichiers fait avec les nightlies, RC, Béta1, Béta2, 2.0 et nightlies précédent 2.0.1, j'ai toujours attribué le problème à 1.3. ou à ma manière de l'utiliser, donc d'un moindre intérêt à faire un rapport de bug. D'autant plus que c'est aléatoire ( jamais de problème sur la première page ) les vignettes, identiques étant soit non altérées mais déplacées, soit sous forme de rectangles vides en place ou n'importe où dans la page ( voire sur une autre page ), soit hors de la page donc invisibles ( il faut manipuler la mise en page pour s'en rendre compte )...

Tu peux te rendre compte de ceci. Visualise et télécharge ces fichiers https://musescore.com/user/44521/scores/72098
https://musescore.com/user/44521/scores/79860
et ouvre les avec 2.0.1 le résultat est édifiant... mais je pense que si bug il y a, c'est plus 1.3 que 2.0.1 mais tu es plus expert que moi pour trancher.

En réponse à par Miré

Dans les deux cas je vois les images à l'écran dans la 2.0.1. Si tu peux faire un fichier très simple avec une image dans MuseScore 1.3, et à l'ouverture dans 2.0, l'image n'est pas affiché. C'est un bug. Avec le fichier, on doit pouvoir le corriger.

En réponse à par Nicolas

Petit aparté: en vous voyant parler de la 2.0.1, j'ai dû rater un épisode... Je viens de la télécharger, pas de souci, mais depuis quand est-elle disponible?
La sortie des Betas 1 et 2, de la R.C, puis de la 2.0 avait été annoncée sur le forum anglais (forum "Discussion générale"). Je n'ai rien vu de tel pour la mise à jour 2.0.1, enfin pour l'intant. Qu'ai-je oublié, ou pas vu? Merci.

En réponse à par Miré

Eh oui, hélas, ça s'est joué à quelques minutes ou petites heures près... J'ai fait le rapport de bug dès que je l'ai vu, à 1h30 du mat... ou de la nuit... Je ne pouvais décemment pas faire plus. C'est un peu rageant, mais c'est ainsi...:(

En réponse à par cadiz1

A Lasconic : Tu vois les images à l'écran ? Moi je n'en vois que quelques unes. La mise en page est dévastée mais c'est assez logique les unités utilisées n'étant pas les mêmes. Dans les 2 fichiers de MuseScore.com il y a des vignettes verticales en fin des toccata et des fugues et des vignettes avec le titre du morceau et surtout une figure neumatique ( le quilisma ) qui n'apparaissent plus.

MuseScore 1.3 : Toccatas et fugues page 1
Toccatas et fugues-1.3 page 1.png

MuseScore 2.0.1 : Toccatas et fugues page 1
Toccatas et fugues-2.0.1 page 1.png
Toccatas et fugues-2.0.1 page 1a.png

La page est éclatée en 2 mais on s'y attendait... et les couleurs du texte de titre sont inversées.

MuseScore 1.3 : Toccatas et fugues page 2
Toccatas et fugues-1.3 page 2.png

MuseScore 2.0.1 : Toccatas et fugues page 2
Toccatas et fugues-2.0.1 page 2.png

La vignette est visible mais pas vraiment où attendue...

MuseScore 1.3 : Toccatas et fugues page 6
Toccatas et fugues-1.3 page 6.png

Là j'ai bien indiqué des images auxquelles ont ne prête pas attention...

MuseScore 2.0.1 : Toccatas et fugues page 6
Toccatas et fugues-2.0.1 page 6.png

Que sont-elles devenues ici ?

MuseScore 1.3 : Toccatas et fugues page 9
Toccatas et fugues-1.3 page 9.png

MuseScore 2.0.1 : Toccatas et fugues page 9
Toccatas et fugues-2.0.1 page 9.png

Ici curieusement la vignette verticale est présente mais la vignette de début est un rectangle vide.

Tout ceci est ce que je vois quand je passe de 1.3 à 2.0 et suivantes. Et l'analyse plus complète du fichier montre que des vignettes ne sont plus apparentes ni telles qu'elles ni sous forme de rectangle vide ( elles sont hors de la page ). Pour l'instant je tiens à ce qu'on soit d'accord sur le visuel sinon c'est qu'il y a problème chez moi.

En réponse à par Miré

Quelle est la différence entre les images de la page 1 et de la page 2? (à part le fait qu'elles sont sur la page 1 et la page 2 :)

Tu peux créer un fichier encore plus petit avec le problème? Juste une image? Plus le fichier est petit, plus c'est facile de trouver la cause.

En réponse à par cadiz1

Après multiple essais et tests j'ai réussi à produire le phénomène à volonté. Accrochez-vous car c'est un peu accrobatique entre 1.3 et 2.0.1. Je joins le fichier de base ( fait avec 1.3 ) et les 3 images ( quelconques n'importe qu'elles autres donneraient le même résultat ).

test images 2.mscz

Ouvrir MuseScore 1.3
Créer une partition avec au moins 2 pages
Insérer un cadre vertical en début de partition en 1ère page
Ajouter un cadre vertical en 2ème page
Placer une image dans le cadre de la 1ère page
Enregistrer le fichier et le laisser ouvert...
( Ceci est déjà fait dans le fichier joint )

Ouvrir MuseScore 2.0.1
Y ouvrir le fichier...
Résultat obtenu et attendu : identité d'aspect avec 1.3
Fermer le fichier...

Revenir à 1.3
Ajouter une image n'importe où sur la page 1
Enregistrer...

Passer à 2.0.1
Y ouvrir le fichier
Résultat attendu et obtenu : identitéd'aspect avec 1.3
fermer le fichier...

Revenir à 1.3
Ajouter une image en page 2
Enregistrer...

Repasser à 2.0.1
Y ouvrir à nouveau le fichier
Résultat obtenu : page 1 toujours identité d'aspect
page 2 l'image n'est que représentée par un rectangle vide
Fermer le fichier...

Dans 1.3 supprimer une image de la page 1 et enregistrer

Ouvrir le fichier dans 2.0.1
Etrange : l'image de la page 2 qui était altérée précédemment est maintenant conforme.

Dans 1.3 à nouveau replacer une image en page 1 et enregistrer

Ouvrir le fichier dans 2.0.1
Re-étrange : l'image en page 2 reste conforme mais maintenant c'est l'image ajoutée précédemment en page 1 qui n'est plus visible que comme un rectangle vide...

Refait et re-refait X fois... c'est systématique il semble que l'ordre dans lequel on entre les images à une importance. Il semble que des vignettes monochromes placées dans un cadre ( dans 1.3 ) résistent au rectangle vide... mais pas toujours. Là je n'ai pas encore pu systématiser le phénomène.
Un artefact curieux, car cela ne se produit que quelques fois et seulement à l'affichage de 2.0.1 : une image otée du fichier 1.3 apparaît, quand on ouvre ce fichier avec 2.0.1, en lieu et place de l'image dans le cadre de 1ère page... Ce n'est qu'un affichage que j'ai rencontré parfois au cours des essais : il suffit de fermer 2.0.1 ( sans sauvegarder ), de le relancer et d'y ouvrir à nouveau le fichier et tout rentre dans l'ordre ( :|... je reste perplexe

Fichier attaché Taille
La dernière Aube 0.png 43.56 KB
Fleur de rose.png 30.83 KB
oiseau 1.png 37.27 KB

Do you still have an unanswered question? Please log in first to post your question.