Is tie creation broken?

• Sep 25, 2012 - 17:20

I've noticed that I can no longer tie notes using nightly build ba582c2 on either Mac or Windows. I've not tried to go back to earlier builds yet and can't remember how far back I lasted tied notes. Is this a known problem? Does anyone know how far back I'd need to go to get a version which works?


Comments

I haven't had any problems creating ties in any build I've tried. How are you trying to do it (step by step)? From note entry mode, press "7 C 6 +" - you should get whole C, tied to half note C. Do you see something different? I'm using a build I did myself two days ago.

In reply to by Marc Sabatella

Thanks for the reply.

That's interesting. I am seeing something different.

I would not normally enter the tie when in note entry mode. I have been selecting the first of two consecutive notes of the same pitch and pressing "+" to no effect.

Trying in note entry mode I see the following:

1. enter note entry mode on a newly created (blank) score
2. press "7" - I see the note length in the palette change from the default minim to a semi-breve
3. press "C" and a C semi-breve is entered in the staff
4. press "6" and the note length in the palette changes to minim (all as expected up to this point)
5. press "+" and nothing happens. I see no visible change in either the score or the palettes.

In reply to by brod

What about if you use the actual icon for creating ties? The "+" shortcut still works for me, but I see that it is no longer listed under edit / preferences / shortcuts (used to be listed as "Tie"). SO many it comes down to whether you have an old preferences file lying around or something like that?

Anyhow, it does appear something has changed, although I don't know when that happened or if it was deliberate. But I would assume the icon would still work.

In reply to by Nicolas

I just built from the latest sources (I think) and saw the same thing I reported earlier: it *does* work, but "Tie" is now missing from the list of customizable shortcuts. It appears "+" still *works* to do a tie, and it continued to do so after as full a revert to factory settings as I know to do (wiping out MuseScore and MuseScoreDevelopment folder from both Local and Roaming under AppData then running mscore -F). So maybe it's just been hardcoded now? But if I try to assign "+" to do something else, it has no effect. MuseScore doesn't complain the shortcut is already in use when I try to define it to do something else, and it appears I have successfully assigned it to do that other thing, but press "+" continues to add ties. So *something* is definitely amiss with t he handling of "+".

In reply to by Marc Sabatella

I've not been able to get on line for a few days but have done some testing and don't understand the results.

I had a look at the preferences to see if the "+" was assigned and it was. I should say I have never added or removed shortcuts myself and set preferences back to default to test some new functionality a couple of weeks ago so I know everything is default. After closing the preferences dialog, using "+" to add ties was working again.

I tried the same on Windows, first checking to see if the shortcut worked (it didn't) then checking in preferences to find it listed. After closing preferences it works again. I have no idea why this fixed the problem nor what went wrong in the first place. When I upgrade I do just overwrite the previous version rather than do a clean install so I suppose it could have been some sort of conflict which was resolved when preferences were re-saved but I can't be sure. I've not upgraded since I first came across the problem and starting this thread.

In reply to by brod

OK, I now see that the command *does* exist in the shortcuts list, but it has been changed from simply "Tie" to "Note duration: tie". And the shortcut is listed as simply "+" whereas on my keyboard, "+" is accessed with the shift key (it's above "="), so when I try to assign "+" to some other key, what actually shows up is "Shift++", which is why no conflict is detected and why "+" still has the effect of adding a tie.

So, I'd still say something is up with this.

In reply to by Jojo-Schmitz

I would assume (or at least hope) that MuseScore has been coded to use a "+" regardless of where it's mapped.

For those with a number pad you're right, there's a one key option but of course laptops don't have them and I believe Apple don't ship what they now refer to as an "extended keyboard" as standard. Having only Japanese keyboards that leaves me with a shift key combination only.

Do you still have an unanswered question? Please log in first to post your question.