no playback on Kubuntu

• 9 years ago

I just installed "mscore" on Kubuntu using Adept Manager. I got version 0.9.1 (perhaps you need to update the repository...?).

It starts up OK and I created a score with a piano track. However, there is no audio playback. There is no play button and Display-->Play Panel is greyed out.

Can anyone help me out? Is something missing from the installation?

One thing I should point out, Adept finished downloading all the dependencies but then it hung during installation and when I killed it my computer crashed.


Comments

I thought of running it from the command line and I got these messages as it started up.

/usr/bin/mscore: 27: list: not found
Using JACK for audio
fluidsynth: error: Unable to open file "/usr/share/sounds/sf2/FluidR3_GM.sf2"
fluidsynth: error: Couldn't load soundfont file
fluidsynth: error: Failed to load SoundFont "/usr/share/sounds/sf2/FluidR3_GM.sf2"
ISynth: Failed to load SoundFont "/usr/share/sounds/sf2/FluidR3_GM.sf2"Synti init failed
sequencer init failed
Couldn't resolve property: 2

Does that give any clue as to how to fix it?

In reply to by Thomas

I tried installing fluidsynth plus sound files (they're big, had to do it overnight) and playback started working now. There are still some problems, however.

1. I still get some errors on startup, Do I need to do anything about this?

/usr/bin/mscore: 27: list: not found
Using JACK for audio
fluidsynth: warning: Failed to pin the sample data to RAM; swapping is possible.
Couldn't resolve property: 2

2. I tried to open some midi files and some of them opened fine but some crashed mscore. I think what they have in common is that they have embedded lyrics. Any midi file with embedded lyrics crashes mscore with the following message:

separate channel for 8 tracks
Segmentation fault

Is this feature supported? Is there anything I can try?

3. Playback of the other midi files happens but the relative volume of the instruments does not seem right. Some instruments drown out others. When I used to play the same midi files on Windows Media Player they sounded OK. Help, anyone please!!

In reply to by Raichu

You can help to make a better midi import for mscore by preparing a short test file which shows an bug. I'm collecting such files for debugging and regression testing.

MScore is not a good midi player because the imported midi is heavily modified (aligned and quantized etc.). In the current version the articulation is completley lost (velocity).
For a future version i'm working on this to retain as much information as possible from a midi file by transforming it to score notation.

Sorry if this is a little off topic, but since MuseScore won't play midi files properly, I tried installing kmid as it purports to be a midi player. It appears to go through the motions of processing midi files but no sound comes out. There is no error message.

Does anyone know what I might be doing wrong?

Do you still have an unanswered question? Please log in first to post your question.