D.S. saute les cages de reprises

• 21 Janv. 2020 - 12:44

Bonjour à tous, je suis sur la dernière version actuelle de Musescore (v 3.3.4.9066), et j'ai un soucis au niveau d'un signe de renvoie.

Quand le lecteur (je sais pas si on appelle ça comme ça :D ) arrive au D.S., il retourne au signe de renvoie (jusque là tout est normal). Cependant quand il rejoue la partie que je lui ai indiqué il saute les cages de reprise (1. ; 2. ; ...) pour passer à la suite, alors que j'ai précisé dans l'inspecteur de jouer les reprises.
J'ai fait une partition test en recréant le même style de partition, et je me suis rendu compte que le lecteur n'aime pas les cages de reprise avec des blanches pointées :D (ma partition est en 3/4).
Auriez-vous une solution pour qu'il lise correctement la partition en rejouant la partie indiqué par le signe de renvoie, tout en effectuant les reprises.

Je vous ai mis à disposition le fichier test qui se lit correctement si les cages de reprises contiennent des noires (par exemple), mais sont oubliées lors du renvoie avec le D.S.

Merci !

Fichier attaché Taille
test.mscz 16.04 KB

Commentaires

Le renvoi D.S. ne peut comprendre comment gérer les lignes de reprises qui ont la même numération et considère qu'étant déjà exécutées il les saute et ce n'est pas un disfonctionnement ni un bug car c'est la structure de la reprise qui l'impose. La bonne manière est celle-ci :
 
Reprises spéciales.png
 
N.B. vous remarquerez que 2 tournures de D.S. peuvent renvoyez sans problème au même segno et
les "cages de reprise" s'appellent "lignes de reprise" ou encore "Voltas"
 
Reprises spéciales.mscz

En réponse à par Miré°

Merci pour votre réponse rapide !

Je vois d'où vient le problème, cependant je ne comprend pas pourquoi ma partition se lit correctement (sans sauter les lignes de reprises) si les voltas sont constituées de noires (par exemple) et qu'elle sont sautées si ces dernières sont constituées de blanches pointées...

En réponse à par L'accordéonist…

Noires ou blanches j'ai le même fonctionnement en revanche le fait de faire "rejouer les reprises" dans cette configuration fait buguer MuseScore ( une corruption ? car même en décochant l'anomalie persiste ). Supprimer le D.S. et le replacer ( sans cocher "jouer le reprises" ) et lancer la lecture, logiquement les reprises doivent se faire normalement, ce qui me laisse perplexe car j'avais signalé que cette structure ne fonctionnait pas ( d'où mon post précédent ) ce qui sous entend qu'avec MuseScore 3 cela a été corrigé... mais qu'il reste encore un truc.

Edit Donc le bug signalé lors des tests au tant de 2.2.0 a été corrigé mais curieusement lorsqu'on coche "jouer les reprises"... il revient et les blanches ou les noires n'ont rien à voir avec ce disfonctionnement.
Je m'occupe de faire un rapport de bug, juste le temps de trouver comment m'exprimer clairement de manière concise pour expliquer le problème.

En réponse à par gipi14

Quelques info complémentaires et surprenantes:
en fait quand j'ai écrit 'cela fonctionne' c'etait avec votre ficher attaché dans le rapport de bug , et dans lequel vous aviez supprimé ce qui précédait le 'segno' .
J'ai voulu essayer la même astuce du +1 dans le fichier complet , et là retour du saut des reprises au second passage, SAUF si on supprime la toute première reprise, celle du premier système, qui ne semblait à priri être en dehors du problème du D.C.
Voila c'etait juste pour info !

En réponse à par Miré°

Merci j'ai lu le rapport et la réponse à ce dernier, j'ai suivi ce qu'il a conseillé de faire (du moins je pense avoir bien traduit : j'ai coché "jouer les reprises" au D.S., j'ai cliqué sur le bouton "retour au début" et j'ai joué le morceau, mais ça a quand même sauté les mesures

P.S. : Ce qui est dit ci-dessus a été fait avec ma partition originale sans avoir modifié les voltas par des codas comme vous avez fait.

En réponse à par L'accordéonist…

La version réduite faisait disparaître l'anomalie après avoir cliquer le retour en début... mais le fichier original fait reconnaître le bug. La balle est dans le camp des programmeurs.

EDIT
Un contournement du bug a été trouvé : bug repeats 2.mscz
Sur la mesure où est le D.S. placer un saut de section dont la durée a été réglée à 0 et les 2 cases décochées. ( clic droit sur le saut pour accéder à ses propriétés ).

En réponse à par Miré°

Pour l'heure, il n'y a pas eu de rapport de bug proprement dit (qui doit se faire dans le Issue Tracker pour avoir quelques chances d'être vu et traité par les développeurs). C'était peut-être prévu?
Actuellement, en effet, c'est un fil comme un autre dans le forum international - et même s'il se trouve dans la section 'Support and bugs reports' - qui sera bien vite noyé dans quelques heures dans le flot d'autres messages.

En réponse à par cadiz1

Prévu ? pas vraiment... mais avant un vrai rapport de bug je voulais savoir si le problème a été rencontré sur le forum anglais. Pour l'instant j'ai la confirmation d'un bug et comment le contourner... me reste à rédiger le rapport clairement sur issue tracker, c'est la que ça coince un peu pour moi car être clair et concis dans la langue de Shakespeare m'est problèmatique d'autant plus que le bug est vicieux à expliquer puisque présent seulement s'il est précédé d'une autre reprise adajacente ce que je n'avais pas perçu et avais bêtement supprimé cette reprise dans le 1er exemple du post en question.
Autre problème mais technique : mon portable sous Win10 en panne semble revenir de réparation sous garantie de la planète Mars par omnibus, j'use donc de mon très vieux clou sous Vista avec des navigateurs obsolètes qu'il n'est plus possible d'ugrader et c'est galère de se connecter et de le rester ( je rédige mon texte avec le bloc-note, le copie et le colle dans la fenêtre de commentaire et suis heureux si pas systématiquement déconnecté quand je clique sur "Enregister" ).

En réponse à par Miré°

" me reste à rédiger le rapport clairement sur issue tracker, c'est la que ça coince un peu pour moi car être clair et concis dans la langue de Shakespeare m'est problèmatique d'autant plus que le bug est vicieux à expliquer"

Un titre et un simple lien du fil du forum, mais donc figurant dans le Issue Tracker, cela suffit - sinon ce bug tombera dans les oubliettes très rapidement et pour longtemps probablement. Il est possible/ probable aussi que @jeetee (celui qui a été en charge de ces questions pour MuseScore - en tout cas, des dernières améliorations) relancera le sujet sur cette page du Issue Tracker, avec gain de visibilité donc.

Do you still have an unanswered question? Please log in first to post your question.