Nuove funzionalità in MuseScore 3.6

Aggiornato 6 mesi fa

    Nuove caratteristiche di configurazione e impaginazione della partitura

    MuseScore 3.6 introduce un nuovo font musicale, Leland, un nuovo font di testo predefinito, Edwin (una versione di New Century Schoolbook), e molte nuove impostazioni predefinite. Introduce anche una serie di nuove caratteristiche che sono disponibili di default in tutte le nuove partiture create, e che possono anche essere applicate automaticamente o manualmente alle partiture esistenti.

    Le tre caratteristiche principali, che sono collegate tra loro, sono:

    • Ordinamento automatico degli strumenti
    • Parentesi quadrate (brackets) e graffe (braces) automatiche
    • Giustificazione verticale dei pentagrammi

    Le prime due caratteristiche si applicano al momento della creazione della partitura e sono disponibili nella “Procedura guidata nuova partitura”, sebbene possano essere accessibili anche in seguito nel pannello Strumenti. In precedenza, spettava all'utente organizzare gli strumenti e aggiungere le parentesi manualmente una volta creata la partitura. Lo scopo di queste nuove caratteristiche è quello di risparmiare tempo e dare un miglior risultato di default nella maggior parte dei casi, ma non è inteso a soddisfare ogni possibile configurazione della partitura. Per impaginazioni insolite i risultati possono essere personalizzati dopo che la partitura è stata creata, le caratteristiche possono essere disattivate completamente, o si può usare un modello.

    Ordinamento automatico degli strumenti

    Dialog: Procedura guidata nuova partitura / Aggiunta Strumenti

    Quando si crea una nuova partitura tramite "Scegli strumenti", è presente ora un menù a tendina “Ordinamento” che mostra il sistema attuale di ordinamento degli strumenti. "Orchestrale" è il predefinito. Man mano che gli strumenti vengono aggiunti alla partitura, saranno collocati nella posizione corretta secondo l'ordine selezionato. (In precedenza, ogni strumento appariva sotto a quello attualmente selezionato nella lista di destra). Questo rende anche facile, per esempio, aggiungere una doppia sezione di fiati, selezionando Flauto, Oboe, Clarinetto e Fagotto nella lista di sinistra, e cliccando due volte su “Aggiungi alla partitura”.

    Ogni ordinamento definisce una posizione nella partitura per gli strumenti solisti. Per esempio, in un ordinamento orchestrale, questi sono sopra gli archi. Con uno strumento selezionato nella lista di destra, il pulsante “Rendi solista” lo sposterà in quella posizione. Si possono designare più solisti; all'interno della 'sezione' del solista verrà applicato l'ordine generale. Gli strumenti solisti avranno "solo" aggiunto al loro nome per impostazione predefinita, e saranno numerati separatamente dagli strumenti non solisti, dove necessario. Notare che la designazione del solista è solo una funzione di impaginazione della partitura e non ha alcun impatto sulla riproduzione sonora.

    Una stranezza è che, per ora, solo una singola posizione di solista è definita per ordinamento, quindi un'opera con un coro più solisti sia vocali che strumentali metterà i solisti strumentali sopra il coro. Questi dovranno essere spostati manualmente.

    Come prima, gli strumenti possono essere spostati su e giù manualmente con i pulsanti che si trovano ora a destra della lista. Se si operano spostamenti, nel menù a tendina del campo “Ordine” comparirà “(Personalizzato)” aggiunto al nome già presente (ad esempio, in caso di aggiunta strumenti con “Ordine: Orchestrale”, spostando su o giù uno strumento rispetto alla posizione assegnata, il campo “Ordine” del menù a tendina diventerà “Orchestrale (Personalizzato)”. L'ordinamento personalizzato viene salvato con la partitura. È possibile ripristinare l'ordine selezionando l'ordine originale (o uno diverso) dal menù a tendina.

    Selezionando direttamente l’ordine “Personalizzato” questa funzionalità viene completamente disabilitata, analogamente all’assegnazione automatica delle parentesi di raggruppamento pentagrammi/famiglie (capitolo successivo).

    Parentesi quadrate e graffe

    Gli ordinamenti predefiniti associano famiglie di strumenti (flauti, oboi, clarinetti, ecc.) e dispongono queste famiglie in sezioni (fiati, ottoni, percussioni, ecc.). Le parentesi vengono aggiunte automaticamente secondo queste semplici regole:

    • Una “parentesi spessa” (heavy bracket = quadra grossa) è applicata a tutti gli strumenti adiacenti della stessa sezione, supponendo che ve ne sia più di una
    • una “parentesi quadrata sottile” (thin square bracket) è applicata a tutti gli strumenti identici adiacenti (quattro corni, per esempio)
    • una parentesi graffa (curly brace) è applicata a ogni singolo strumento che è annotato su più di un pentagramma (pianoforte e arpa, più comunemente)

    In aggiunta, mentre questo dovrebbe fornire ordinamenti predefiniti ragionevoli per la maggior parte delle partiture, non darà risultati perfetti per ogni possibile stile o disposizione. Fortunatamente, è facile fare aggiustamenti una volta che lo spartito è stato creato.

    Giustificazione verticale dei pentagrammi

    È stato aggiunto un nuovo algoritmo per giustificare verticalmente i pentagrammi al fine di riempire correttamente la pagina, attivato di default per le nuove partiture in MuseScore 3.6. Per disattivarlo, deselezionare Formato > Stile > Pagina > Abilita la giustificazione verticale dei pentagrammi.

    Finestra dialogo: Modifica Stile / Pagina

    Il principio di base dell'algoritmo è quello di cercare di rendere uguale lo spazio tra i pentagrammi, soggetto a due impostazioni (tutte in Formato > Stile > Pagina):

    • Lo spazio ai lati (superiore e inferiore: trattasi di allineamento verticale) di una accollatura può essere aumentato proporzionalmente regolando l'impostazione "Fattore per la distanza sopra/sotto la parentesi quadra (bracket)" ad un valore maggiore di 1. Per esempio, se questo è impostato a 1,5, l'algoritmo tenterà di rendere lo spazio ai lati di una parentesi 1,5 lo spazio 'standard' usato altrove (space used elsewhere).
    • La stessa cosa può essere applicata alla graffa con l’impostazione del " Fattore per la distanza sopra/sotto la parentesi graffa (brace)".

    Lo spazio tra una parentesi graffa (brace) e una quadra (bracket) sarà determinato dal più grande di questi due valori. L'impostazione " Massima distanza doppio pentagramma " è usata per limitare l’ammontare della distanza tra pentagrammi uniti da una parentesi graffa (curly brace). Ciò è utile perché questi pentagrammi generalmente devono essere letti in una sola volta con un solo sguardo del musicista.

    La "Massima distanza tra accollature" e la "Massima distanza pentagrammi" dovrebbero avere valori ragionevolmente grandi per permettere all'algoritmo di riempire anche pagine piuttosto scarse. A volte una pagina non avrà abbastanza pentagrammi perché abbia senso giustificare. In questo caso, prima l’algoritmo equalizza lo spazio come sopra descritto, poi aggiunge spazio extra fra i pentagrammi fino al massimo pari all’impostazione data in "Massima distanza di riempimento della pagina" (moltiplicato per ogni impostazione di fattore applicabile). Se si trova che molte pagine non sono completamente giustificate, ma si vorrebbe che lo fossero, provare a regolare questa impostazione. In generale, un valore basso è probabilmente il migliore per una partitura con un piccolo numero di pentagrammi per accollatura, e uno più grande per un numero maggiore di pentagrammi.

    La giustificazione verticale è dinamica, e non è legata alle assegnazioni di sezione degli strumenti usate per determinare l'ordine della partitura in fase di impostazione, quindi se si aggiungono o si rimuovono parentesi la spaziatura cambierà di conseguenza. Allo stesso modo, se i pentagrammi vuoti sono nascosti in una data accollatura, la spaziatura sarà determinata solo dalle parentesi che sono effettivamente presenti in quella accollatura.

    Si spera che le impostazioni di default diano buoni risultati nella maggior parte dei casi, ma potrebbe essere necessaria un po' di sperimentazione con le impostazioni a seconda della composizione di una partitura. Se si ha l’abitudine di usare i distanziatori per ottenere risultati simili, è meglio cercare di trovare le impostazioni che danno un buon risultato per la maggior parte della partitura, e usare i distanziatori solo dove sono necessari aggiustamenti locali. È previsto per le versioni future di rendere questo più configurabile. Per esempio, lo spazio extra potrebbe essere soppresso per una specifica parentesi, o il valore potrebbe essere aumentato o diminuito per una particolare pagina o accollatura.

    Indentazione (rientro) della prima accollatura

    Questa nuova opzione, che è attivata di default, si trova in Stile > Partitura > Abilita l’indentazione sulla prima accollatura. Come suggerisce il nome, farà rientrare la prima accollatura di una sezione nel modo consueto per le partiture classiche. (Il vecchio artificio di usare una cornice per questo scopo non è più necessario.) Se sono presenti etichette di strumenti, si applica il massimo tra il valore dato per questa impostazione e la lunghezza delle etichette.

    Applicare nuove caratteristiche a spartiti esistenti

    Quando si apre una vecchia partitura, una finestra di dialogo dà la possibilità di applicare o il nuovo font di notazione Leland, o il nuovo font di testo Edwin, o entrambi. Ognuno di questi applica - oltre ai soli cambiamenti di font - un sottoinsieme di nuove impostazioni di stile preimpostate per la 3.6, per esempio la larghezza delle linee e le dimensioni del testo, ma non applica tutte le nuove impostazioni di default, allo scopo di minimizzare cambiamenti di impaginazione dirompenti.

    Finestra Dialogo: Importazione

    Per applicare tutte le nuove impostazioni predefinite, comprese queste modifiche ai caratteri di testo e di notazione, aprire la finestra Formato > Stile e cliccare sul pulsante in basso "Ripristina tutti gli stili ai valori predefiniti". Questa era in precedenza l'opzione di menu Formato > Ripristina Stile. Il pulsante si comporta allo stesso modo, eccetto che non resetta più le opzioni di impaginazione che sono impostate nella finestra Formato > Impostazioni di pagina; quella finestra ora ha il suo pulsante equivalente, che resetterà solo quelle impostazioni che contiene. Ciò significa che le nuove opzioni di stile possono essere provate senza rovinare completamente l’impaginazione della partitura, anche se alcune impostazioni di Partitura e Pagina della finestra Stile potrebbero dover essere reimpostate manualmente.

    Se c'è l'opzione, cancellare qualsiasi interruzione di sistema e di pagina non essenziale, selezionare l'intero spartito poi Formato > Larghezza > Ripristina larghezza impaginazione. Eliminare anche i distanziatori per vedere i risultati di default del nuovo algoritmo di giustificazione verticale (vedi sotto).

    Edwin ha dimensioni dei caratteri più ampie in generale rispetto a FreeSerif (anche se vengono usate dimensioni dei punti di default leggermente più piccole) quindi è abbastanza probabile che l'opzione Edwin causerà cambiamenti di impaginazione, in particolare nelle partiture con testi cantati. Leland influenzerà la spaziatura in modo meno radicale, ma alcuni aggiustamenti potrebbero essere ancora necessari.

    Gli elementi di testo che hanno locali sovrapposizioni di stile applicate, non subiranno alcuna rimozione per quelle personalizzazioni, sia come parte del processo di migrazione della partitura, sia tramite le opzioni di Ripristino Stili. Questo potrebbe portare al risultato di una partitura incoerente nella quale alcuni testi mantengono il loro vecchio carattere o non ne variano la dimensione. La nuova opzione del menu Formato > Ripristina lo stile del testo sovrascrivi rimuoverà queste personalizzazioni, ripristinando tutti gli elementi di testo in modo che corrispondano agli stili di testo attualmente definiti. (Questo equivale a cliccare su “Ripristina lo stile predefinito” per ogni attributo nell'area Testo dell'Ispettore). Notare che questo non rimuove la Formattazione personalizzata, operazione che deve essere fatta manualmente se necessaria.

    Applicazione nuovo automatismo di ordinamento strumenti e corretta applicazione parentesi

    Premere “I” per accedere al pannello Strumenti, oppure scegliere la voce di menù Modifica > Strumenti. Assumendo che la partitura sia stata creata con versione precedente la 3.6, l'ordinamento selezionato sarà “Personalizzato”. Se si vuole applicare un ordinamento standard, selezionane uno dal menu, per esempio “orchestra”. Gli strumenti nella partitura saranno riordinati secondo quella definizione, e le parentesi quadre e graffe saranno applicate di conseguenza. Notare che qualsiasi parentesi quadra e/o graffa esistente sarà cancellata.

    Applicazione della giustificazione verticale dei pentagrammi

    Se si vuole usare questa funzione ma erano stati collocati in precedenza nella partitura dei distanziatori per creare distanze extra o fisse tra i pentagrammi, è meglio prima cancellarli tutti, poiché distorcerebbero il funzionamento del nuovo algoritmo. Un modo veloce per farlo è cliccare con il tasto destro del mouse su qualsiasi distanziatore, scegliere Seleziona > Tuti gli elementi simili e premere Canc.

    Per attivare questa funzione selezionare Stile > Pagina > Abilita la giustificazione verticale dei pentagrammi. Successivamente possono essere reintrodotti i distanziatori se ci sono posti specifici dove la spaziatura predefinita ha bisogno di essere regolata.

    Altre modifiche tipografiche in 3.6

    Nel processo di investigazione delle impostazioni di stile, dei problemi di incisione e creazione di un nuovo font musicale, sono stati scoperti molti problemi che dovevano essere corretti e che possono avere un piccolo impatto sull'aspetto degli spartiti esistenti. In alcuni casi è possibile annullarli manualmente

    Spaziatura travature (Beam spacing)

    Un errore di vecchia data nell'interpretazione dell'impostazione spaziatura travature che è definita insieme ai font SMuFL ha fatto sì che questo valore fosse spesso la metà di quello che dovrebbe essere in MuseScore, anche con Emmentaler e Bravura. (MuseScore definisce la distanza tra le travature come una percentuale dello spessore di una travatura, ma per SMuFL l'impostazione è una distanza assoluta in spazi di pentagramma. Lo spessore normale di una travatura è 0,5sp, e la distanza standard tra le travature è anch'essa 0,25sp, che MuseScore interpreta come il 25% di 0,5sp, cioè 0,125sp).

    La nuova interpretazione corretta di questo valore, 50%, sarà applicata anche alle partiture esistenti, a meno che questo valore non sia stato esplicitamente sovrascritto. Lo spazio extra viene aggiunto verso l'interno, quindi la posizione delle travature più esterne rimane la stessa. Se si vuole davvero la vecchia spaziatura molto stretta, impostare manualmente Stile > Gruppi di note > Distanza tra travature al 25%.

    Prima (distanza travature 25%):
    Travature (prima)
    Dopo (distanza travature 50%):
    Travature (dopo)

    Lunghezza del taglio addizionale (Ledger line)

    In modo simile, MuseScore interpretava questo valore SMuFL come l'estensione totale della linea di taglio addizionale oltre la testa della nota (cioè x/2 ad ogni lato), quando il valore dovrebbe essere l'estensione ad ogni lato. Questo errore è stato anche mascherato dall'uso di un “coperchio quadrato” (square cap) per la linea, piuttosto che un “coperchio dritto” (straight cap), aggiungendo così anche la metà dello spessore della linea ad ogni estremità.

    Come per la spaziatura delle travature, se questa impostazione non è stata esplicitamente sovrascritta nel file, verrà applicato un nuovo default anche nelle vecchie partiture, ma questo darà risultati identici. Se questo valore è stato regolato sarà conservato, ma produrrà tagli addizionali troppo lunghi. Si può convertire il valore manualmente con la formula:

    nuovo valore = (x / 2) - (y / 2)

    dove x è il precedente valore di “Lunghezza taglio addizionale” e y è il valore di “Spessore taglio addizionale”. Oppure, usare semplicemente le impostazioni predefinite ora correttamente interpretate per ogni carattere:

    • Leland: 0.35sp
    • Bravura, Gonville, Petaluma: 0.40sp
    • Emmentaler: 0.38sp

    “Attacchi” dei gambi e posizioni delle codette (Stem caps and flag positions)

    “Round caps” (?) erano precedentemente disegnati sui gambi. Questo è stato sostituito da un “flat cap” (?). In parte questo è per rendere la lunghezza del gambo più esatta, ma principalmente è così che il “round cap” non oscura il disegno della punta dei simboli della codetta in ogni carattere. Le codette di Emmentaler, per esempio, sono disegnate con una punta piatta; Bravura e Leland hanno punte arrotondate che non sono esattamente simmetriche.

    Il posizionamento delle codette era anche in precedenza in contrasto con i font SMuFL: veniva fatto un calcolo di quanto estendere il gambo per un dato numero di codette, e poi il simbolo della codetta veniva disegnato con la parte superiore o inferiore del suo riquadro di delimitazione alla fine del gambo. Ora, la presenza di codette non influisce sulla lunghezza del gambo (cioè un gambo di lunghezza normale è usato per una nota in funzione della sua posizione verticale e della direzione del gambo stesso) e il simbolo della codetta è quindi posizionato con la sua y=0 alla fine del gambo. Qualsiasi "estensione" del gambo è quindi determinata dalla misura in cui il simbolo della codetta si estende al di sopra o al di sotto di y=0. Le codette in Emmentaler, come usate all'interno di MuseScore, sono state riposizionate per riflettere questo, e per corrispondere ad altri font SMuFL.

    Il risultato di ciò è che le codette possono apparire leggermente più basse o più alte di come apparivano in precedenza; tuttavia, il loro posizionamento riflette ora le intenzioni dei designer di ciascuno dei font disponibili. Le note con travatura non sono interessate.

    Prima (Bravura, in 3.5):
    Codette (prima)

    Dopo (Bravura, in 3.6):
    Codette (dopo)

    Parentesi di alterazioni

    In precedenza MuseScore non aggiungeva alcuno spazio tra le caselle di delimitazione delle alterazioni e le parentesi attorno ad esse. Ora viene aggiunta una piccola quantità di spazio, che può essere personalizzata tramite Stile > Accidenti > Riempimento tra le parentesi.

    Prima (Bravura, in 3.5):
    Alterazioni fra parentesi (prima)

    Dopo (Bravura, in 3.6):
    Alterazioni fra parentesi (dopo)

    Alterazioni in Emmentaler

    Queste sono state sostituite con quelle prese da Parnassus. Per dettagli, vedere PR #6747.

    Hai ancora una domanda senza risposta? Effettua l'accesso per prima cosa per porre la tua domanda.