No PPA for Ubuntu 17.04

• Jul 13, 2017 - 18:06
Reported version
S5 - Suggestion
won't fix

There is no build for Ubuntu 17.04.

$ cat /etc/lsb-release

$ sudo apt update
Err:9 zesty Release
404 Not Found
Reading package lists... Done
E: The repository ' zesty Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.


I'm the maintainer. It's tricky building an Ubuntu package for 2.1 because it requires Qt 5.4, but Ubuntu 17.04 provides Qt 5.7. You can usually get away with using a later library version, but not in this case because Qt WebKit was depreciated in Qt 5.5 and removed altogether in Qt 5.6.

I recommend you use the AppImage.

In reply to by shoogle

Hi shoogle

I would love to help with maintaining the PPA, if you could teach me how.

The AppImage integrates very badly with Linux desktop environments, with things like Compose Keys and Copy-and-pasting either not working, or not working properly.

In reply to by etienne

Hi etienne-snyman,

If the AppImage isn't behaving properly then that's a bug that should be fixed. You could also try the MuseScore Snap or Flatpack packages to see if they integrate better with your system.

Nevertheless, it would be nice to get the PPA up and running again. I'm glad you are keen to do this, but this is actually quite tricky. If you like you could create an account on Launchpad and try to get this working in your own PPA. If you manage it then I would copy what you've done into the MuseScore PPA, or consider adding you to the team to do the same.

For your information, building Debian packages is actually pretty complicated - there are pages and pages of documentation to read. Fortunately you're only modifying an existing package, not starting from scratch, and we're not as fussy about what goes in the PPA as Debian are about what goes in their package archive. In theory, you only need to bundle MuseScore with a different version of Qt...

However, that's where things become very difficult. The Debian packaging system (and hence also the Ubuntu/Launchpad packaging system) is specifically designed to only allow you to build against one version of a library - the version that's already in the archive. For example, Qt 5.6 is in the Ubuntu 17.04 repos and it's very difficult to build against any other Qt version. If you were building MuseScore on your own machine you could install any Qt version straight from the Qt website and build against that, but Launchpad only allows you to build against packages already in the archive, or other PPAs.

This means that if you want to build against a specific Qt version you first have to build a Qt package for that version yourself and host it in a PPA. You also need to modify and rename the Qt package so that installing it wouldn't affect whatever Qt package the person already has installed on their system. (Someone has done this to allow later Qt versions to be installed on old Ubuntus, but as far as I am aware nobody has packaged an older Qt for recent Ubuntus, which is what we need in this case.)

And that's all without considering people's sensibilities:

  1. Debian et al would prefer people didn't take deliberate steps to bypass their packaging system.
  2. The MuseScore core development team would prefer MuseScore to be build against upstream libraries rather than distribution libraries (which tend to be modified and behave slightly differently to the upstream versions).

So basically Linux packaging is all a big mess right now ;)

I highly recommend that we concentrate efforts into getting the AppImages to play nicely with different desktop environments, but as I say, if you (or anybody) manages to get MuseScore building in a PPA on Launchpad then I am happy to take a look at it and consider updating the main PPA.

In reply to by shoogle

Status (old) active won't fix
Status active won't fix

I’m the new maintainer. I’ve added a build for 17.10, but at that point, 17.04 was so EOL already that I was unable to provide a package for it.

I absolutely urge you to upgrade to the next supported release (18.04 LTS).

If you can’t, you should be able to install the packages for 16.04 on 17.04 but note that they include a backported Qt, which may impact other Qt5 applications on your system.