Windows build, QT required for 2.1 vs 3.0

• Apr 2, 2017 - 04:15

I wanted to build Musescore on windows to attempt some changes, but am struggling.

I followed the compile instructions, which call for QT 5.8, and then pulled the latest source and it built. But it built 3.0, which I don't think is ready enough for use.

So I checked out 2.1 and built, and have been trying combinations for a couple hours, and I think it just doesn't work. With Build WebKit selected, it fails because 5.8 doesn't have QWebView (it's no longer supported). With Build Webkit not selected it fails missing MyNetworkAccessManager which is related to not compiling with Webkit (I can't quite see how startcenter can ever build without the pragma set for QWebKit).

Does this mean that 2.1 requires 5.6 but not later, which had QWebKit?

Most writeups I see talk about "5.6 or later". But maybe later won't work?


I'm not an active Musescore developer, but 2.0.3 wouldn't build for me with Qt 5.8 either regarding QWebKit. It may be worth attempting a multi-version setup of Qt on your system if you want to compile the previous versions. This might be helpful: Otherwise, hopefully an active developer will respond to your post. Maybe see it as an opportunity for an attempted conversion from the QWebKit code to QWebEngine (assuming it's possible) with the aid of the online Qt documentation as practice for sharpening some skillz . . .

In reply to by Jojo-Schmitz

You are exactly correct, and I somehow went right past that. I think the problem is I originally built it on Linux, but was building it for different reasons. The linux pages (specifically…) read a bit differently, emphasizing a need for either 5.6 or 5.8, but doesn't speak to which version of Musescore.

Mea culpa. Thank you for the quick response.

To further clarify; 3.0/master is indeed not ready for everyday use; lots and lots of incompatible changes going on there, because the layouting has been redesigned from the ground up.

If your only goal is to start using 2.1, you can just download a pre-built version for your operating system at Make sure you are actually downloading 2.1 then and not master.

About versions: what Jojo said.

In reply to by jeetee

Thanks, I have run both nightlies, and understand that difference; I am trying to build so I can change the tool's midi output to test an idea.

That does beg a question however -- when 3.0 is "done", will the 2.1 created files format approximately the same? Right now the slurs in particular go from being over or under a couple notes to running clear across the page. I assume that's just bugs being worked.

In reply to by Ferguson

3.0 is intended to have greatly improved formatting, in particular automatic resolution of some conflicts (overlapping elements, etc). So for example, slurs in 2.1 will happily cross notes, but 3.0 has code to automatically modify slurs to avoid notes. Everything in 3.0 is of course a work in progress. Way to early to say, but my guess would be, slurs that are left in their default state in 2.1 will be able to take advantage of the improvements, slurs that were manually adjusted in 2.1 would hopefully keep their same shape in 3.0. Realistically, though, I could easily imagine manually adjusted slurs just looking bad when loaded into 2.1 as the adjustments might be calculated relative to the new defaults, so we might just throw away the manual adjustments and trust the new defaults to eliminate the need for the manual adjustment. That's more or less what we did with a bunch of things that were improved from 1.3 to 2.0.

Do you still have an unanswered question? Please log in first to post your question.