Playback halts temporarily (MS3 beta 2bxxxxx)

• Dec 10, 2018 - 14:09

In attached score, playback halted for a number of seconds at the indicated position. Then it resumed again.

For completeness: I had just added a fermata with extended duration in measure 27, that probably had nothing to do with it. I also mention that I had added and then removed a 2s caesura in that same measure.

I noticed the same happening shortly before, this occurrence I did not capture. I think it was in a different spot.

I observe similar behaviour when I press Command-S during playback. Apparently the program suspends playback during the operation. During the incidents, I had not touched any key, but perhaps the program was doing something (autosave?) that kept it busy.

Schermafdruk 2018-12-10 14.43.41.png

OS: macOS 10.14, Arch.: x86_64, MuseScore version (64-bit): 3.0.0.19686, revision: 2b25396

Attachment Size
Silent_night.mscz 20.87 KB

Comments

I don't see this problem on OS: Windows 10 (10.0), Arch.: x86_64, MuseScore version (64-bit): 3.0.0.4370, revision: 29165bb, so my first guess is that it is related to auto save. If this was a one time thing I would make that assumption. If it happens every time, I have no explanation except that fermatas were reported to cause some problems in #279296: Stretched-fermata timing mishandled in 3.0 Beta.

There have been several reports of "random" pauses or sputters during playback by various users. It seems there are an unusually large percentage of Mac users making these reports, but I don't have to tools to prove this. I keep auto save turned off and never experience this, even on my old machine.

I don't know if this will help you, but it my help someone else who can fix it if it's a problem.

In reply to by jeroen2442

The problem happens at the 1:15 point in the score, so I suspect you have auto save set to 2 minutes, which is the default. I don't know how obvious the auto save is on your computer, but I'd be curious if you started the score from the top as soon as the auto save kicked in if it would stutter around measure 56, which is about 2 minutes into the song. To assure auto save will kick in, edit the score by doing something like selecting a random note and press the up followed by the down arrow. I don't think auto save is active on clean scores.

In reply to by mike320

I was able to reproduce the problem, in a somewhat different way.
At first I did as you suggested. Changed some notes, started replay. Replay lasted the whole piece, without problem. Autosave was at the default 2 min.
I then set autosave to 1 minute, changed a note and started replay again. It went well for a while. But in the middle, around measure 25 I think, replay suddenly jumped ahead to measure 34, where it stayed still for a long time (in my estimate, at least 10 s, maybe more). Just as I was about to end the program, replay resumed.

The reason that I am not sure about the measure where replay jumped is that I was not prepared for it, but I am almost certain that this is what happened. Unfortunately, the behaviour is erratic and not easily reproduced.

I have replayed a number of times after this, but no further incidents occurred. Based on this, I now doubt that it is necessarily related to autosave. In any case, not every autosave seems to lead to the behaviour.

OS: macOS 10.14, Arch.: x86_64, MuseScore version (64-bit): 3.0.0.19686, revision: 2b25396

Schermafdruk 2018-12-10 21.12.02.png

Attachment Size
Silent_night.mscz 20.83 KB

In reply to by mike320

Unless autosave would sometimes be skipped for whatever reason... Just a thought , based on no factual knowledge whatsoever, except that in software development nothing is to be taken for granted. And the theory looked very plausible. Especially because of the issue mentioned by Laurelin above, citing exactly similar symptoms while saving by hand during playback.

In reply to by mike320

I can now confirm that autosave is at least involved.

As I understand it, on the Mac the folder ~/Library/Application Support/MuseScore/MuseScore3 is where autosave files are kept.
With this folder open in Finder, I started MuseScore, loaded a score, changed a note, and started replay. As luck would have it, after some time replay halted for a while. Exactly at the same moment a new file appeared in the folder. It is too much for me to believe this to be a coincidence.

In reply to by jeroen2442

That leads to a couple of questions.

First of which is why did it not happen the first time I asked you to test it? The score is longer than the 2 minutes for auto save.

Does auto save only work on dirty (edited) score?

Did you have a different set of scores open when you saw it than when you didn't? As auxiliary questions: Was the auto save score you saw the score you are testing or was it another score you had open at the same time. If you had more than one score open why did it only auto save one?

These questions exist for me because I don't look at the program, perhaps someone with the proper skills can look into these questions in the code.

In reply to by mike320

Those are good developer debugging questions - finding out why exactly the program is glitching is how you spend 90% of your time as a developer. And you should ask on the issue tracker, it might trigger recognition from someone with experience with the code base, who will then know where to look for the glitch and find it.

Finding it is way harder than fixing it, always. Luckily, it's also kinda fun, most of the time.

Maybe of you set the autosave to 15 sec so you didn't need to wait, kept the window with the auto save files where you could see it, and did your absolute best to make it glitch you could see the pattern?
Half of programming is 'What the heck is that' + Google. The other half is doing your best to break whatever you built.

In reply to by mike320

  • Why did it not happen the first time I tested?

Because autosave can happen without interrupting replay. I tested this: started MS3, loaded score, changed some notes, started playback while watching autosave folder. Autosave set to 1 min. After a minute or so, autosave happened but no pause in playback.

  • Does auto save only work in dirty score?

I think it does. I tested with a score that I replayed very slowly to as to have a lot of uninterrupted playback time. During 20 or so minutes no autosave occurred.

  • Do you have different sets of scores open?

During testing: No, except for the default empty "Untitled" that remains when I close the start window.

Auxiliary questions:

  • Do not apply, no other working score open except "Untitled" (untouched).

In reply to by jeroen2442

I have some final information that might help.

I did the same run: start MS3, load score, changed note, playback while watching autosave folder.

I ran it twice. First time, after a while autosave occurred, no delay noted in playback. Second time, when autosave kicked in, replay halted temporarily. The runs were identical, except I did not restart the program in between.

One difference was that in the first run the size of the autosave file was 8 kb, the second time it was 24 kb. I have no explanation for that and it seems odd to me since the scores saved were identical and changes made were minimal.

I have repeated the experiment one more time, with identical result.

I now firmly conclude that:

  • when delay occurs, it is triggered by autosave
  • autosave alone does not trigger delay, some other unknown condition must also be present
  • there may be an issue with the size of the autosave file.

OS: macOS 10.14, Arch.: x86_64, MuseScore version (64-bit): 3.0.0.19686, revision: 2b25396

Attachment Size
Silent_night.mscz 19.79 KB

Do you still have an unanswered question? Please log in first to post your question.