Musescore 2.0.2 not starting on Windows 10

• Jou 29, 2015 - 12:05

Hi friends!

From one day to the other Musescore wasn't starting anymore. It shows up in the task manager, but that's it. I tried to reset to factory settings including the parameters -s and -w too. I tried all sorts of compatibility adjustments down to XP, No success :-(

Is there anything left I could try???

Now I'm using MS 1.3 again...

Thanks a lot!
Cheers,
Thomas


Comments

Have you moved it off screen? Or were using 2 Screens, move it to the secondry and now are using only one?
Or have you been a victim of some Windows update that conficts with MuseScore, ISTR to have seen reports mentioning this.

In reply to by Jojo-Schmitz

Hi Jojo-Schmitz!

Thx for your reply! No, haven't used two screens here. Probably a Windows Update, but on Win 10 you have no real choice...

Hope a future update will solve this issue. I don't want to try to restore some past before-update Windows situations. Wouldn't make sense to me.

Cheers,
Thomas

I'm also running MuseScore 2.0.2 on Windows 10. See screenshot.

So...
#1. If MuseScore shows up in the task manager, what do you see when you click on the carat next to MuseScore in the task manager - any open files, like MuseScore: My_First_Score?
#2. Do you see the MuseScore icon in the taskbar, and when you roll the mouse over the MuseScore icon, does it show any score thumbnails?

Task_manager.png

Regards.

In reply to by Jm6stringer

Yes, it's there. I already tried this before. I see the repair dialogue, and when I try to start MS 2 after that, I get the same behaviour. Mouse arrow shows loading activity for around 20 seconds - no splash screen, musescore.exe shows up in the task manager under background processes. That's all...

Cheers,
Thomas

In reply to by sedminek

Since repair doesn't work, have you tried to uninstall, and then re-install MuseScore?

Perhaps it is a permissions/UAC issue. You can also try:
1. Navigate to the MuseScore installation folder [Program Files (x86) -> MuseScore2 -> bin] and then right click on MuseScore.exe and select 'Run as administrator'.

2. Disable UAC (user account control) in Control Panel -> User Accounts -> Change User Account Control settings - then move the slider down.

Regards.

Thanks a lot for all the advices, but unfortunately none of them worked! I still have a MuseScore 2.0.2 running on my Win 7 office PC. Hopefully this problem can be solved in the near future. I quite sure this had to do with a Windows update, as MuseScore was running for several months on my Win 10 PC without problems.

Cheers,
Thomas

In reply to by sedminek

@sedminek:
From the log file, the initialization freezes after loading the fonts, before showing the information for the screen.
In that region of the code -a- some Qprinter properties are set and then -b- we have a "qmlRegisterType" instruction (related to the plugin framework).
Regarding those two points:
a- Do you have a printer installed?
b- Can you try with the unsupported "noSSE2" version (in which the plugin framework is disabled)?
(found here: https://musescore.org/en/download#Unsupported-versions-of-Windows you need 7zip to extract the archive)

In reply to by ABL

Hi ABL!

Thank you for your advices! Actually there is no printer installed. What is installed is:

MS Print to PDF
MS XPS Document Writer
Nitro PDF Creator

I tried the version without SSE2, but it shows the exact same behaviour :-(

Cheers,
Thomas

No, it's a Dell Inspiron AIO. MS 2.0.2 was already running on it, even after the upgrade to WIN10. It happened from one day to the other, that it didn't want to start. But it was running on WIN10 for at least 4 months without any issue!

In reply to by sedminek

Thank you for the log file.
The exact point where MuseScore hangs is here:
line 4809 of musescore.cpp
QSizeF psf = QPrinter().paperSize(QPrinter::Inch);
i.e. when the code is creating a QPrinter and retrieving the default page size.

I think you can try to change the default printer among those installed and see if this changes something. Or you can try to install another printer, maybe a dummy printer, and set it as the default one.

Ciao,
ABL

Thank you all very much! Finally it works again. All I did was changing the default printer. It was automatically set to Nitro PDF. When I set the Microsoft PDF Export as the default printer MuseScore 2.0.2 was starting like before.

So again thank you very much - I never thought it could actually be that easy to make it run again.

Cheers,
Thomas

Dear all!

Thank you again for all your contribution to solve this problem for me!!! The software, that obviously caused the error, is Nitro Pro 10 (10.5.2.11).

Cheers,
Thomas

In reply to by sedminek

Can I just stress, I faced this problem to, and it's a problem with your default printer setting as opposed to the software specifically. I know because I had the exact same problem replicated, with my default printer as a cloud printing service. As soon as i changed it it was okay!

In reply to by Jojo-Schmitz

A printer that can directly connect to the Internet (No need to be connected to a computer or laptop)
You define it as a cloud printer (for example in your google cloud printer account).
If you send a document to "Cloud printer service", it is printed by your printer. ( from your mobile phone, from another computer, from your tablet; at your work place, while in the car, at the cafe; etc.).

Do you still have an unanswered question? Please log in first to post your question.