Replace "Allow diagonal" by "Allow slope" or the contrary "Force horizontal"
"Allow diagonal" is a property of lines that, if unchecked, forces them to be horizontal.
As "diagonal", formally speaking, is a line that connects two non-adjacent vertices of a polygon, I propose that string to be changed to "Allow slope". Changing it to "Force horizontal" might be even more straightforward (?), but that would suppose to make more changes to the code, as the checkbox would have to work in the opposite way as it does now.
Benefits would include a higher clarity, as well as a reduced chance for translations to be wrong in the languages where "diagonal" isn't used informally to refer to any sloping line.