Nightly build doesn't run on Ubuntu 14.04

• Nov 7, 2014 - 16:23

Hi there

I have been testing the nightly builds for Linux on Ubuntu 14.04 (32-bit) for a few months now, since I really do need some of the MuseScore 2.0 features.

However, the past few weeks' worth of builds do not run. I have all the correct dependancies, and build mscore.32bits-2014-07-07-11-01-c63936e does run, for instance.

I don't know when the builds stopped working, but all the builds I have attempted to run in the past 2 weeks have given me this same error (or something extremely similar):

$ ./mscore
./mscore: symbol lookup error: ./mscore: undefined symbol: _ZN7QString13toUtf8_helperERKS_

Any ideas?


In reply to by ABL

Did you try it and did it work?

I get:
xxx@xxx-desktop:/usr/local/bin$ Nmscore
./mscoreN: /lib/x86_64-linux-gnu/ version `GLIBC_2.16' not found (required by ./mscoreN)
./mscoreN: /usr/lib/x86_64-linux-gnu/ version `CXXABI_1.3.8' not found (required by ./mscoreN)
./mscoreN: /usr/lib/x86_64-linux-gnu/ version `GLIBCXX_3.4.20' not found (required by ./mscoreN)

I named the most recent Nightly mscoreN and, yes, it is referred to as such in the launch script, it has been made executable, I have other scripts that run from that directory, the directory is in my $PATH etc.

mscore Nightlies seem to be looking for files in /lib... which means you must have the most up-to-date Qt etc. as primary on your system but if you install Qt and other more recent things into a different directory because you still need to keep the older versions for compatibility with current applications then it seems the the Nightlies can't find the dependent files. Or you can put the newest versions into /lib but then some of your existing applications might have problems where Qt 5.x and others are not completely backwards-compatible with 4.x etc.

In reply to by underquark

./mscoreN: /lib/x86_64-linux-gnu/ version `GLIBC_2.16' not found (required by ./mscoreN)
./mscoreN: /usr/lib/x86_64-linux-gnu/ version `CXXABI_1.3.8' not found (required by ./mscoreN)
./mscoreN: /usr/lib/x86_64-linux-gnu/ version `GLIBCXX_3.4.20' not found (required by ./mscoreN)

Update libstdc++6 and gcc to 4.8.x..

I had a similar error when updated to Ubuntu 14.04.
I don't remember exactly, but seems like I had a mix of libraries installed manually and via packet manager (Qt4 + Qt5 + Qt5 from packet manager).
As I remember clearing it up might help (remove unnecessary versions and reinstall the version you need).

The linux 32-bit Nightly from 10 hours ago only appears to be a few Mb in size. I downloaded the 64-bit one but the archive seems corrupted. I tried a couple of other recent ones and couldn't get them to run despite having Qt 5.3.2 and setting the PATH variables for Qt, LD etc. I couldn't help but noticing that the 2.0 beta 1 download is 350Mb or so but the recent Nightlies weigh in at only 275MB-ish - is something missing?

I don't understand half of what's going on. However, it appears that Qt 5.3 is default in the Ubuntu 14.10 repositories. I will upgrade and then try again from scratch.

There should, in my opinion, still be an easier way. Musicians are usually not skilled in dependancies.

In reply to by etienne

I agree that it should be unnecessary to have the very latest version of Linux (whatever one you use) in order to run MuseScore. Whilst you can't and shouldn't expect new software to work with all obsolete Operating Systems (and that would include Windows XP as support is withdrawn) IMHO it should ideally work with commonly-used current OS's that have support planned for a couple more years.

Version 12.04 ubuntu is a longterm stable release with support until 2017, as is Linux Mint 13 (Maya). I know the Nightly developers/maintainers are doing a lot of work but would it be possible to ask for the builds to be done in an environment such as ubuntu 12.04, Mint 13, or similar? Qt 5 is still needed but easy to install and you can likely get by with glibc-2.15 and other C libraries from about 2012. Moving to Qt5 doesn't appear to have a huge hit on existing applications (you can readily install it alongside Qt4) but it's much more difficult for the average punter to install newer C libraries whilst maintaining the older ones that some applications still need to run

I've upgraded Qt, struggling with the latest C libraries. I dont' want to go from 12.04 to 14.04 if I can help it because it would mean re-doing a lot of stuff I use regularly outside of music.

In reply to by underquark

I could not get it to work on 14.04 LTS. I was forced to upgrade to 14.10, which isn't a problem for me, but it might be for others. Once you install the necessary Qt5 packages from Software Centre (Ok I did a sudo apt-get install) then the latest Nightlies work like a charm.

Do you still have an unanswered question? Please log in first to post your question.