Exported musicaLxml percussion parts from Finale not imported correctly.

• Feb 19, 2015 - 17:21
Type
Functional
Severity
3
Status
needs info
Project

1. Create a part or score containing at least 1 (one) non-pitched percussion (such as drum-set or conga drums) part in Finale.
2. Export this part to a musicalxml.
3. Import the part to MuseScore.

Expected Behavior: Part should be properly recognized as percussion instrument, with appropriate playback sound and note annotation.

Actual Behavior: Part is read in with appropriate name in the "name" field of the instrument, however MuseScore does not recognize the part appropriately, with notes being displayed in typical music note style, instead of the default annotation used by MuseScore's percussion creator, and playback defaults to "piano."

I am using the most recent MuseScore pull and the currently released beta and have been unsuccessful in importing a percussion part yet. This is my first real bug report, so if I've made any mistakes or made anything unclear please let me know. I'm also trying to work towards fixing this bug, so I have assigned it to myself, but if someone knows an obvious fix please go ahead and apply the fix. Thanks for your help.


Comments

Here's the error I get with build 3a8fff5:

clp100.png

And if I say "load anyway" here's a portion of what the resulting score looks like:

clp101.png

Drums are playing back OK.

Severity
Status (old) active needs info

Same for me. I suspect the OP was actually using 1.3, as 2.0 beta should have worked just fine, but in any case, whatever problem may have existed at one time no longer seems to apply.

bigtmoose, can you verify?