MIDI input slower than expected

• Dec 31, 2018 - 01:51
Reported version
3.0
Type
Performance
Frequency
Many
Severity
S3 - Major
Reproducibility
Always
Status
duplicate
Regression
No
Workaround
No
Project

I just upgraded to 3.0, and MIDI input is now painfully slow. When I press a key on the keyboard, there's a delay of almost a second before I hear the note sound. Then I release the key, and there's a similar delay before it stops playing. Worse, there's a separate delay for every note: if I play a chord, they don't all sound together. They get played arpeggiated, with a significant delay between notes.

This is in version 3.0.0.20137 running on macOS 10.13.4, using CoreMIDI for MIDI input.


Comments

That might be the case. It's 60 measures of full orchestral score, so not huge, but not tiny either. I tried an empty score with only one instrument, and there was no perceptible delay. Note, though, that it happens even when I'm not in note entry mode, so all it's doing is playing sound, not actually editing anything.

In reply to by peastman

With 60 measures in a score with >50 instruments, using the mouse and qwerty keyboard is fast, though it is very slightly slower than on the same score with 20 measures. I don't have a real noticeable slowdown until i get somewhere over 100 measures, and have a several year old computer with not much memory. It sounds like you have a midi issue. What's strange is that you're the only person I've see talking about midi being slower.

Title MIDI input very slow MIDI input slower than expected

I have compared midi input into an empty document. Musescore 3 shows a bigger delay than Finale Notepad 2012, chord shows a slight arpeggio. My system: Musescore 3.4.2.9788 Intel Core i7-7500U, 16 GB RAM, Win x64 10.0.18363.720, USB-Midi-Keyboard Akai LPK25.