Accidental::isMicrotonal() function name is misleading
Accidental::isMicrotonal() function returns
true for natural-flat and natural-sharp accidentals which are, in fact, not microtonal. As per discussion here, its real usage corresponds to its current definition (so it is used in situations where it is desired to group natural-flat and natural-sharp and microtonal accidentals together) but in this case the name of this function is misleading which may cause issues when working with this function later. Therefore it would be good to find a correct name for this function and rename it correspondingly.