Volta with multiple endings not working

• Oct 8, 2020 - 14:16

I have followed the manual's instructions scrupulously (I think I have?) and I can't get the repeats I entered in the Inspector to show in the sheet music. I'd like to have...
- Volta 1: repeat 1,2, 3
- Volta 2: repeat 4
Any ideas?

Attachment Size
Musescore - Volta problem.png 74.02 KB

Comments

@chumbolito
I agree that voltas are quite confusing.
Check the attached example, which plays Volta 1.2.3. (first volta) three times and then Volta 4 (second volta) once.
Repeats and Voltas.png

For the "end repeat" measure: you have to set the measure property "Play count" to the full repeat count i.e. in this case 4 (not 3).
For both voltas: you have to set the volta property "Begin text" to whatever you want displayed i.e. how the performer sees the volta on the printed page.
And the most important point (easy to miss, at the foot of the inspector panel):
For both voltas: you have to set the volta property "Volta - Repeat list" to the actual repeats when this volta plays i.e. in this case 1, 2, 3 for first volta, and 4 for second volta.

Attachment Size
Repeats and Voltas.png 29.8 KB
Repeats and Voltas.mscz 7.65 KB

In reply to by DanielR

Did everything you suggested, still not fully working i'm afraid.
First there's the visual problem: the '1,2,3' & '4' doesn't not appear in the sheet music inside the volta?
Second, when I play the sheet, it will repeat 3 times and on the fourth repeat, it skips completely the 2nd volta (the 2/4 bar) and goes on to the Chorus on the next staff.
See attached animated gif...

Attachment Size
Musescore - Volta problem.gif 553.63 KB

In reply to by DanielR

Oops! Sorry I missed that 'Begin text' thing.
However, I don't understand how you ended up with a Volta 2: Repeat list = 2 (it's 4 here, as on my gif), same with End-repeat measure (1st volta measure), Play count is 4 here, not 2 (again, as in my gif).

There's just one thing I don't understand...I can't seem to find the difference between your file which properly changes to volta 2 at the 4th repeat and mine which stills completely skips volta 2?
Did you do anything additionally to solve that because, for the rest, now it really looks the same to me? (I'm sure you'll point out something else I forgot :-S)

In reply to by chumbolito

In the volta there are two places that you can change. First is what is printed on the score, the Begin text, the second is what is played, the Repeat list. Begin text does not affect playback. If you want volta 2 to play only on the 4th time through the Repeat list must be 4, you could change the text to anything you want like "Finale" if you wanted to rather than "4."

In reply to by mike320

Well, it looks like your comment fixed the problem! :-)
Closing and reopening Musescore seems to have fixed it but I can assure...it was happening before.
However, there is still an odd bug - but Musescore seems to still be a very buggy program as it's not my first - where it pauses for a long time on that 2/4 bar in volta 2 before moving on to the next.

Thanks to everyone for kindly helping me out with this! :-)

In reply to by chumbolito

The pause is not a bug but rather by design. You have entered a section break at the end of the first 3 systems so you will get a pause of 3 seconds by default. If you want a system break, enter those like you did in all of the following systems.

Every program has bugs that is a fact. MuseScore is a program designed to work a certain way. It is not a bug that it doesn't work the way you want it to. If you do find any bugs, everyone involved in the program wants them fixed. If you need help, people here in the forum are happy to assist. BTW, everyone you've talk to that I'm aware of is a program user like you and none of us are actually employed by MuseScore.

In reply to by DanielR

I downloaded the example and played it. The player just blows through the repeat (without repeating) and pays the 4th volta and on to the end.

Is there some global setting that tells the player to ignore (or play) repeats?

I'm running the latest MuseScore available to me ...
OS: macOS 10.14, Arch.: x86_64, MuseScore version (64-bit): 3.5.0.28537, revision: 43c5553

In reply to by datihein

In version 3.5.0 there is a bug where repeats are never played in continuous view. To play repeats you must use Page View (not Single page view) and turn Play repeats off then back on every time you switch from continuous view. This has been fixed for version 3.5.1 which was released yesterday and available for download at https://musescore.org/en/download. I believe the Mac download is good to go, there is a minor unrelated problem with the Windows version.

Do you still have an unanswered question? Please log in first to post your question.