Printing Problems

• Feb 11, 2021 - 18:10

When I print a score, it is missing clefs, dots from dotted notes, note values before a tempo marking, and a few other things. It's quite annoying.
I have tried to print from both PDF and straight from MuseScore. What's going on, and how do we fix this?


Comments

Please also attache the score itself. Is it displayed correctly with a PDF-viewer (which one)? What OS you're using?

I assume this is a LaserJet Pro? Somehow the Mac printer driver for that particular series seems to have issues with the Leland font. Is this using 3.6.2? We tried to make a change to the font to improve this, but if you're still seeing that in 3.6.2, I guess it didn't happen, or didn't work. Anyhow, you might try contacting Apple and/or HP, because that seems to be the only combination that has problems with this font, so it's something they should probably fix, even while we continue to investigate what we might be able to do to work around it.

Meanwhile, switching to any other font should fix this.

As of today I'm having the same issue using:

macOS 10.16, Arch.: x86_64, MuseScore version (64-bit): 3.6.2.548020600, revision: 3224f34

And printing to an HP LaserJet MFP M281.

Love the Leland font, and will contact Apple and HP to hope they work on it too. Excited for the day we get the news that this issue is resolved.

In reply to by Jojo-Schmitz

12th June 2022
That's brilliant to hear. I too was flummoxed by this problem and it hadn't occurred to me that the font could be the culprit. I'm running
"Musescore 3.6.2.548020600 Revision: OS: macOS High Sierra (10.13.6), Arch.: x86_64, MuseScore version (64-bit): 3.6.2.548020600, revision: 3224f34 Mac OS" and what appeared to be a complex problem has such a simple solution: use another font. The fixed Leland hasn't reached me yet but I'm optimistic and find MuseScore to be brilliant.

Do you still have an unanswered question? Please log in first to post your question.