Windows 8.1 64 bit 'QT Creator' build

• Feb 26, 2015 - 03:11

Hey,

I was building the tar ball of MuseScore downloaded from GitHub and the cmd line build with mingw make worked fine.

Now I am trying the QT Creator build process and though everything was OK but it's stopped on this mistake:

Linking CXX static library libdiff_match_patch.a
[ 48%] Built target diff_match_patch
[ 48%] Generating ../resfile.o
'-i' is not recognized as an internal or external command,
operable program or batch file.
mscore\CMakeFiles\mscore.dir\build.make:951: recipe for target 'resfile.o' failed
mingw32-make[2]: *** [resfile.o] Error 1
CMakeFiles\Makefile2:298: recipe for target 'mscore/CMakeFiles/mscore.dir/all' failed
mingw32-make[1]: *** [mscore/CMakeFiles/mscore.dir/all] Error 2
makefile:136: recipe for target 'all' failed
mingw32-make: *** [all] Error 2
21:52:53: The process "C:\QT\Tools\mingw491_32\bin\mingw32-make.exe" exited with code 2.
Error while building/deploying project mscore (kit: Desktop Qt 5.4.1 MinGW 32bit)
When executing step "Make"
21:52:53: Elapsed time: 48:51.

Anyone care to tell me what is wrong in my QT Creator build setup? It's the same source type as was build earlier in cmd but with the alterations from this page:

http://musescore.org/en/developers-handbook/compilation/compile-instruc…

Thanks.


Comments

It looks like the build process can't find QT_WRC_EXECUTABLE as defined in build/mingw32.mingw.cmake. Did you run CMake from Qt Creator with the following argument -DCMAKE_BUILD_TYPE=DEBUG -DCMAKE_TOOLCHAIN_FILE=build/mingw32.mingw.cmake -DCMAKE_INSTALL_PREFIX=../win32install

In reply to by Nicolas

The instructions said

1. Run CMake

2. Add the command line args: -DCMAKE_BUILD_TYPE=DEBUG -DCMAKE_TOOLCHAIN_FILE=build/mingw32.mingw.cmake -DCMAKE_INSTALL_PREFIX=../win32install

3. Those other things.

4. 'Debug'

The thing I didn't do that it said to do was:

2.Choose CMake Executable:
Browse to where you installed CMake (i.e. C:\Program Files (x86)\CMake\bin)

because it already had ran a script on it's own or gotten the location of CMake from the PATH or something like that.

I can't find a location to manually choose cmake either. Hold on...I'll look elsewhere than the run CMake / Run windows...

OK, I found what I think I was supposed to configure:

Tools -> Options -> CMake -> Executable: C:\Program Files (x86)\CMake\bin\cmake.exe (Browse...)

but it still gave the save error as before.

Do I need to

1) make clean

2) Reinstall CMake, Jack, and other dependencies to a more 'old fashioned' path like c:\bin\chains\CMake and c:\bin\chains\Jack

as I also get warnings from CMake that it doesn't like the ( in the Jack install path.

Thanks

In reply to by JackJura

I am rerunning the 'Run CMake' part now that I browsed to add cmake.exe. I still get the Jack warnings but I'll add -Wno-dev.

That finished and I still get the error on generating resfile.o

I will do a make clean & try again.

OK, this time when running CMake I added the arguments as you directed before I ran CMake not after as the instructions say.

Since I ran make clean it will be an hour or more before the build process tries to generate resfile.o

Thanks

In reply to by JackJura

OK, same error:


[ 48%] Built target portmidi
[ 48%] Generating ../resfile.o
'-i' is not recognized as an internal or external command,
operable program or batch file.
mscore\CMakeFiles\mscore.dir\build.make:951: recipe for target 'resfile.o' failed
mingw32-make[2]: *** [resfile.o] Error 1
CMakeFiles\Makefile2:298: recipe for target 'mscore/CMakeFiles/mscore.dir/all' failed
mingw32-make[1]: *** [mscore/CMakeFiles/mscore.dir/all] Error 2
makefile:136: recipe for target 'all' failed
mingw32-make: *** [all] Error 2
12:32:25: The process "C:\QT\Tools\mingw491_32\bin\mingw32-make.exe" exited with code 2.
Error while building/deploying project mscore (kit: Desktop Qt 5.4.1 MinGW 32bit)
When executing step "Make"
12:32:25: Elapsed time: 50:10.

I attached an overview of my CMake configuration that was generated in the QT Creator as it appears in the CMake-gui.

Thanks.

Attachment Size
CMake.png 78.48 KB

In reply to by JackJura

Ok... so maybe "Run Cmake" is not clear enough.

1/ Open Qt creator
2/ Go to File => Open File or Project....
3/ choose the CMakeLists.txt file at the root of MuseScore directory.
4/Now it will take you through a pathwizard
shot_150226_185701.png
5/ In the wizard, choose the build directory, and the cmake arguments and press Run CMake

Something else you could try, it's to add VERBOSE=1 in the make argument in the Project tab in Qt Creator. The output will be a lot more verbose then.

In reply to by Nicolas

OK, I'm looking more closely at the build.make section below:


resfile.o: ../mscore/data/mscore.rc
$(CMAKE_COMMAND) -E cmake_progress_report C:\bin\hg\MuseScore\build.qtc\CMakeFiles $(CMAKE_PROGRESS_146)
@$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --blue --bold "Generating ../resfile.o"
cd /d C:\bin\hg\MuseScore\mscore\data && -i mscore.rc -o C:/bin/hg/MuseScore/build.qtc/mscore.res
cd /d C:\bin\hg\MuseScore\mscore\data && \home\ws\.wine\drive_c\MingW\bin\windres.exe C:/bin/hg/MuseScore/build.qtc/mscore.res -o C:/bin/hg/MuseScore/build.qtc/resfile.o

It appears that the input files that cmake uses to generate the build instructions for resfile.o is wrong. Those instructions are for Linux machine with wine.

OK, I manually edited the build.make file. It seems somewhere should have been defined a windres.exe macro telling where windres.exe is as I added it to the correct places for the build instructions for resfile.o and that fixed the problem.

e.g.


resfile.o: ../mscore/data/mscore.rc
$(CMAKE_COMMAND) -E cmake_progress_report C:\bin\hg\MuseScore\build.qtc\CMakeFiles $(CMAKE_PROGRESS_146)
@$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --blue --bold "Generating ../resfile.o"
cd /d C:\bin\hg\MuseScore\mscore\data && C:\QT\Tools\mingw491_32\bin\windres.exe -i mscore.rc -o C:/bin/hg/MuseScore/build.qtc/mscore.res
cd /d C:\bin\hg\MuseScore\mscore\data && C:\QT\Tools\mingw491_32\bin\windres.exe C:/bin/hg/MuseScore/build.qtc/mscore.res -o C:/bin/hg/MuseScore/build.qtc/resfile.o

A macro is not defined somewhere that cmake would have substituted in for this resourse, e.g. $(WINDRES_COMMAND) = C:\QT\Tools\mingw491_32\bin\windres.exe but where I don't know.

I will try to learn some more about CMake includes.

I just noticed, the object file for resfile.o: instructions ends in .o as traditional for UNIX but Windows object files that need to be linked in usually end in .obj? I'm not sure about Windows, I really only developed a lot on UNIX. I'll know in about an hour if it find it with .o and links it in.

In reply to by JackJura

OK, the build finished but I'm getting unresolved symbols, probably just need to rename the resfile.o as the unresolved resources seem to be Windows resources.


[100%] Building CXX object mscore/CMakeFiles/mscore.dir/mscore_automoc.cpp.obj
Linking CXX executable MuseScore.exe
CMakeFiles\mscore.dir/objects.a(qrc_musescore.cpp.obj): In function `Z24qInitResources_musescorev':
C:/bin/hg/MuseScore/build.qtc/mscore/qrc_musescore.cpp:39816: undefined reference to `qRegisterResourceData(int, unsigned char const*, unsigned char const*, unsigned char const*)'
CMakeFiles\mscore.dir/objects.a(qrc_musescore.cpp.obj): In function `Z27qCleanupResources_musescorev':
C:/bin/hg/MuseScore/build.qtc/mscore/qrc_musescore.cpp:39824: undefined reference to `qUnregisterResourceData(int, unsigned char const*, unsigned char const*, unsigned char const*)'
CMakeFiles\mscore.dir/objects.a(qrc_musescorefonts-MScore.cpp.obj): In function `Z36qInitResources_musescorefonts_MScorev':
C:/bin/hg/MuseScore/build.qtc/mscore/qrc_musescorefonts-MScore.cpp:8609: undefined reference to `qRegisterResourceData(int, unsigned char const*, unsigned char const*, unsigned char const*)'
CMakeFiles\mscore.dir/objects.a(qrc_musescorefonts-MScore.cpp.obj): In function `Z39qCleanupResources_musescorefonts_MScorev':

...
and so on...
...

In reply to by JackJura

Here is correct generated resfile.o generation according to the cmd version of cmake file.


resfile.o: ../mscore/data/mscore.rc
$(CMAKE_COMMAND) -E cmake_progress_report C:\bin\hg\MuseScore\build.release\CMakeFiles $(CMAKE_PROGRESS_146)
@$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --blue --bold "Generating ../resfile.o"
cd /d C:\bin\hg\MuseScore\mscore\data && call C:\bin\hg\MuseScore\build\wrc.bat -i mscore.rc -o C:/bin/hg/MuseScore/build.release/mscore.res
cd /d C:\bin\hg\MuseScore\mscore\data && call C:\bin\hg\MuseScore\build\wine.bat /home/ws/.wine/drive_c/MingW/bin/windres.exe C:/bin/hg/MuseScore/build.qtc/mscore.res -o C:/bin/hg/MuseScore/build.qtc/resfile.o

So the .o is expected and this

/home/ws/.wine/drive_c/MingW/bin/windres.exe

seems to a mistake that gets ignored in the cmd version of the build process.

In reply to by JackJura

Have you checked that the files are generated with the correct "kit" inside QtCreator?
(you have to choose the correct kit with MinGW and Qt version in the drop-down list at the wizard when opening the project before clicking the "Run CMake" button, see the previous comment by lasconic for a screenshot)
See also:
http://stackoverflow.com/questions/28005590/qt-creator-using-mingw-comp…
and
http://doc.qt.io/qtcreator/creator-targets.html

Hope this helps.
Ciao,
ABL

In reply to by ABL

Thanks, I checked that but since I only have the kit needed for MuseScore that dropdrop list only lists the one kit MuseScore needs.

Ugh! I am trying to get TortoiseHG working nicely with GitHub again so I can easily sync with MuseScore nightlies but for whatever reason the ssh+git or even https is not working between GitHub and TortoiseHG. Earlier, it was not a problem to work with another project. Now TortoiseHg works with no GitHub project. :-(

After I do that I will again but even more carefully follow the Windows QT Creator build instructions so I can fix it for that one macro and figure out what is wrong with the link step (probably another macro that isn't defined). I am happy the command line version works easily without problem until then.

In reply to by JackJura

Thanks Jack for figuring this out and posting it. I just ran into the same problem on Win7 Ultimate x64, and your edits to the build.make file got me from 47% complete to 73%, compiling in the Qt Creator UI (I still haven't installed vorbis).
But now I must remember to make this change again if I ever run CMake again. Is there a way to fix this in CMake too?

On the positive side: this solution works.
To summarize the changes I now make after every CMake:
1) Edit the build.make file in: MuseScore-master\build\mscore\CMakeFiles\mscore.dir
2) Find "windres.exe", which takes me to line 833
3) Replace the path for windres.exe in that line:
original: {syntaxhighlighter SPEC}\home\ws\.wine\drive_c\MingW\bin\windres.exe{/syntaxhighlighter}
new: {syntaxhighlighter SPEC}C:\Qt\Tools\mingw491_32\bin\windres.exe{/syntaxhighlighter}
4) Add windres.exe to the previous line, 832, prior to the "-i" option that caused the compiler to cough:
original: {syntaxhighlighter SPEC}-i{/syntaxhighlighter}
new: {syntaxhighlighter SPEC}C:\Qt\Tools\mingw491_32\bin\windres.exe -i{/syntaxhighlighter}

In reply to by sideways

Changing that windres.exe line is actually what I remember finally changing to get the build to complete successfully too. Sorry that I didn't remember to post it to this thread. I've since moved on to another project, home remodeling, which I have to complete before I can mess around with MuseScore again, which I like very much using to supplement teaching myself music.

In reply to by JackJura

No need to apologize, your posts helped me a great deal. I can compile MuseScore.exe.

But now I'm stuck on a link error, and I see that it's the same place you left off, and it's dawning on me that you never finished building MuseScore, and we're both stuck in the same place, again. Actually it's a list of 80,150 link errors, and they begin exactly the same way as the ones you posted above:
{syntaxhighlighter SPEC}Linking CXX executable MuseScore.exe
CMakeFiles\mscore.dir/objects.a(qrc_musescore.cpp.obj): In function `Z24qInitResources_musescorev':
Z:/MuseScore-master/build/mscore/qrc_musescore.cpp:43764: undefined reference to `qRegisterResourceData(int, unsigned char const*, unsigned char const*, unsigned char const*)'{/syntaxhighlighter}

I have followed all the instructions, including un-rem'ing the last line of Qt.bat, putting the Creator/bin in my path and launching Qt Creator from Qt.bat. I have rebooted and restarted and rebuilt from scratch. My OS is Windows 7 Ultimate 64 bit.

Any ideas? Anyone?

In reply to by sideways

No, I did actually finish building MuseScore, on Windows 8.1.

I am now on Windows 10. I am working on a completely different project now otherwise I'd take a bit of time right away and get to the same problems to solve again. If I finish the bit of work I'm working on now by Wednesday, I will look on Thursday at compiling again.

In reply to by sideways

That means a library you need to be included in the list of libraries to be linked with the executable is not in the list.

The easiest way to find out which library is to search for the source file for qRegisterResourceData and use the make file that complies that source file to an object file and then adds it to the library you are missing in the make instructions linker section for the executable. There should be one or more occurrences of qRegisterResourceData in the make files.

However if I remember right, the problem, and you've already seen it, is this Linux wine build instruction listed in the make file which isn't really appropriate for a true Windows environment as it fails. If I recall correctly, fixing that Linux instruction to be the equivalent for Windows was the last thing I needed to do for the build to succeed al the way through.

However, it's been several months.

I will keep the email this bulletin board sent my to remind me to setup the MuseScore build environment on my PC on Thursday and help you. Maybe if my work goes fast this evening I can help you as soon as tomorrow.

In reply to by JackJura

I don't see qRegisterResourceData implemented anywhere, it's declared in 8 places, but implemented nowhere. These two lines appear in qrc_musescore.cpp and 7 other files:
{syntaxhighlighter SPEC}line 43752 bool qRegisterResourceData(int, const unsigned char *, const unsigned char *, const unsigned char *);
line 43763 QT_RCC_PREPEND_NAMESPACE(qRegisterResourceData){/syntaxhighlighter}
I would guess that it's a Qt function, but that's just a guess.
The interesting part is that qrc_musescore.cpp is next after resfile.o in the build.make file. I did not replace any newline characters in the build.make file, so it shouldn't be some windows/linux incompatibility there. Here are the relevant lines for resfile.o and qrc_musescore.cpp in build.make:

{syntaxhighlighter SPEC}resfile.o: ../mscore/data/mscore.rc
@$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --blue --bold --progress-dir=Z:\MuseScore-master\build\CMakeFiles --progress-num=$(CMAKE_PROGRESS_149) "Generating ../resfile.o"
cd /d Z:\MuseScore-master\mscore\data && C:\Qt\Tools\mingw491_32\bin\windres.exe -i mscore.rc -o Z:/MuseScore-master/build/mscore.res
cd /d Z:\MuseScore-master\mscore\data && C:\Qt\Tools\mingw491_32\bin\windres.exe Z:/MuseScore-master/build/mscore.res -o Z:/MuseScore-master/build/resfile.o

mscore/CMakeFiles/mscore.dir/qrc_musescore.cpp.obj: mscore/qrc_musescore.cpp
@$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --green --progress-dir=Z:\MuseScore-master\build\CMakeFiles --progress-num=$(CMAKE_PROGRESS_150) "Building CXX object mscore/CMakeFiles/mscore.dir/qrc_musescore.cpp.obj"
cd /d Z:\MuseScore-master\build\mscore && C:\Qt\Tools\mingw491_32\bin\g++.exe $(CXX_DEFINES) $(CXX_FLAGS) -o CMakeFiles\mscore.dir\qrc_musescore.cpp.obj -c Z:\MuseScore-master\build\mscore\qrc_musescore.cpp

mscore/CMakeFiles/mscore.dir/qrc_musescore.cpp.i: cmake_force
@$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --green "Preprocessing CXX source to CMakeFiles/mscore.dir/qrc_musescore.cpp.i"
cd /d Z:\MuseScore-master\build\mscore && C:\Qt\Tools\mingw491_32\bin\g++.exe $(CXX_DEFINES) $(CXX_FLAGS) -E Z:\MuseScore-master\build\mscore\qrc_musescore.cpp > CMakeFiles\mscore.dir\qrc_musescore.cpp.i

mscore/CMakeFiles/mscore.dir/qrc_musescore.cpp.s: cmake_force
@$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --green "Compiling CXX source to assembly CMakeFiles/mscore.dir/qrc_musescore.cpp.s"
cd /d Z:\MuseScore-master\build\mscore && C:\Qt\Tools\mingw491_32\bin\g++.exe $(CXX_DEFINES) $(CXX_FLAGS) -S Z:\MuseScore-master\build\mscore\qrc_musescore.cpp -o CMakeFiles\mscore.dir\qrc_musescore.cpp.s

mscore/CMakeFiles/mscore.dir/qrc_musescore.cpp.obj.requires:

.PHONY : mscore/CMakeFiles/mscore.dir/qrc_musescore.cpp.obj.requires

mscore/CMakeFiles/mscore.dir/qrc_musescore.cpp.obj.provides: mscore/CMakeFiles/mscore.dir/qrc_musescore.cpp.obj.requires
$(MAKE) -f mscore\CMakeFiles\mscore.dir\build.make mscore/CMakeFiles/mscore.dir/qrc_musescore.cpp.obj.provides.build
.PHONY : mscore/CMakeFiles/mscore.dir/qrc_musescore.cpp.obj.provides

mscore/CMakeFiles/mscore.dir/qrc_musescore.cpp.obj.provides.build: mscore/CMakeFiles/mscore.dir/qrc_musescore.cpp.obj{/syntaxhighlighter}

So I fixed resfile.o, but now it fails on the next step after that. It would be nice if it was a Windows/Linux newline incompatibility. Am I missing a typo somewhere?

In reply to by sideways

Well I am setting up the build environment now but I have a slow internet connection so it will take a while.

The build is particular about the version of Ming and other tools you use so double check those.

And there are two sets of build instructions. When I setup last time correctly with the correct tool versions the command prompt version of the build went smoothly 1st time I tried. It was the QT Creator that I had trouble with. Or maybe that's vice versa???

In reply to by JackJura

I too just built (compile + link) successfully from the command linel. I also tried removing the /low parameter from the call to open the Creator in Qt.bat, but that failed too. At least I can build. Hopefully debugging won't be inconvenienced in any way...

...My debug MuseScore.exe runs normally. It does call itself v2.1.0 unstable, which is not reassuring, but I am able to debug it inside the Qt Creator, which was my goal. I can always retrieve a different version of the source if I so desire.
FYI: It only works for me using the Debug Menu -> Attach to Unstarted Application... option. Press the "start watching" button, then launch the debug .exe.

In reply to by sideways

If you're using the nightly build then they are mostly OK.

I found that my cmdline successfully compiled & linked MuseSore.exe actually didn't run because it can't find freetype6.dll.

So I tried on QT Creator and the CMake process can't fid the freetype header files or library anymore. I think it has something to do with Windows 10 but I'm not sure.

e.g. of that (new since Feb problem):

FREETYPE_INCLUDE_DIR_freetype2: not found
FREETYPE_INCLUDE_DIR_ft2build: not found
FREETYLE_LIBRARY: not found

I set those manually in the CMake GUI though and I've gotten the error I had the 1st time on Windows 8.1. Then I fixed that the same way as the 1st time.

Then it compiles all the way through and it tries to link together MuseScore.exe but fails to link. I then get 85913 link errors that I didn't get when I did this back in February.

Then last linker error was:

collect2.exe:-1: error:
error: ld returned 1 exit status
File not found: collect2.exe

So something in the QT Maintenaince & Install has failed to set up the environments correctly as collect2.exe is part of the GCC linker and included in the MingW install and present in my install of MingW. :-(

So something has changed about the CMake / QT Creator / MuseScore / Windows 10 build process that I need to figure out.

How many linkers errors did you get at the end and was it trying to link MuseScore.exe too?

In reply to by JackJura

Yes, in Qt Creator I get either 85K or 76K errors, depending on I don't know what. The linker message for MuseScore.exe and the first pair of errors are in one of my earlier posts. collect2.exe was in the second message.

I'm running the "community" version of Qt, which might explain some tidbit not being installed.

As for freetype6.dll, I ran into and fixed the same problem, but didn't think to mention it. My solution was to change the GnuWin32 directory in the PATH env var. I appended "\bin" to this directory, which is where the freetype installation puts freetype6.dll:

C:\Program Files (x86)\GnuWin32\bin

if you're still looking for a fix there.

In reply to by sideways

This v2.1.0 unstable is to be expected when compilung from the GitHub MuseScore master branch.
I'm building via QtCreator since a Long toime, and I'm pretty sure it is possible when following the steps in https://musescore.org/en/developers-handbook/compilation/compile-instru… to the letter. I'm on Windos 7 Enterprise, 64bit) though.
Back in February I think freetype was not needed, it is now though, and this is mentioned in the developers' handbook.

In reply to by Jojo-Schmitz

JoJo,

Are you using the "community" version of QtCreator? I too am running Win7x64.

I have followed those handbook compilation steps to the letter, including the optional Qt.bat, and I still have to modify the build.make every time I run CMake, and I still can't build inside QtCreator. Plus the change to the path to find freetype6.dll.

But I can build in the command line and debug in QtCreator, so I'm functioning, which is the important part.

In reply to by Jojo-Schmitz

Interesting. Are you launching Creator from a Qt.bat file or some other way? What version of Creator and when did you install it?

I installed very recently. Here is the Help->About... text:
{syntaxhighlighter SPEC}Qt Creator 3.5.1 (opensource)
Based on Qt 5.5.1 (MSVC 2013, 32 bit)
Built on Oct 15 2015 01:55:47
From revision b4c52505ca{/syntaxhighlighter}

In reply to by Jojo-Schmitz

I also launch from Qt with that line un-rem'd and the /low removed, so it looks like this:
{syntaxhighlighter SPEC}start qtcreator -lastsession{/syntaxhighlighter}I see that's different from yours. I'll have to try that change.

Is it possible that because you installed a "long time" ago, residual files that Qt community no longer installs, but doesn't delete either, are making a difference here? I'm really just fishing, though it does seem that the missing libraries in question are Qt.

I've given up actively trying to compile/link in Creator, but I'm curious to see this resolved. Also, especially since at least one other person has this issue and the issue has presented on Windows 7, 8 and 10, I'm wondering if I should post a new thread outlining the required fixes concisely. This thread has gotten long. Thumbs up or down on that one?

fyi - I had one additional issue that I resolved by reading another, older forum topic: the installation of the 64 bit libsndfile. The handbook compile instructions are not specific on that topic, and I would include the specifics in this new forum post. Extra instructions for users on Windows 64 bit v7, 8, or 10.

In reply to by JackJura

I just compiled and linked MuseScore 2.0.2 from within QtCreator. But I also still have to change build.make, and these two lines are slightly different in 2.0.2 vs. Master.

I'm going with 2.0.2 anyway for now, if there's a desire to integrate changes with MuseScore, that integration shouldn't be difficult regardless.

So it's something in the latest version that is causing a linking error on some installations.

And the build.make issue for Windows users is present regardless. I'm not recently familiar with CMake, and have little insight to provide for a real fix. I can live with the workaround into the foreseeable future...

Jojo, as you're the one with a fully functioning system: What might be different on your install from mine that the build.make file requires manually editing after each CMake? I just downloaded the zip for 2.0.2 from here: https://github.com/musescore/MuseScore/releases

I'm forced to modify build.make lines 830 and 831 (in Master it's 832 and 833 as described in my post above) to use the proper path for windres.exe. This is in the section for resfile.o, as described many places in this thread.

In reply to by Jojo-Schmitz

Oops. OK, I'll do that. I'm just barely getting started, as you can see by previous posts in this thread. Also I haven't coded C++ in 14 years, and back then we didn't use git, so I'm a pseudo-novice, please forgive my breaches of conduct, hopefully they will continue to be slight.

I was on my way to creating a fork right after I signed up for GitHub, but it kept forking the Master, and then I saw a link for "Releases" and found the zip files first. Now I see how to clone into the GitHub desktop.

2.0.2 is the current release according to musescore.org and my 2.0.2 installation "Check for updates..." command.

In reply to by sideways

2.0.2 is the latest released version, yes, but building yourself is about getting the next version, isn't it?
if there's a desire to integrate changes with MuseScore
Exactly this where you should look at the master branch, and maybe the 2.0.3 branch too. The 2.0.2 branch is a dead end road (well, actually the 2.0.3 branch is the extension to it, but for important bug fixes only)

In reply to by Jojo-Schmitz

Thanks for the tip, but for me right now it's all about stability and getting my project to function. My code changes will be isolated and documented in a way that I can integrate them easily into a later version. I've got my own internal documentation that's pretty extensive.

On a side note, I'm amazed that I can actually do this to the sheet music program I've been using for the past 3 years to write music. It's totally awesome. I've already debugged my way to success on my first coding task. I'll post to a new thread when my project is at a fully functional point, and we can discuss integration into MuseScore at that time.

Thanks!

Do you still have an unanswered question? Please log in first to post your question.