Undo adding instrument to score leads to crash

• Mar 27, 2019 - 22:39
Reported version
3.0
Type
Functional
Frequency
Once
Severity
S2 - Critical
Reproducibility
Always
Status
active
Regression
No
Workaround
No
Project

In an existing score add an instrument using the instruments dialog. Click the undo button and the result is a crash.

Submitting crash report referencing this issue.

The score that crashed was created in version 2.3.2. Creating a similar score in 3.0.5 did not immediately cause a crash, so I'll do some more testing. Perhaps feedback from the crash report could tell where to look.


Comments

Status active needs info

I don't see a crash with these steps on 3.0.5 or master. Is this reproducible for you? Can you attach the score that shows the problem?

Status needs info active

Here's the file. I once made it crash by making it smaller, but when I did the same thing a second time so I could save the file, the crash didn't happen.

Attachment Size
Clarinet Sonata.mscz 91.54 KB
Status active needs info

Sorry, I still can't reproduce on either 3.0.5 or master. Is this reproducible for you? If so, can you please give precise steps, beginning from a fresh start of MuseScore and loading the file? Seems likely the trigger has to d with something else you did previously.

Weird. No crash for me, again, not with 3.0.5, not with master. Thought maybe at first it would turn out that only transposing instruments would cause this and that was why I couldn't reproduce at first. Are you sure there are literally no other steps? I guess other possible relevant difference would be, if you have set up a custom instruments.xml file, or maybe are using a non-default soundfont. I'm on Windows 10, and I believe you are as well? Anything else you can think of that might contribute to a difference?

I have the Agean Symphonic Orchestra sound font set as the default with MuseScore_General.sf3. I'm using sounds from the MuseScore sound font. I didn't even think about that because I've never had a problem with it. The instruments I chose are from MuseScore general.

I examined the soundfonts closer and here's what I discovered. Aegean has only an English Horn Solo instrument. MuseScore General has only the English horn sound. When I add an English horn, it selects the Solo from the Aegean sound font. (thinking out loud) I wonder if this is the source of the problem.

(Answer to myself) I added an English horn, changed the sound to MuseScore General. Undo once, returned the sound to Aegean, the second undo crashed. Sounds like you're on the right track Marc.

Did you see the crash report from yesterday? I put this issue number into it to make it easier to find.

Status needs info active

Once again had a crash on a different score and instrument. I sent a crash report referencing this issue.

In the attached score, I added a staff staff to the piano and clicked undo.

Attachment Size
Clarinet Sonata.mscz 91.54 KB