Reverb: Exported WAV vs. MuseScore playback

• Nov 4, 2011 - 11:44
Type
Functional
Severity
S4 - Minor
Status
closed
Project

using: musescore nightly

This is part bug part UX strangeness.

There are two reverb/chorus settings in Musescore: the "instrument" dialog box has a reverb/chorus slider and the "mixer" dialog box has one too. It is unclear what both of these do as they do not work in an intuitive way:

The instrument reverb slider affects the sound you hear while playing within musescore.
The mixer reverb slider has no effect while playing back in musescore but does determine the amount of reverb in the rendered score. This last bit seems an error to me.


Comments

A lot of this confusion would be eliminated by making reverb (or the UX) more like a send effect and not an insert effect:
http://www.l2pnet.com/blogs/insert-effects-vs-send-effects-02222011

actually there is a really simple fix to this UX problem:
remove the sliders in the SYNTHESISER dialog and hardcode them to somewhere-in-the-middle. Then make sure that for new instruments added the mixer reverb and chorus are set to ZERO

if the user now wants reverb he only has to look at the mixer and he'll immediately understand that if he wants reverb he needs to change that dial.

Title Reverb in exported wav versus reverb in paying back [Trunk] Reverb in exported wav versus reverb in playing back
Title [Trunk] Reverb: Exported WAV vs. MuseScore playback Reverb: Exported WAV vs. MuseScore playback
Status (old) active needs info

Hi bdejong

Are you still encountering problems?