Musescore 4.0 instrument name problem

• Dec 25, 2022 - 23:10
Reported version
4.0
Type
Functional
Frequency
Few
Severity
S3 - Major
Reproducibility
Always
Status
active
Regression
Yes
Workaround
No
Project

In MS 4.0 (not development... website issue tracker issue!) I imported a MS 3.6 file which had "internal" instrument names that I had modified, and had blank long and short display versions of the instrument names (as I do not want to display the instrument names).
Still in MS 4.0, I can see the "internal" instrument names correctly in the mixer, but I do not see them in the Instruments tab... I just see the long display name (if I change that to something non-blank).
I do see the internal names as apparent defaults in the Parts popup but changing the part name does NOT change what the Mixer displays, nor does it change what Instruments tab displays ... which makes total sense, I'm fine with that.
I do NOT find any way to change the "internal" instrument names (shown by the mixer) short of editing the mscx file I suppose.
Note that using the Instruments tab, I can change the display long and short names (not that I wanted to) but it still doesn't change what appears in the Mixer (nor would I want it to!)

I would like the UI to work like it did in 3.6 where I can set separate names for internal instrument name, long display name and short display name.
And I would like the internal instrument name to show up by default on the Instruments tab as well as the Mixer.

Thanks for your hard work!


Comments

I should add that if I add another instrument, it is assigned an internal name by MS 4.0 (e.g. "violin 3") which i don't seem to be able to change.
Since all my "instruments" are violins you might guess at the confusion this cause me.
Or if I "replace instrument" it replaces my previous instrument internal name with one it makes up.