Fretboard diagrams: Offset needs to be renamed and should correspond with the diagram

• Dec 22, 2018 - 20:39
Reported version
3.0
Type
Functional
Frequency
Once
Severity
S3 - Major
Reproducibility
Always
Status
closed
Regression
No
Workaround
No
Project
Tags

OS: Windows 10 (10.0), Arch.: x86_64, MuseScore version (64-bit): 3.0.0.4744, revision: 36e6246

Create a fretboard diagram. Now change the "Offset" value (just above the diagram). Two problems:

  1. The name "Offset" is wrong. Suggested alternatives include either "Fret number", "Fret No.", "Position number," "Position No." or "Position".
  2. To avoid confusion to users, the "Offset" number in the Inspector should correspond to the fret number shown on the diagram.

Comments

Correction: "Offset" should be called "Fret number" as this is the term used in Format > Style > Fretboard diagrams. The number 1 should be omitted from "Fret number": it should jump from 0 (no display) to number 2 and then sequentially as usual.

I'd like to try and fix this issue. Should I also carry the name change through all the variables and property names and such?

What do you think about using the term "Starting Fret" rather than "Fret Number" in the Inspector? I am not convinced that it needs to be the same term used in Format > Style > Fretboard diagrams. I do not like the idea of having a "Fret Number" of 0 to indicate that it is not drawn, and then disallowing a "Fret Number" of 1. Rather, the "Starting Fret" would have a minimum value of 1, which would indicate that it is not drawn.

Or we could call it "Fret Number" as suggested, but have it understood that a "Fret Number" of 1 is not drawn. I can have a PR ready to submit once I hear back from @geetar about this.

I think fret number should just start at 1 and then count up from there to match the number. That's what I did and I think it works well. On reset I set it to 1 and set the minimum value of the QSpinBox to 1.

"What do you think about using the term "Starting Fret" rather than "Fret Number" in the Inspector?"
"Starting fret" is ambiguous: it could be mistaken for the nut (open position) of the instrument. IMV, "Fret position" or "Fret number" is OK.

I do not like the idea of having a "Fret Number" of 0 to indicate that it is not drawn, and then disallowing a "Fret Number" of 1.
Agreed. Just use an ordinary numeric progression.

IMV, the property called "Frets" could also be made clearer. Perhaps "Display X frets" with "X" being a spin box?