Exporting parts from a score does not produce correct MIDI, MP3, WAV, OGG, and FLAC files.

• May 29, 2019 - 14:50
Reported version
3.1
Priority
P0 - Critical
Type
Functional
Frequency
Many
Severity
S2 - Critical
Reproducibility
Always
Status
closed
Regression
Yes
Workaround
No
Project
  1. Create score with 2 staves 2 voices per staff (e.g. treble clef Tenor/Lead; bass clef baritone and bass)
  2. Create individual parts for each voice (e.g voice 1 Treble Clef tenor; voice 2 Treble Clef lead; voice 1 bass clef baritone voice 2 bass clef bass).
  3. Click "export parts".
  4. Select midi

Lead and Tenor midi files will be the same (no separation into individual parts). Bass and Bari files are blank.

Confirmed here: https://musescore.org/en/node/289865

Attachment Size
test.mscz 21.93 KB

Comments

Title Exporting parts from a score does not produce correct midi files. Exporting parts from a score does not produce correct midi files when using voices to parts

Does it work for you when not combining parts on a single staff - that is, when not using the voices-to-parts feature?

  1. I made a new score with one part (voice) per staff. There are four instruments--Tenor, Lead, Baritone, and Bass.

  2. I created individual parts for each staff--Tenor Lead Baritone and Bass.

  3. I used the "export parts" feature.

Result:
The tenor midi was exported correctly, but the baritone, bass, and lead midi files were all empty.

See attached.

Title Exporting parts from a score does not produce correct midi files when using voices to parts Exporting parts from a score does not produce col rrect midi files when using voices to parts
Regression No Yes
Severity S4 - Minor S2 - Critical
Priority P0 - Critical

Does this happen with File > Export parts (with main score being the active tab) or also on File > Export (with any of the parts being the active tab)?

Title Exporting parts from a score does not produce col rrect midi files when using voices to parts Exporting parts from a score does not produce correct midi files when using voices to parts

In reply to by Jojo-Schmitz

When the active tab is on each individual part, the exact same result happens.

  1. Load score (see attached)
  2. Click on "tenor"tab-->file>export part--midi
  3. Click "lead" tab-->file>export part--midi
  4. Click on bass tab--file>export part-->midi
  5. Click on baritone tab--file>--export part-->midi

The only midi file with any midi information in it is the tenor. The rest of the files have no midi content or at least no playable content.

Attachment Size
4_staves midi output test.mscz 7.97 KB
Title Exporting parts from a score does not produce correct midi files when using voices to parts Exporting parts from a score does not produce correct midi files
Title Exporting parts from a score does not produce correct midi files Exporting parts from a score does not produce correct MIDI, MP3, WAVfiles
Title Exporting parts from a score does not produce correct MIDI, MP3, WAVfiles Exporting parts from a score does not produce correct MIDI, MP3, WAV files
Title Exporting parts from a score does not produce correct midi files Exporting parts from a score does not produce correct MIDI, MP3, WAV files

That's why I changed the title...

Title Exporting parts from a score does not produce correct MIDI, MP3, WAV files Exporting parts from a score does not produce correct midi files
  1. Created score with four staves (4_staves_export_parts_test)
    Tenor
    Lead
    Baritone
    Bass

  2. Changed each part's instrument to "french horn" using mixer.

  3. Created separate parts.

  4. Used "export parts" feature.

I exported parts for all of the following audio formats: wav, mp3, ogg, flacc

They all produced the following results:

4_staves export parts test-Tenor file plays the tenor part in french horn and all other parts using piano.
4_staves export parts test-Lead file plays the lead part in french horn and all other parts using piano.
4_staves export parts test-Bass file plays the bass part in french horn and all other parts using piano.
4_staves export parts test-Baritone file plays the baritone part in french horn and all other parts using piano.

EDIT: Typo in first post. Sorry I did not mean to change the title I will fix it.

Title Exporting parts from a score does not produce correct midi files Exporting parts from a score does not produce correct MIDI, MP3, WAV files
Title Exporting parts from a score does not produce correct MIDI, MP3, WAV files Exporting parts from a score does not produce correct MIDI, MP3, WAV, OGG, and FLAC files.

I am going to change title to include the other audio formats.

Title Exporting parts from a score does not produce correct MIDI, MP3, WAV, OGG, and FLAC files. Midi and Wave exports do not work right.

I have 8 staves. For midi, only the first one listed ends up with midi data - but its midi data for all the staves! The other 7 midi files are empty. The wave files each come out with the audio from other tracks too but all the wave files are like this.

"Export parts" for audio files does not export parts but instead exports all staves, as is done in "Export". "Export parts" does export correctly for pdf files. This is a major problem for me. I'm using the most current version : 3.1.0.7078 revision: e26f7c4

In reply to by j623363

Same here, using 3.4.1 and Midi export fails - only 1 track is present when importing into DAW. In 2.3.2, this worked perfectly fine.

Unfortunately, I have not viewed any feature that will let me save my Musescore 3 file as Musescore 2, so I am buggered.

Status closed needs info

The original report was specifically about parts that were generated from multiple voices in the same staff. My guess is that this is still broken, along with several other things about generating parts from multiple voices on a single staff. But the normal case should work fine. Can someone verify this? If you see a way to reproduce a problem without using parts generated
From multiple voices on a single staff let us know precise steps to reproduce the issue.

But to be clear, 2.3.2 didn’t even have the parts from voices feature, so there is no way going back to 2.3.2 would help with that.

Meanwhile, I tried to reproduce a problem with the "Singing Funk" score attached above, and could not - it worked as expected. Here is what I did:

1) load score
2) File / Export Parts
3) choose MIDI as format
4) Save
5) load one of the exported MIDI files - I tried Electric Guitar

Result - as expected, it imported a single staff instrument containing the guitar part

So if you are seeing some sort of problem using this file, we'd need precise steps to reproduce the problem.

In reply to by Marc Sabatella

I have a score with a single staff for each voice (SATB), but on some measures this further splits to SSATTB, where both soprano/tenor voices are written in the same staff.
I can export each staff as mp3.
I can listen to each voice (soprano 1 and 2) separately muting the other one in the mixer.
When I keep these settings and file > export, the result is an mp3 with both soprano voices.

So I would confirm this bug still exists in 3.5
Or am I missing something?

In order to see if this is a bug or a misunderstanding about how it works, we would need you to attach a score showing the problem, and give us precise steps to reproduce the problem.

Fix version
3.2.0