Problem crescendoing after sfp

• Apr 15, 2019 - 22:08
Reported version
3.x-dev
Type
Functional
Frequency
Once
Severity
S3 - Major
Reproducibility
Always
Status
active
Regression
No
Workaround
Yes
Project

Experimenting with new single note dynamic feature in beta

Scenario 1 -
1) Tie two whole notes over two 4/4 measures
2) Add a sudden forte piano mark to the first note
3) Add crescendo to fortissimo on beats 5 - 8.
Result: Note accents and immediately drops in velocity, then increases back to fortissimo the next measure as expected

Scenario 2 -
1) Place an 8th note at the end of a measure, tied to a whole note the next measure.
2) Sudden forte piano on the eighth note
3) Crescendo on the following whole note to fortissimo.
Expected result: Volume would duck after eighth note and rise back to fortissimo the following measure
Actual Result: Volume ducks after eighth note and does not crescendo at all the next measure.

See attached musescore file for both scenarios Sforte piano- crecendo.mscz


Comments

Confirmed (3.1 beta too, using the MuseScore_General_HQ.sf3 soundfont). If instead a sfp (or sfpp, or fp) we attach a normal dynamic such a p or pp, the tied whole note plays correctly the crescendo in Scenario 2.

In this score, I have most instruments playing a whole note with an sfp + crescendo at measure 30, and the crescendo seems to have minimal effect in this situation Contraband.mscz
Edit: It seems as though the issue in this score can essentially be solved by adjusting the crescendo's velocity change attribute in the inspector

The problem is that the velocity change on the sfp is -47 which make it about mp, when I change it to -61 (a slightly arbitrary number putting it down around p) the volume on the whole note drops enough that the crescendo is noticeable back up to f.

In reply to by mike320

Trevor/Mike, I tested the problem (with the first attached score, Scenario 2), changing the sfp's "Change speed" Inspector property to "Fast" , and this way it plays ok that crescendo.

At "Normal" or "Slow" speeds, with the tempo in the score (120 bpm) it seems the synth simply have not enough time to develop the crescendo. If you add a Tempo mark (to 40 for example) to the eight, and leave the default "Change speed" ("normal"), you will hear the crescendo ok.

The crescendo is more noticeable applying the change cited by Mike (the "Velocity change" adjust). I think this precise situation just require these kind of tweaks.