User fonts not visible to MuseScore 3 (Windows 10)

• Dec 18, 2018 - 10:53
Reported version
3.0
Type
Functional
Frequency
Few
Severity
S3 - Major
Reproducibility
Always
Status
active
Regression
No
Workaround
No
Project

Hi,
a lot of (text) fonts are missing in MuseScore 3. At first I thought that only a certain type of font would be affected (e.g. only OTF or TTF, age of fonts etc.), but that doesn't seem to be the case.
By the way, in MuseScore 2 the "disappeared" fonts are available.

OS: Windows 10 (10.0), Arch.: x86_64, MuseScore version (64-bit): 3.0.0.4516, revision: 59a11cd


Comments

Status active needs info

MuseScore 3 has the same fonts built in asd 2.x (only one exception, MuseJazz Text has changed), and otherwsise both additionally use the fonts installed on the system.

Which font(s) in particular are you missing

To be clear: MuseScore includes only a small handful of font itself - FreeSerif, FreeSans, Emmentaler, Bravura, Gonvill, and MuseJazz (I think that is the complete list, maybe I forgot one). Any other fonts you see listed are not provided by MuseScore but by your own system. Any font generally available on your system should be available to MuseScore. Are you by chance testing MuseScore on a different system that you are using for MuseScore 2?

Sorry, I wasn't talking about the fonts installed by MuseScore. MuseScore 3 was installed on the same system as MuseScore 2. Does this cause problems?
I now have both versions installed on a Mac as well. There are fewer fonts installed on this machine, all of which ( spot check ) are available under MuseScore 3. So it seems to be rather a Windows specific problem.
The question now is, which developer voluntarily installs countless fonts to check this?

There should be no problem having MuseScore 2 & 3 on the same system.

So, it sounds like you are saying there is some font that is installed normally on your machine and visible to other applications including MuseScore 2, but not visible in MuseScore 3? If so, then we would need you to attach that font file in order for us to investigate. Even if there is more than one, just attaching one should allow us to test. Could be some sort of incompatibility with the libraries we use, I guess.

@Jojo-Schmitz
I wanted to use a font called "Bodoni BT", which came with an really old version of Corel Draw. But there are so many other installed fonts not available, for example the Ubuntu font family (https://fonts.google.com/?query=ubuntu), to name a font that is slightly newer, which can be freely downloaded for test purposes.

And you're saying that this font / these fonts are available to MuseScore 2 but not in MuseScore 3 on the same computer?
I see Bondoni MT on my computer (Windows 7) in MuseScore 3, no Bondoni BT though

Can you please link to one specific file I can download and install in order to reproduce the problem? As you suggest, we can't very well download hundreds of fonts testing each to see if they cause problems.

In reply to by Marc Sabatella

@Marc Sabatella: above is a link to the also missing Ubuntu fonts.... ok, here it is again: https://fonts.google.com/?query=ubuntu

@Jojo-Schmitz: same computer, yes. Bodoni MT is installed as well on my system, but not available in MuseScore 3. My operating system is Windows 10 (1809).
Maybe there are too many fonts installed (I'm a fontoholic), but they are accessible in MuseScore 2, so this can not be the reason.

Just tested: additionally I still have a MuseScore 3 Alpha version on my computer. In this version the "lost" fonts are visible. If one selects e.g. Bodoni BT in the font menu below, then the font changes, but is immediately reset as soon as the text is no longer marked.
It is the following Alpha version:
OS: Windows 10 (10.0), Arch.: x86_64, MuseScore version (64-bit): 3.0.0, revision: 3abd82b

I did see that link, thought it was a general link to all fonts shipped with Ubuntu (Linux), sorry I misunderstood. Anyhow, I just tested Ubuntu Regular with a build from this morning and it works fine for me Windows 10). You installed Ubuntu Regular in the normal Windows way as opposed to the special Google way?

In reply to by Marc Sabatella

I was almost afraid of that. The only question is, why does it work with MuseScore 2, but not with 3? In addition, the fonts are also displayed in the alpha (see above).
After reinstalling Windows, I simply copied the fonts into the corresponding directory (c:\windows\fonts). I didn't use the Google specific installation (Skyfonts?).
I will try MuseScore 3 Beta on another computer with Windows 10 and gradually increase the number of fonts installed there.

Hard to say why the alpha might display differently than the beta, but I wonder - is merely copying to the fonts folder always good enough? Did you try an actual install?

I have now researched again, using a new installation of Windows 10 (1809), on which only the system fonts, fonts of some programs and those fonts that I often use in MuseScore were installed.
The fonts I installed were installed using the Fonts option in the Control Panel (drag and drop). These fonts were again not visible in MuseScore 3. Worse still, they weren't visible in Scribus 1.5.4, Inkscape 0.92.3 or Gimp 2.8.22, but in MuseScore 2 and LibreOffice 6 (of course also under Windows 10's Fonts dialogue). Then I copied these fonts with a file manager (Free Commander) directly into the Windows’ font directory (C:\Windows\Fonts). Strangely enough, there was no indication whether the fonts should really be overwritten, i.e. they were not yet in this directory. After this action they were suddenly available again in Scribus, Inkscape etc., but still not in MuseScore 3.
In the Control Panel, I selected one of these recalcitrant fonts and checked its properties to see if this font is actually stored under "C:\Windows\Fonts". It wasn't there! It was in "C:\Users[Username]\AppData\Local\Microsoft\Windows\Fonts". This is probably where all user-specific fonts end up. By right clicking I selected a font and selected "install for all users" and voilà, they were now also usable in MuseScore 3. Of course, I now have to install many more fonts in this way to test if the amount of fonts installed also plays a role. By the way, some fonts can also be obtained from the Microsoft Store. These again end up somewhere else, but were available in MuseScore 3. It makes sense to also display user specific fonts, which is really a bug in MuseScore 3, because in other open source programs (Inkscape, Scribus, Gimp...) it works. LibreOffice 6 + MuseScore 2 had the least problems, there the installation method didn't matter.

P.S. MuseScore 3 as a gift just in time for Christmas was a nice idea, but I would have wished for a longer beta phase. The final polish is missing. And the menu icons are worse than those of version 2 (to say it again (won't stop)). An appealing appearance also plays a role in whether you like to use software - OK, I still like it, thanks for all the work! - but with the program icon and the splash screen, you finally put more effort into it! Well, I'll stop here... there would be even more. I'll report more bugs at the right place, if that hasn't happened yet. Happy new year to all of you!

Title Missing fonts in MuseScore 3 Beta (Windows 10) User fonts not visible to MuseScore 3 (Windows 10)
Regression No Yes
Status needs info active
Workaround No Yes

So it is a regression vs 2.x and there is a workaround.
The cause probably is to be looked for in the Qt version we use, 5.4 for MuseScore 2.x, and (currently) 5.9 for MuseScore 3 (hopefully soon Qt 5.12), as this should be doing the font handling.

In reply to by Jojo-Schmitz

In any case, "font installation for non-admin users" is something that Microsoft introduced with Windows 10 1809 (October update). I was really surprised that there is now an extra folder for user fonts and that installing them in the proven way by drag and drop or copy didn't work for all applications anymore, which is why I googled again after possible changes in the last release of Windows 10:
https://blogs.windows.com/windowsexperience/2018/06/27/announcing-windo…

Regression Yes No
Workaround Yes No

I also have a font missing from MuseScore 3 (that worked in MuseScore 2), specifically this one: https://www.dafont.com/es/lemon-milk.font

The problem in my case is not the font not being installed for all users (it's actually in C:\Windows\Fonts), and I haven't been able to replicate the problem with any other font, though this font does NOT give me any problem in any other application...

I'm using W10.

(I reported this here https://musescore.org/en/node/282501 as well)

In reply to by frjurado

It doesn't work for me either (Windows 10, 1809). Some fonts might cause problems. In the German forum there was the problem with the font Nyala.ttf and this font was even part of the pre-installed fonts of Windows 7 and 8.
Maybe it has something to do with how a font was created. If you open your font (Lemon Milk, which somehow reminds me of the font of the Nivea brand) with a double-click, it says that it is of the type PostScript contours. Of course this doesn't help. If the font is very important, it helps to use only MuseScore 2 at the moment.

In reply to by enkidu

"By right clicking I selected a font and selected 'install for all users' and voilà, they were now also usable in MuseScore 3." Could you elaborate on this? I'm using Windows 10, but when I right-click a selected font, there is no such option that says "install for all users." I'm having the same problem where certain fonts that I had on MuseScore 2 are not usable on MuseScore 3 because the whole font just turned in white rectangle boxes.

In reply to by SirArsen

Hi, the option to install one font for all users is brand new in Window 10 in version 1809, which was the last major official update of Windows 10 last October. Unfortunately, it's no longer enough to just talk about Windows 10, the version used is just as important (the version can be found under Settings, then System and there under Info). There are also fonts that cannot be used with the option "Install for all users". Among them are also fonts that worked under MuseScore 2.
Which font doesn't work for you? If it is a font that can be downloaded for free, then I'll try it out. Sometimes you only see white boxes if it is a Unicode font with special characters that cannot be displayed correctly in the list of fonts in MuseScore. Or it is a symbol font that has no letters. The fields reserved for the letters are then empty, which is why nothing can be displayed in the font list.

In reply to by enkidu

Downloaded the update, reinstalled the fonts with "Install for all users", go to MuseScore 3, and I get nothing. So I'll provide a link to a folder with all the files and see if anyone can do anything about it. I don't understand how MuseScore 2 has no problems with fonts at all, yet they're not compatible in MuseScore 3 in any form, it makes no sense. One thing I noticed however is that JazzText has a lowercase "ttf" file type, while the rest have capital "TTF" file types, and the only one that works on MuseScore 3 for me is JazzText, maybe that's just a coincidence though as they all still identify as TrueType font files.

https://drive.google.com/open?id=1Foh1CwGQihM89ufL0uuVXfEPpYERY14S - JazzFont Folder

I'm afraid that's another problem. There is a thread (https://musescore.org/en/node/281905) about it and it is actually a bug in MuseScore 3. I also tried it with the last developer version (https://ftp.osuosl.org/pub/musescore-nightlies/windows/), even there the bug still exists. The Jazz fonts are installed with MuseScore and should actually work, strange that nobody came across this bug before the release. If you absolutely need the jazz font, then you have to switch to MuseScore 2.

Same problem here with Papyrus font. Installed, shown in Windows fonts list, working in LibreOffice, Band-In-A-Box as song text font, and in MuseScore 2. But not visible in MuseScore 3. Please, erase this bug. Thanks a lot.

Attachment Size
papyrus.zip 173.21 KB

It seems to be a bug in Qt, so we need them them to fix it, rhem wait on Travis amd AppVeyor to provide the fixed libs, then switch to using the fixed version in our builds of MuseScore.
Unless someone finds a clever workaround.

In reply to by Jojo-Schmitz

As I stated in another thread: according to Qt issue tracker, the Windows 10 (1809) font bug has been fixed since version 5.12.2 (https://bugreports.qt.io/browse/QTBUG-73241). Krita 4.1.7 seems to list all font types. Jazz font is displayed correctly and can be used as well as other problem fonts that have been listed here. Wouldn't it be possible to use Qt 5.12.2 or higher for MuseScore for Windows? Maybe another fontengine is used in Krita? And perhaps you could ask Krita & Co team what they use exactly or what they do differently.

I can't confirm that:
Font_Test.png
I'm using Windows 10, 1809. I think with Windows 10 it ist very important to mention the version as well. This should be part of the information you can copy out of MuseScore (if MuseScore is able to retrieve this information).
As I said in Krita, it works:
krita_4.1.7_fonts.png
As someone from the Qt issue report mentioned above said, it seems to work with the "default font engine" (whatever that means, of course I don't know what you're using, nor how it works in Krita):
Mårten Nordheim added a comment - 28 Jan '19 9:50 AM
Tested locally with the fontsampler example and reproduced for the freetype engine, with the default fontengine I see the user font I installed.

@enkidu : it is actually easy to test the default Windows font engine. You simply need to delete the lines
[Platforms]
WindowsArguments = fontengine=freetype

from file qt.conf inside MuseScore bin folder (i.e. the folder where you can find MuseScore3.exe).
(Maybe make a backup copy of qt.conf before modifying it)
Those lines were added to use the freetype engine and solve bug #276566: [Windows] underline too close to (lyrics) letters, as well as have the same text behavior (spacing, etc.) as the one under Linux, but apparently freetype engine inside Qt has a series of bugs, see also #281601: Musescore 3 FreeSans bold text rendering is bad. One big problem is that I don't think we can have an alternative font engine under Linux.

@ABL: 👍 I did what you said and in fact if you turn off the freetype engine, those font problems are gone:
Font_Test_MuseScore_Dev,_Qt_5.12.2_freetype_off.png

For people who want to use MS3 and depend on certain non-working fonts, this would at least be a workaround.
I can still remember the problems with kerning in the Windows version. But in my opinion non-functioning fonts are even worse. The question is how other Qt based projects solved the problem. Krita will probably also use the default font engine, but I haven't tested whether kerning is bad there as well (for Scribus as a DTP program, for example, kerning certainly plays an important role, but they still use Qt 5.6.3).

In reply to by Jojo-Schmitz

What the Qt guys did fix was the problem of missing fonts if fonts were installed in Windows 10 1809 only for the current user. These fonts no longer end up in the usual Windows\Fonts directory.

This was the description of the Qt font issue with Windows 10 1809 (https://bugreports.qt.io/browse/QTBUG-73241), which was fixed in 5.12.2:

Windows update 1809 introduced new location for system fonts. Previously the fonts were installed in all-users location C:\Windows\Fonts, but in Windows update 1809 the fonts are installed in user specific location C:\Users\UserName\AppData\Local\Microsoft\Windows\Fonts. Now, Qt cannot find system fonts on systems with Windows update 1809.

Steps to reproduce:

Install new font
Query fonts with QFontDatabase::families() or use Qt's Font Sampler example.
The newly installed font is not on the list

However, this has nothing to do with the second problem, that fonts do not appear at all, even if they have been installed for all users. The JazzText font installed with MuseScore appears, but cannot be used. If you switch off the Freetype engine, the JazzText works again and the invisible fonts (e.g. Nyala) reappear in the list.

Frequency Once Many
Severity S4 - Minor S3 - Major
Status active won't fix
Type Functional Graphical (UI)
Reported version 3.0 3.2

Hello!
I am having fontproblem on my Windows computers as well. It is Nyala that is the problem for me.
I've tried to take away the lines inside the bin folder as you suggested, but I'm not so good on computers so I didn't managed it. Is there some way to solve it for a none geek person? ;) I have version 3.2.3.7635 of Musescore.
/Veronica